Having problems with Anycubic Kossel Linear Plus calibration



  • I'm new to the Duet, love this board already - fast and it is possible to make configurations on the fly.
    Yet i have problems with calibrating my delta printer. It was initially on Marlin 1.1.9 and i even managed to get acceptable prints on it before.
    Now i have installed Duet board and moved to 24 V power supply. No changes to heat bed (except for wiring of course), MK3+Ultrabase. No changes to rods and carriages. Changed the heating cube and nozzle.
    Now i'm trying to calibrate using the original Anycubic Z probe (switch). Mesured it's trigger height: G31 P500 X0 Y0 Z15.893
    Trying to calibrate using 6-factor calibration. The results are not good: when i try to print, the printing goes too high from bed and plastic (PETG, 230 on hotend, 70 on bed) does not stick to bed at all. I try baby stepping going down to -0,13 - still not sticking. With babystepping -0.14 the plastick is smiply smashed into bed, it sticks, but won't go from bed after cooling and removing the print.
    Can you, please, help me out and point what i'm missing?



  • post your config. you might have not configured the thermistor correctly and therefore printing at the wrong temperature.



  • Here are config.g, config-override.g and bed.g.
    I tried to change bed temperature to 80 С with no success.
    Thermistor used on hotend is this one: HT-NTC100K
    2_1567334916468_config-override.g 1_1567334916468_config.g 0_1567334916467_bed.g

    BTW i'm on Firmware Version: 2.0(RTOS) (2018-06-05b3)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.6
    Do you think updating to 2.04 RC1 will do anything better?



  • does this happen for pla as well?



  • @veti yes, just the same with PLA



  • ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    this will disallow babystepping below 0 i believe



  • also you have 271.5 as the rod length. marlin has 267 for it.



  • Your steps per mm are wrong. These should be 80 and not 100.
    Are you using mesh compensation as well in case your bed is slightly tilted?



  • @veti Good point, will double check.



  • @veti Yes, Marlin has 267, i took 271.5 after one of the calibration attempts. Will change to 267 and try again (actial measurements show 266.5, but not sure that those are really accurate as i was using just a metal ruler).



  • @jay_s_uk No, steps are correct, i'm using 16 teeth pulleys now, not 20 teeth as in the original build.
    Tried bed compensation - did not help.



  • Set L=267, recalibrated with S6:

    6:22:32 PMM666
    Endstop adjustments X-0.86 Y0.95 Z-0.09, tilt X0.00% Y0.00%
    6:22:27 PMM665
    Diagonal 267.000, delta radius 133.934, homed height 287.589, bed radius 115.0, X 0.517°, Y -0.986°, Z 0.000°
    6:22:11 PMG32
    Calibrated 6 factors using 16 points, deviation before 0.041 after 0.041

    Checked with S-1:
    6:28:52 PMG32
    G32 bed probe heights: 0.061 0.048 -0.070 -0.012 0.047 0.035 -0.052 -0.038 0.061 0.031 -0.060 -0.030 0.000 0.011 0.019 -0.029, mean 0.001, deviation from mean 0.043

    Checked that the nozzle goes to correct position: lowered nozzele to Z=0 and was hardly able to put paper between nozzle and bed (just as back then when i was on Marlin), so Z=0 is about 0.08 mm above the bed at center. Tried moving nozzle at Z=0 - height is about the same.

    Commented M208 Z0 S1 in the config.goes

    Tried printing PLA at bed 50C and hotend at 190C. Layer = 0.2, no offsets applied. Printing goes mid air.
    Tried using baby stepping. No changes till -0.2. With baby stepping = -0.2 plastic hardly sticks to bed but is moved away by the nozzle when it goes to the next line.
    Baby stepping = -0.22 made plastc smash into the bed.

    I really do not understand what's wrong...



  • @snakesp said in Having problems with Anycubic Kossel Linear Plus calibration:

    really do not understand what's wrong...

    while printing do a M122 and show us the output. just to make sure that no mesh bed leveling is active.



  • @veti said in Having problems with Anycubic Kossel Linear Plus calibration:
    7:03:57 PMM122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.0(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-9T6BU-FG3SW-6J1FG-3SS6L-KBTHH
    Used output buffers: 3 of 20 (15 max)
    === RTOS ===
    Static ram: 28380
    Dynamic ram: 95920 of which 16 recycled
    Exception stack ram used: 372
    Never used ram: 6384
    Task NETWORK ready, free stack 396
    Task HEAT blocked, free stack 1256
    Task MAIN running, free stack 3624
    === Platform ===
    Last reset 00:18:40 ago, cause: software
    Last software reset at 2019-09-01 18:45, reason: User, spinning module GCodes, available RAM 6384 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0041f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 56.2, current 56.4, max 56.6
    Supply voltage: min 23.2, current 23.9, max 24.3, under voltage events: 0, over voltage events: 0
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max 75/194
    Driver 3: ok, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-09-01 19:03:55
    Slowest loop: 174.92ms; fastest: 0.08ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 228, MinFreeDm 213, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 56, completed moves: 53
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.1
    Heater 1 is on, I-accum = 0.2
    === GCodes ===
    Segments left: 1
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is doing "G1 X9.475 Y-40.525 F900" in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 3.74ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 338, notready 0, noresp 0
      WiFi firmware version 1.21
      WiFi MAC address 4c:11:ae:02:e3:cf
      WiFi Vcc 3.33, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 16200
      WiFi IP address 192.168.1.37
      WiFi signal strength -70dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0
      === Expansion ===

    M122



  • @snakesp said in Having problems with Anycubic Kossel Linear Plus calibration:

    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.0(RTOS) running on Duet WiFi 1.02 or later

    you are using a very old version of the firmware. just to rule out any problems there update to 2.04RC1

    but the problems comes down to this? with marlin pla sticks on the ultrabase. with duet it does not?



  • @veti Simply put, yes, with Marlin prints were ok, with Duet plastic does not stick (not only PLA, PETG also).
    But i'm almost sure this is due to i'm doing something wrong.
    Will try updating to 2.04 RC1 today and recalibrate.
    Also it may occur that thermistors are configured incorrectly (hotend thermistor is changed from original one, but the bed is the same except changing it to 24V).
    Possibly bed or hotend or both produce lower temperature than expected, but not sure how test this. But on the other hand PLA should stick even to cold bed.



  • @snakesp said in Having problems with Anycubic Kossel Linear Plus calibration:

    lowered nozzele to Z=0 and was hardly able to put paper between nozzle and bed

    this means that your offset is wrong btw. if there is space between the nozzle and bed for paper, then z=0 is not z=0 rather something like z=0.1+movement space.



  • what thermistors have you configured in marlin?



  • @veti
    Current Z probe offset is Z15.791, do you mean i should change it to 15.891 ?
    It was
    5 : 100K thermistor - ATC Semitec 104GT-2/104NT-4-R025H42G (Used in ParCan & J-Head) (4.7k pullup)
    in Marlin, but that was original Anycubic thermistor. Same one for the bed.



  • that is significantly different.

    semitec is B4725 C7.060000e-8



  • @veti Yes, you are right, looks like i really need to change B from 3950 to 4725 at least for the bed thermistor, but what about the hotend thermistor? It is different from the bed one. And should i use С parameter?
    And about Z offset for the probe: should i change it to 15.891?



  • @snakesp said in Having problems with Anycubic Kossel Linear Plus calibration:

    And should i use С parameter?

    yes without that the B parameter is wrong.

    for the offset. what i do is do a first layer print. if i need to adjust it with microstepping to get a good first layer i update the offset with the microstepping used.



  • The firmware upgrade guide tells to update not only the firmware itself, but DuetWiFiServer and DuetWebControl.
    WHATS_NEW.md for 2.04RC1 says, that compatible files are:
    DuetWiFiServer 1.23
    DuetWebControl 1.22.6 or 2.0.0-RC6 or 2.0.0-RC7

    But i cannot find those files. Can you point me where to get those?
    And also a question: what is an appropriate order to upgrade firmware? Upload all 3 files to /sys through Settings-General-Upload files declining update offers and run M997 S0:1:2 after that, correct? Will it preserve my network settings or i'll need to connect using usb and terminal to restore those?
    Nevermind. Found those:
    WiFiServer in 2.0.3 release
    WebControl



  • Results so far:
    updated firmware
    changed bed thermistor to B4725 C7.060000e-8
    recalibrated with 15.881 (recalibrated Z probe, at Z=0 no paper can be placed under the nozzle)
    tried printing

    1. 190C 50C babystep=0 - no sticking to bed at all
    2. 190C 50C babystep=-0.5 - partially sticking, corners not sticking
    3. 190C 50C babystep=-0.8 - smashed into the bed
    4. 200C 60C babystep=-0.5 - better sticking, some corners not sticking
    5. 200C 60C babystep=-0.6 - same
      But when trying to print at center of the bed - no sticking until babystep=-0.12 at all

    Looks like the calibration is still not consistent, although with S-1 it reports height deviations less than 0.07:
    G32
    G32 bed probe heights: 0.056 0.037 -0.068 -0.010 0.041 0.026 -0.060 -0.038 0.058 0.032 -0.059 -0.034 -0.000 0.021 0.029 -0.031, mean -0.000, deviation from mean 0.042

    Thoughts:
    either calibration is still incorrect or temperature is still incorrect.



  • can you check with 7 factor what the rod length is calculated to be.
    and maybe try 8 factor.
    https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer


Log in to reply