7inch Paneldue showing only 6 heaters, doesn't show 7th

  • Hi,

    Panel due showing only 6 heaters but i am using Heater 6 and 7 , 7th heater is not showing in Panel

    and i done want to see heaters 1 to 5

    please suggest how to configure.

  • Please can you give us a little more information.
    What it is you are trying to achieve, Printer / CNC / other and most importantly your config.g

    I am taking a guess from the screen that you have a Duet2 and Duex5 possibly?
    Could you not wire your heaters into the first 2 heater ports.


  • Moderator

    I think it is showing them all, it just can't cope with that number of heaters on the display. There's a double 2 on the 5/6th heater, which is probably the missing one. If you can sort out the settings on the other heaters so they don't show 2000.0C, it may reduce the width of the columns so you can see all of them.


  • I had a similar thing when I thought I had an issue with E0, I used E1 instead.
    On my paneldue, it showed both E0 and E1 even though only E1 was showing in the DWC.
    It seems to not respect what tools are actually created and assumes the preceding ones are in use.

  • @PaulHew I am using it as 3D Printer, and using Duet Expansion Board and there is PWM Heater 6 and 7 only, i want to use PWM heaters with my SSR.

  • @droftarts I dont know know to remove unwanted heaters or make it 0 instead of 2000.0C, anyone can help me out with this.

  • administrators

    PanelDue isn't designed to support so many heaters. However, my understanding is that you are actually only using 2 heaters, which are the heater 6 and 7 outputs. So one solution is for you to switch to using RepRapFirmware 3, which allows you to map any heater to any available port. This means you can map heaters 0 and 1 to outputs 6 and 7. See https://duet3d.dozuki.com/Wiki/RepRapFirmware_3_overview if you want to try this.

Log in to reply