Blinking bltouch



  • I took a couple weeks off of printing and when I tried to fire up the printer (coreXY) i got the flashing bltouch. I had been using it for quite some time and nothing has changed since it last worked.

    • I checked all the wiring and I get good continuity from the Duet all the way to the BLtouch (i checked using the pins under the connector on the BLTouch). All was good and no cross connections.

    • I have a second BLTouch I bought for another project but have not used yet and got exactfly the same blinking results.

    • I read through many messages on this forum but did not find any that were instructive for my problem.

    I am at a loss as to were to go from here. Any suggestions?



  • Does it initialise at power on? Out - in, out - in?

    A couple of users have had an issue 'similar' to this and it was one of the wires, had a break in the cable when it was at a particular angle.

    HTH Paul.



  • Check to see if the pin is not binding, even slightly. I had that and found a very slight bend that may have happened at some probe gone wrong. Once I bent it a little bit to remove the stiction, it was fine. also check the grub screw at the end to see if it may need turning to ensure better retraction.



  • Two very good suggestions, I have a usb microscope and will test for bent pins and intermittent wire breaks later today and post here.

    Thanks
    Charlie



  • I checked continuity on all the wires while twisting, bending and wiggling and could not see any breaks in continuity.

    I checked the pins on both the BLTouch and the Duet wifi and found nothing that looked at all questionable.

    It would seem that these two finds are supported by the fact that I have changed the wires and the BLTouch to now effect.

    I seem to be back to zero. Still can't figure out what to try next.



  • You did not say if the probe did its initialise sequence when powered on from cold.

    Post your config.g please.

    Also, you have not got the same issue with the black and white as you did on your previous post?

    P.



  • I get this a lot with my BL Touch. Its always been been the connectors (I use latched Dupont connectors at the hot end side). You could just cut off the connectors and solder a wire all the way back to the duet to eliminate them. What I found worked very well was a 3 x 2 standard block Dupont Connector (not latched) that I used to connect the 3 logic pins to the 50Pin Male connector on the Duet Wifi board (Orange Brown and yellow). It will be these three pins that will be causing the problem.
    If you have used the connectors at the hot end side ... the cable they provide is very thin (shit actually) and hard to crimp reliably. I soldered and heat shrinked some solid core wire and used that wire to crimp pins for the connector. It mostly fixed my issue.

    FYI Continuity testing dose not always pick up the issue if is a broken pin barb on the connector it can get pushed back in the housing if that's broken and you don't spot that when you continuity test further up the pin on the exposed bit where the barb latches. What happens is that when connecting male to female the broken pin gets pushed back and makes a very poor contact.

    Good luck this drives me nuts too.



  • @PaulHew : it does not do the down-up-do wn-up thing at power up. Just starts flashing. Every time I’ve run intoan issue like this, it has been the wiring, but I am quit sure I have the correction wire connections this time. (Checked it a dozenn times).

    @simonboydfoley : one of the first things I tried was toI eliminated the connector on the hot end side by purchasing the longer cable from antslab/amazon, so the only connectors are on the Duet end. I checked continuity and resistance on all five wires and found no problem.

    I guess I will try eliminating the antslab wire back to just before the BLT and solder in a little more substantial wire (22 or 24 aug). I am not real optimistic that will solve it, but I guess it’s worth a try.

    Keep in mind that this has been working perfectly until one morning when it wasn’t, no changes from the last time I printed until I discovered the problem.



  • @crchisholm said in Blinking bltouch:

    it does not do the down-up-do wn-up thing at power up. Just starts flashing.

    That means it's trying to do the up down up down test but the pin is getting stuck.

    The pin can be removed and cleaned by removing the set screw on the top of the unit.



  • @Phaedrux I will check the pin on both. I did check for freedom of movement by gently pulling the pin out and in on both BLTs, though.

    BTW, your hardware list is very interesting and I am sure it will provide me with many wonderful things to be confused about. 🤪



  • I checked the resistance between each of the lines from connector to connector and they are all at 0.5 ohm.

    I plugged the cable into the Duet and checked the voltage between the black and white on the two position and it was 3.27v . The voltage between the black and red was 5.0v.

    I checked the resistance on a piece of 24 awg stranded wire and it was also .4 ohms which I take to mean that the difference between ANTCLABS wires and a 24 awg is less than 0.1 ohm. This tells me that that swapping out the wire with a 24 awg would probably be a waste of time.

    One thing a bit troubling is that I am plugging and unplugging the power on the printer and there is an audible pop at the plug. It seems pretty loud, but I am not sure if that indicates a problem or not. The p/s normally plugs into a switched outlet, so if it was popping before, I wouldn't have heard it. The board in every other respect performs as I would expect....connects and allows movement of axis's. I would think that would more likely be an issue with the p/s, if it's an issue at all.

    The pin in both BLTs moves in and out very freely, so I don't think there is any problem there. I guess both BLTs could have a problem with the hall effect chip, but if they both went bad at the same time, I should buy lottery tickets.



  • @PaulHew Sorry, I forgot to post my config.g. Here it is...

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Fri Feb 01 2019 16:04:24 GMT-0500 (Eastern Standard Time)
    
    ; General preferences
    G90                                                ; Send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    
    M667 S1                                            ; Select CoreXY mode
    
    ; Network
    M550 P"Core XY"                                    ; Set machine name
    M552 S1                                            ; Enable network
    M587 S"BHNDVW3201B4B28_5GEXT" P"3c5d116a"                ; Configure access point. You can delete this line once connected
    M586 P0 S1                                         ; Enable HTTP
    M586 P1 S0                                         ; Disable FTP
    M586 P2 S0                                         ; Disable Telnet
    
    ; Drives
    M569 P0 S0                                         ; Drive 0 goes backwards
    M569 P1 S0                                         ; Drive 1 goes backwards
    M569 P2 S1                                         ; Drive 2 goes forwards
    M569 P3 S0                                         ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1                            ; Configure microstepping with interpolation
    
    M92 X80.5369 Y100.7067 Z399.9219 E416.666      ; Set steps per mm
    
    M566 X900.00 Y900.00 Z150.00 E857.1428                ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y6000.00 Z380.00 E1500.00           ; Set maximum speeds (mm/min)
    M201 X3000.00 Y500.00 Z100.00 E10000.00            ; Set accelerations (mm/s^2)
    M906 X950.00 Y950.00 Z950.00 E950.00 I30           ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; Set axis minima
    M208 X300 Y270 Z300 S0                             ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z1 S0                                      ; Set active low and disabled endstops
    
    ; Z-Probe
    ;M574 Z1 S2                                         ; Set endstops controlled by probe
    ;M558 P5 H5 F0 T6000                                ; Set Z probe type to switch and the dive height + speeds
    ;G31 P500 X0 Y0 Z0                                  ; Set Z probe trigger value, offset and trigger height
    ;M557 X15:13 Y15:195 S20                            ; Define mesh grid
    
    ; Heaters
    M305 P0 T100000 B4138 R4700                        ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                                       ; Set temperature limit for heater 0 to 120C
    
    M305 P1 T100000 B4725 C7.06e-8 R4700				; as suggested by Phaedrux
    ;M305 P1 T100000 B4388 C7.06e-8 R4700			; As suggested by mudcurxzr
    ;M305 P1 T100000 B4138 R4700                        ; Set thermistor + ADC parameters for heater 1
    
    M143 H1 S280                                       ; Set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700                        ; Set thermistor + ADC parameters for heater 1
    M143 H2 S280  
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1                           ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                          ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                                      ; Define tool 0
    G10 P0 X0 Y0 Z0                                    ; Set tool 0 axis offsets
    G10 P0 R0 S0                                       ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss
    
    ;  Attempt to control heater2
    M307 H2 A-1 C-1 D-1 ; Disable Heater E1 for use with the Berd-Air cooling
    M106 P0 A2 S0 F30000 ; Fan 0 (Part Cooler) using Heater E1 Mosfet; Custom settings are not configured
    
    ;  BLTouch code
    M557 X30:290 Y30:290 S112
    G29 S
    M307 H3 A-1 C-1 D-1
    M558 P9 H5 F100 T2000
    G31 X30 Y15 Z3 P25
    ;G31 P500 Z1
    G31 P500 Z2.63
    M375						; load "heightMape.csv"
    
    
    


  • M122 as well, please



  • @PaulHew

    M122 return....

    12:33:51 PMM122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917NK-F23T0-6J9FL-3SD6R-KDB0F
    Used output buffers: 3 of 20 (11 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98660 of which 0 recycled
    Exception stack ram used: 280
    Never used ram: 6608
    Tasks: NETWORK(ready,544) HEAT(blocked,1232) MAIN(running,3844) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:04:22 ago, cause: power up
    Last software reset at 2019-09-15 18:22, reason: User, spinning module GCodes, available RAM 6340 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 30.9, current 37.4, max 37.6
    Supply voltage: min 23.6, current 23.7, max 23.8, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-10-06 12:33:46
    Cache data hit count 973540141
    Slowest loop: 2.50ms; fastest: 0.07ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: mesh
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 23.07ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    - WiFi -
    Network state is running
    WiFi module is connected to access point
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.22
    WiFi MAC address b4:e6:2d:53:00:09
    WiFi Vcc 3.40, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 28568
    WiFi IP address 192.168.0.11
    WiFi signal strength -54dBm, reconnections 0, sleep mode modem
    Socket states: 0 0 0 0 0 0 0 0
    


  • Firstly, what version BL Touch are you using, 2 or 3?
    Do you have another printer to test it with?
    Also do you have a ' config-override.g '? If you have please check it does not have a M307 H3 command in it.

    Secondly, may I suggest you update your firmware to at least 2.03.

    I have combined your 'BLTouch code' and 'Z-Probe' into one.
    It has the main commands I think to get you going.

    I am not saying it is perfect....... Just trying to help.
    ;New BLTouch
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F100 T2000
    G31 X30 Y15 Z2.63 P500
    M557 X30:290 Y30:290 S112

    Have you tried this again?
    https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Software_setup_Duet_2_WiFi_Ethernet

    The BLT not doing its probe test on power up is the mind boggling thing.

    P.



  • @crchisholm said in Blinking bltouch:

    G29 S
    M375 ; load "heightMape.csv"

    It's best to NOT load the heightmap in the config.g since at power up the Z0 point hasn't been located yet. Better to add it to the end of homeall or to the slicer start gcode as long as it's after the Z axis has been homed using the probe.

    If you upgrade to firmware 2.03 it will complain that the heightmap has been loaded before the Z 0 datum has been established.

    If the BLTouch problem seems to follow the board and not the probe itself then there is either something wrong with the board connectors or wiring.



  • I just went through the same issue. I rewired and still had the same problem even thought my bl would be able to drop and lift the pin. I could even probe without any problems. It would just always flash. I ended up removing the top grub screw and seeing how well the pin could move. I found that there was just the slightest resistance as it moved. It could still move on its own but it must be able to tell if there is any lag or hesitation. I used a replacement pin and still had the same issue. I ended up cleaning up the hole at the end of the bltouch body and that seemed to fix the issue. The bl should be able to self test without the duet giving it commands when you first power up. If you are into radio controlled models or drones you can plug it into a receiver and see if it works. Its just a fancy servo after all.



  • yep. I took the pin out and checked it out. There was absolutely no resistance. If I turned the BLT upside down, the pin will fall out with no effort.

    I also re-terminated the connectors on the Duet side of the cable and looked at them under the USB microscope and they are exactly as they should be.

    And yet, it only flashes and does not initialize.

    I will look more closely at the changes that @Phaedrux and @PaulHew suggested tomorrow.

    I am really baffled. I always hope that it's something that I am doing wrong. That's been the case in the past, but I have been over this over and over and over and I can't find it.



  • @crchisholm i would say hit them up. They are a little slow to respond but they may work out a replacement for you. antclabs@gmail.com



  • the only thing I HAVE NOT changed is the Duet board. I have ....

    • tried three versions of the cable.
    • tried two BLTouches...one that has never been used before now.
    • checked all the connectors
    • checked continuity and resistance on all wires (all wires show 0.4 oms)
    • Looked at the pins on both the Duet and the BLT with a usb microscope. All looked good (no bends or discoloration)
    • tried all the code changes suggested.
    • probobly a few other thing I can't remember now.

    The only thing that has been constant through the whole ordeal has been the problem and the Duet board itself.

    Has anyone experienced a problem with the BLT and found that there was an issue on the Duet board itself?

    I can't really afford to buy another Duet board. I might buy another BLT, but am afraid that's another rabbit hole. Also, this problem went from working perfetly and then not working at all with no changes in between other than not printing for a few days.

    Frustrated in Florida!


Log in to reply