Extruder 0 reports little movement



  • I have started to get the error, "Extruder 0 reports little movement" at the beginning of a print. Everything would heat up, It would do a line or two of purge, then it would flash the error and the print head would go to the upper left corner of the bed and stop. It .Just started out of no where. I have the extruder calibrated so I am getting almost exactly 100mm on a 100mm extrusion command. I tried using a new start gcode in Cura, but that didn't change the result either. I have included the M592 D0 results, my config.g file and the starting gcode from the file in question.

    Thanks for the help!
    Pat

    M591 D0
    Duet3D laser filament monitor v1 on input 3, enabled, allow 10% to 300%, check every 3.0mm, no data received

    Config.g
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Sep 06 2018 21:21:12 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 Pe3 ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400 E95 ; Set steps per mm
    M566 X1000 Y1000 Z100 E30000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000 Y6000 Z500 E1500 ; Set maximum speeds (mm/min)

    M201 X300 Y300 Z100 E5000 ; Set accelerations (mm/s^2) was 500 you changed it to 300 for stall guard
    M906 X500 Y500 Z500 E1000 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout

    ; Axis Limits
    M208 X-5.5 Y-10 Z0 S1 ; Set axis minima
    M208 X258.5 Y246 Z260 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M307 H4 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M307 H1 A373.9 C115.3 D4.9 V23.8 B0
    M307 H0 A126.1 C599.1 D0.4 V23.0 B0
    M558 P9 H2.5 F120 T6000 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X-31 Y0 Z3.457 ; Set Z probe trigger value, offset and trigger height
    M557 X50:185 Y50:185 S65 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S345 ; Set temperature limit for heater 1 to 345C

    ; Fans
    M106 P0 S0 I0 B0.5 F250 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 B0.5 F500 L255 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Minimum Speed is 1/3 aka 87 Thermostatic control is turned on triggered at nozzle temp 45;
    M106 P2 S0 I0 B0.5 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings
    M591 D0 P5 C3 R10:300 E3.0 S1 ; Duet3D laser sensor for extruder drive 0 is connected to endstop input 3 (E0), tolerance 10 to 120%, 3mm comparison length

    Starting GCode
    ; Ender 3 Custom Start G-code
    G28 ; Home all axes
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    ; End of custom start GCode



  • I guess the issue is with your laser monitor.
    Which firmware version are you on?



  • Interesting thing is I don't have a laser monitor hooked up and not even sure what it is. I would assume it monitors filament run out.

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.04RC3 (2019-10-08b3)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6



  • @BearcatTD Well then I would comment it out and try again



  • Thanks! What file is this located in?



  • @BearcatTD M591 in the config file



  • Duh...LOL. Thanks Jay!


Log in to reply