Stuttering and vertical lines in print



  • Hey guys,

    after solving nearly all my other problems, I'm coming to the next - and last - one I hope. When printing bigger parts, I was getting some vertical lines in print, first I thought that would be retract, but it wasn't. When printing longer straight moves, the printer is kind of stuttering. He stops very very short and continues the line. In the picture you can see, that he is doing this only on longer lines in solid bottom layers. In the corners with short ways there is no bloob and no problem. In the solid infill you can see the same patterns (where he stuttered) as in the outlines... I tried different jerks and ACC's, I also decreased the current dramatically...

    Maybe someone can help me in here. Have a nice evening!!!IMG_20191116_180440.jpg

    IMG_20191105_162510.jpg

    This is my config.g:

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Thu Oct 17 2019 16:50:41 GMT+0200 (Mitteleuropäische Sommerzeit)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Soldex AM8" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S1 ; enable Telnet
    M552 P10.115.111.109 ; (0 = DHCP)
    M554 P10.115.111.108 ; Gateway
    M553 P255.255.255.0 ; Netmask

    ; Drives
    M569 P0 S0 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes BACKWARDS
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S0 ; physical drive 3 goes BACKWARDS
    M569 P4 S0 ; physical drive 4 goes BACKWARDS
    M584 X0 Y1 Z2 E3:4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E420.00:420.00 ; set steps per mm
    M566 X2000.00 Y2000.00 Z12.00 E300.00:300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X15000.00 Y15000.00 Z1800.00 E12000.00:12000.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z200.00 E1000.00:1000.00 ; set accelerations (mm/s^2)
    M906 X700 Y700 Z1000 E1000:1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X220 Y230 Z230 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S3 ; set endstops controlled by motor stall detection

    ; Z-Probe
    M574 Z1 S2 ; set endstops controlled by probe
    M307 H7 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P5 H5 F1000 T12000 X0 Y0 Z1 ; set Z probe type to bltouch and the dive height + speeds
    G31 P25 X40 Y0 Z0.983 ; set Z probe trigger value, offset and trigger height
    M557 X40:200 Y30:200 S10 ; define mesh grid
    M851 Z-0.63 ; set Z offset

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M305 P2 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F500 H-1 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P2 S0 I0 F500 H-1 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 S"Extruder links" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C
    M563 P1 S"Extruder rechts" D1 H2 F1 ; define tool 1
    G10 P1 X18.11 Y0 Z0 ; set tool 1 axis offsets
    G10 P1 R0 S0 ; set initial tool 1 active and standby temperatures to 0C

    ; Custom settings
    M574 X2 Y1 Z0 S3
    M915 P0 S12 R0 ; Higher values reduce the sensitivity
    M915 P1 S14 R0

    M501
    ; Miscellaneous
    T1 ; select first tool





  • @Phaedrux I'm sorry, forget my config.g

    Is there anything else you need for this problem?


  • administrators

    Are you using mesh bed compensation? If so, then your very low Z jerk value (M566) is probably causing the stuttering.



  • @dc42 Yes I do. Got that. Great hint! Thanks a lot!!!


Log in to reply