Dual color direct drive switching extruder.



  • I have been experimenting lately using a bowden extruder to push filament into a BMG which then extrudes the filament (see pics). It worked the first time without fuss. I have worked with the prusa MMU and various "switching" nozzles with little success. Other than the MMU, TPU was not viable and I had lots of jams and lack of tolerance. The MMU was a little over-engineered for me which in concept works well, but the inaccuracies of real-life made it unreliable.

    Anyways, to start, I am running a Duet 2 wifi with a Duex 5 add-on board. My loading extruders are 1:1 geared 3D printed bondtech bowden extruders and my printing extruder is the 3:1 geared bondtech BMG extruder direct drive. My hotend is an e3d v6 with copper heatblock, 50W heater, and nozzle X nozzle. The build volume is 300 x 300 x 400 mm^3. Right now I am running two feeding hotends, but in the future I will run up to 6 because I can.

    How it works. The feeder extruders each have a filament loaded partially into the first length of bowden. Each tool has two drivers running simutaneously in mixing mode with a 1:1 mix ratio. When tool 0 is selected, E drivers 0 and 1 are running. When tool 1 is selected, E drivers 0 and 2 are running... etc. When a tool is selected, both motors push the filament through the bowden splitter and into the BMG, out the nozzle. The benefits of this is that I maintain the direct drive setup and no longer have to maintain tight tolerances in the bowden tubes or the splitter wich is where most clogs come from.

    In the future, I plan to add limit switches for clog detection and peace of mind.

    Let me know what you guys think.
    Thanks

    alt text
    alt text


  • administrators

    Looks good!



  • Interesting! Any issues tuning the extruders with the different steps / mm?



  • Very nifty. Keep us posted.

    Let's see some prints!!



  • @oliof Theoretically the extruder motor moves 1/3 of a step faster, but because it is geared, I do not think it is a problem. Other than that, the extruder calibration is the same.


Log in to reply