Home all not working



  • @deckingman

    So that didn't go so well...

    I've put my old config.g file on the SD card, and now it's all pretty much unresponsive.

    I've got 2000 degC on my extruder temp, yet my M305 is set to "X200" for a PT100 sensor.

    The wifi module does not start when I turn the machine on, I can only activate it with YAT, then it works fine.

    When I activate it through YAT and connect to the DWC, I see I've got the following firmware:

    DWC 2.0.4
    Firmware 2.04
    Duet wifi version 1.23

    The machine does not respond to any movement commands at all now, which is strange as this is the exact config.g file I've used for years on this same machine.

    Pretty stressful this...

    Here's my config.g file as it stands right now:

    ; Configuration file for Duet WiFi
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 22 2016 18:28:19 GMT+1100 (AUS Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X195 Y195 Z175 S0 ; Set axis maxima
    M557 X20:180 Y20:180 S40

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F600 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X0 Y0 Z2.4 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping without interpolation
    M92 X80 Y80 Z800 E127 ; Set steps per mm
    M566 X1600 Y1600 Z12 E800 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z1200 E8000 ; Set maximum speeds (mm/min)
    M201 X1200 Y1200 Z20 E1200 ; Set accelerations (mm/s^2)
    M906 X1100 Y1100 Z800 E600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S280 ; Set maximum extruder temperature to 280C
    M143 H0 S140 ; Set maximum bed temperature to 140C
    M305 P0 T100000 B4000 C0 R4700 L0 H0 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 L0 H0 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200
    M307 H0 A144.9 C625.3 D1.0 B0
    M307 H1 A999.7 C377.6 D13.5 B0

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    T0

    ; Network
    M550 PZortrax M200 ; Set machine name
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured



  • Hi,

    Do you have a Duet WiFi or a Duet Ethernet board?

    The commands you have in your OLD config.g file are trying to enable the network on a Duet Ethernet board.

    I think you may be a "victim" of the configuration tool. By that I mean the config tool sort of shields you from the nitty gritty of the commands needed to get a machine up and running.

    Life gets much easier, printer wise, when you fully grasp the purpose of every line in your config.g file. And a good way to get that education is by constructing your own config.g file with an editor. Just the process of typing it in helps you learn even if you start with a basic config file from some other source and make changes as needed.

    Anyway enough of that - let us know what kind of board you have.

    Frederick



  • Mate that's most kind of you.

    Poor old David and Deckingham have been enduring me for years lol, and I end up in this situation if ever I touch the thing. I do build a very tough and straight printer mechanically by the way, it''s just this stage that takes me down every time.

    I did use the config tool with my json file uploaded into it, and you are correct, I've got a Duet wifi 2. That would explain the connection issues!

    Are you referring to M552? This is what I have now:

    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP

    So yes please, tell me what I need to change to correct the connection issues for starters.

    I do appreciate the help I get on here, and my love/hate relationship with this printer is more love than hate.



  • Hi,

    From the docs for M552:

    Parameters for Duet 2 WiFi

    P"ssid" (optional, RepRapFirmware 1.20 and later) SSID of network to connect to. The SSID and password must already have been registered using M587. If this parameter is not present, the Duet 2 WiFi will try to connect to the strongest network that is broadcasting its SSID and whose SSID has been registered using M587.
    Snnn 0 = disable networking, 1 = enable networking as a client, 2 = enable networking as an access point , -1 = disable WiFi module



  • Try just "M552 S1", assuming you want the IP assigned by your router.

    Here's the relevant part of my Duet2 config files:

    ; Network
    M550 PDanal's BFD               ; Set machine name
    M551 P                          ; Set password
    M552 S1                         ; Enable network
    ;*** Desired SSID is configured manually via M587, once only, do not put M587 in config.g
    M586 P0 S1                      ; Enable HTTP
    M586 P1 S0                      ; Disable FTP
    M586 P2 S0                      ; Disable Telnet


  • In regards to your original problem with G30 S-1, do you by chance have a deployprobe.g and retractprobe.g files in your /sys folder? If so, delete them, and I think your probing problem will be resolved.

    Did you happen to backup the config files you were working on before reverting to the old ones? Your old firmware was quite old and there are likely several changes that would need to be made to get the old config to work on the new firmware. Mainly that you won't be able to move any axis before it is homed, which also means that your homing files will need to be updated. The new set of config files you got from the configurator would have had all those changes in place already.



  • Guys,

    I don't know how to multiquote (I think we've established that I'm not the computery type), but these were all very helpful tips, and a couple of problems are now resolved.

    fcwilt/Danal,

    Yes, it was just a matter of making it "M552 S1" and it all lights up and connects almost instantly. Very happy, thank you.

    Phaedrux,

    Same for you mate, deleted those 2 files and it's homing on all 3 axis's. I haven't time for setting nozzle height right now as I'm headed out. Feeling confident it's more happy now.

    I did keep backups, but I've gotten all flustered and mixed them all up. When I get this all sorted, I'll back a good copy onto my laptop.

    I do really appreciate the help I'm getting on here, and thank you all for your time.

    Of course I've got another post following this one with my next problem...



  • Guys,

    My next problem seems to be my extruder heater setting.

    I've got a reading of 2000 degC, but it's also in a purple box, whatever that means?

    My M305 is set to X200, as I have a PT100 sensor fitted, but the text my have extras added by the configurator. Could you please help me out with this one, as after that I think it's pretty much a case of starting to print.

    Please see below:

    ; Configuration file for Duet WiFi
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 22 2016 18:28:19 GMT+1100 (AUS Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X195 Y195 Z175 S0 ; Set axis maxima
    M557 X20:180 Y20:180 S40

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F600 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X0 Y0 Z2.4 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping without interpolation
    M92 X80 Y80 Z800 E127 ; Set steps per mm
    M566 X1600 Y1600 Z12 E800 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z1200 E8000 ; Set maximum speeds (mm/min)
    M201 X1200 Y1200 Z20 E1200 ; Set accelerations (mm/s^2)
    M906 X1100 Y1100 Z800 E600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S280 ; Set maximum extruder temperature to 280C
    M143 H0 S140 ; Set maximum bed temperature to 140C
    M305 P0 T100000 B4000 C0 R4700 L0 H0 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 L0 H0 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200
    M307 H0 A144.9 C625.3 D1.0 B0
    M307 H1 A999.7 C377.6 D13.5 B0

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    T0

    ; Network
    M550 PZortrax M200 ; Set machine name
    M552 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured



  • @Corexy said in Home all not working:

    M305 P1 T100000 B4138 C0 R4700 L0 H0 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200

    Remove all the T B C R L H stuff and just use M305 P1 X200



  • @Phaedrux said in Home all not working:

    @Corexy said in Home all not working:

    M305 P1 T100000 B4138 C0 R4700 L0 H0 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200

    Remove all the T B C R L H stuff and just use M305 P1 X200

    And of course that fixed it, thank you again.

    As we've had a couple of cases of excessive text causing problems here, do you see any other lines that could be cleaned up? I'm keen to scrape this right back to just what it needs now, as I run the old one with all sorts of extra folders in there, and it did start up fiddly sometimes. I want to make this one dead clean and back it all up on my laptop to avoid this drama moving forward.

    ; Configuration file for Duet WiFi
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 22 2016 18:28:19 GMT+1100 (AUS Eastern Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X195 Y195 Z175 S0 ; Set axis maxima
    M557 X20:180 Y20:180 S40

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F600 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X0 Y0 Z2.78 ; Set Z probe trigger value, offset and trigger height

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping without interpolation
    M92 X80 Y80 Z800 E127 ; Set steps per mm
    M566 X1600 Y1600 Z12 E800 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z1200 E8000 ; Set maximum speeds (mm/min)
    M201 X1200 Y1200 Z20 E1200 ; Set accelerations (mm/s^2)
    M906 X1100 Y1100 Z800 E600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S280 ; Set maximum extruder temperature to 280C
    M143 H0 S140 ; Set maximum bed temperature to 140C
    M305 P0 T100000 B4000 C0 R4700 L0 H0 ; Set thermistor + ADC parameters for heater 0
    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200
    M307 H0 A144.9 C625.3 D1.0 B0
    M307 H1 A999.7 C377.6 D13.5 B0

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    T0

    ; Network
    M550 PZortrax M200 ; Set machine name
    M552 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured



  • It looks ok otherwise.



  • You don't have an M584 command, which sets the drive mapping. This should be the first command in the "Drives" section. However, you're using the standard mapping (M584 X0 Y1 Z2 E3), so it's not necessary. If you have two Z motors (currently individually connected to ZA and ZB, or wired together) you could split them, which would allow for X gantry levelling. But that might sound difficult to you!

    You can remove:

    • M111 S0 as debugging is off by default
    • G21 as working in millimetres is default
    • M555 P2 as compatibility with Marlin is default

    I'd move:

    • Endstop section to after the Drives section (though it doesn't really matter) and include M208 commands
    • Network to the beginning (if any command in config.g causes the config.g to abort, at least you get network!), and put machine name in quotes (good practice for string parameters). You can even remove the M586 commands as HTTP is enabled by default, FTP and Telnet are disabled by default
    • Probe settings into it's own section after endstops, and include M557 (bed probing grid).

    This should bring most settings into sensible sections, and in order of importance. So it would end up looking like:

    ; Configuration file for Duet WiFi
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 22 2016 18:28:19 GMT+1100 (AUS Eastern Daylight Time)
    
    ; General preferences
    
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    
    ; Network
    M550 P"Zortrax M200" ; Set machine name
    M552 S1 ; Enable network and acquire dynamic address via DHCP
    
    ; Drives
    M584 X0 Y1 Z2 E3 ; Set drive mapping
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping without interpolation
    M92 X80 Y80 Z800 E127 ; Set steps per mm
    M566 X1600 Y1600 Z12 E800 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z1200 E8000 ; Set maximum speeds (mm/min)
    M201 X1200 Y1200 Z20 E1200 ; Set accelerations (mm/s^2)
    M906 X1100 Y1100 Z800 E600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    
    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X195 Y195 Z175 S0 ; Set axis maxima
    
    ; Z-Probe
    M558 P1 X0 Y0 Z1 H5 F600 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X0 Y0 Z2.78 ; Set Z probe trigger value, offset and trigger height
    M557 X20:180 Y20:180 S40
    
    ; Heaters
    M143 S280 ; Set maximum extruder temperature to 280C
    M143 H0 S140 ; Set maximum bed temperature to 140C
    M305 P0 T100000 B4000 C0 R4700 L0 H0 ; Set thermistor + ADC parameters for heater 0
    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200
    M307 H0 A144.9 C625.3 D1.0 B0
    M307 H1 A999.7 C377.6 D13.5 B0
    
    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    T0
    
    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Custom settings are not configured
    

    Hope that helps!

    Ian



  • Mate that helps a lot.

    I've had visitors for a few days and haven't had a chance to look at this, but I'm assuming this going to be more tidy and efficient?

    I'll have to have a look at my bed and homing files as well.

    And to be honest I just copied and pasted this in and it's working a treat. Thanks for that!



  • Before I fire this all up again, I haven't done anything with my bed and homing files, and the configurator definitely changed all of them. Before I had it doing a autolevelling routine at the start of a print, and then I had it putting the tool off the the left/back at the end, but I'm pretty sure most of the commands for that are entered in my slicer (S3D).

    bed.g

    This is what I had before:

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 22 2016 18:28:19 GMT+1100 (AUS Eastern Daylight Time)

    ; Clear any bed transform
    G29 S2

    ; Home all
    G28

    ; Probe the bed
    G29

    ; Absolute positioning
    G90

    ; Go to center bed probe point and home the Z axis
    G1 X97.5 Y97.5 F4800

    G30

    ; Uncomment the following line to lift the nozzle after probing
    G1 Z50 F500

    This is what I have now:

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.2 on Thu Nov 21 2019 10:53:55 GMT+1100 (Australian Eastern Daylight Time)
    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation

    homeall.g

    This is what I had before:

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool on Sat Oct 22 2016 18:28:19 GMT+1100 (AUS Eastern Daylight Time)

    ; Relative positioning
    G91

    ; Lift Z
    G1 Z1 F1200

    ; Move towards X and Y axis endstops (first pass)
    G1 X-200 Y-200 F4800 S1

    ; Go back a few mm
    G1 X5 Y5 F4800

    ; Move slowly to axis endstops once more (second pass)
    G1 X-200 Y-200 F360 S1

    ; Absolute positioning
    G90

    ; Go to center bed probe point and home the Z axis
    G1 X97.5 Y97.5 F4800
    G30

    ; Uncomment the following line to lift the nozzle after probing
    G1 Z50 F1200

    This is what I have now:

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.2 on Thu Nov 21 2019 10:53:58 GMT+1100 (Australian Eastern Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-200 Y-200 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-200 Y-200 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 H2 X97.5 Y97.5 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    G91 ; relative positioning
    G1 S2 Z5 F100 ; lift Z relative to current position
    G90 ; absolute positioning

    I'm wondering if I should be looking at all these as well?



  • The old bed.g file looks like you could continue using it.

    The old homeall.g file lacks the H2 parameter for the initial Z axis lift. This would throw an error in recent firmware for trying to move an axis before it's been homed. But otherwise they are basically the same, so you should probably just keep using the new one.



  • Cheers Phaedrux,

    So I might as well just keep using the new bed and homing files? They're the one's it's running at the moment, so if there's no reason to change I won't. Just looking at what can be tidied up before I save a copy of this.

    I've also got a "homedelta.g" file in there. Can that be deleted?



  • @Corexy said in Home all not working:

    I've also got a "homedelta.g" file in there. Can that be deleted?

    Yes If you do not have a delta you can delete it.



  • Thanks guys,

    All good and knocking out a reasonably tidy print if I say so myself. Bed leveling ran in the start of the print, can't tell if it set up a map or not.

    One issue I'm having that is after using the e stop to cancel a print, I can't move my Z axis up and down. I have to switch off the machine and star it again to get operation.

    What have I missed here? The Z axis worked before in any order of operation.


  • administrators

    @Corexy said in Home all not working:

    One issue I'm having that is after using the e stop to cancel a print, I can't move my Z axis up and down. I have to switch off the machine and star it again to get operation.
    What have I missed here? The Z axis worked before in any order of operation.

    Axes cannot be moved until they have been homed, unless you either use G1 H2 movements or you use M584 M564 to allow axis movement before homing. Emergency stop sends M112 to do the stop followed by M999 to reset the controller.



  • @dc42 said in Home all not working:

    @Corexy said in Home all not working:

    One issue I'm having that is after using the e stop to cancel a print, I can't move my Z axis up and down. I have to switch off the machine and star it again to get operation.
    What have I missed here? The Z axis worked before in any order of operation.

    Axes cannot be moved until they have been homed, unless you either use G1 H2 movements or you use M584 to allow axis movement before homing. Emergency stop sends M112 to do the stop followed by M999 to reset the controller.

    No worries David, thank you.

    I do recall an M584 back on the old config.g somewhere, and as I'm the only one who uses this machine I'd like to remove the limitation. So where would I put the M584 command?

    Now I'm retuning the heaters, which I haven't done for years or at all on this board.

    What I'm worried about is that why the extruder (PT100/H1) and bed (thermistor/H0), both have the same "B0", meaning they are both operating by PWM? Shouldn't the bed be different (B1 or something) due to the thermistor? The M307 H1 settings are from my first hot end heater test, and I'll run it a second time once it's all cooled down. Haven't done the bed yet.

    ; Heaters
    M143 S280 ; Set maximum extruder temperature to 280C
    M143 H0 S140 ; Set maximum bed temperature to 140C
    M305 P0 T100000 B4000 C0 R4700 L0 H0 ; Set thermistor + ADC parameters for heater 0
    M305 P1 X200 ; Set thermistor + ADC parameters for heater 1 and remap it to channel 200
    M307 H0 A144.9 C625.3 D1.0 B0
    M307 H1 A895.8 C393.4 D6.1 V24.3 B0


Log in to reply