Heater Faults



  • @Phaedrux M307 H1 A359.0 C202.1 D4.8 S1.00 V12.4 B0



  • Which version of RRF are you running? I had this exact same problem the other day although in my case it turned out to be an issue with saving and restoring config-override on RRF3/DSF.

    Anyway, you say you've tried other temp sensors but were they all using the same wiring? A connection issue that's not long enough to be seen in DWC can still easily cause the fault to trip.



  • @jottesman

    Might want to check any cooling fans or put some insulation on the block. If you’re up at decent temperature and the heater isn’t powerful enough, it’s possible to have the heater on at full and the hot end actually cooling. A good ceramic insulation piece usually does the trick to solve the problem. A tip though, run auto tune again after you install it. The second parameter should increase by at least 50%.


  • Moderator

    @jottesman said in Heater Faults:

    I have tried upgrading to a 40w heater

    Are you sure it's not a 24v heater cartridge running at 12v? A 40w cartridge that can't keep up without the fan blowing and a block sock on it doesn't sound right.

    Is there a bad fit between the block and either the heater or thermister cartridges?



  • @TLAS No cooling fan onto the block itself, and a silicon sock to cover it 😞 . Might not be as good as a ceramic one but shouldn't be an issue.



  • @Phaedrux Yead double checked too. Like I said this has been the same issue with multiple other heater cartridges



  • @gtj0 I can't remember what version it was before, a few months old, but I've also upgraded to the latest firmware 2.05 to try and fix the issue with no luck.

    Both the different heaters that I have tried and the different temperature sensors all had their own unique wiring however they all attached to heater 1. Could it be an issue with the board? Is there a way of remapping to heater 2?



  • @jottesman
    Also keep in mind if you have a fan in the room or other random factors that might cause increased cooling.

    It’s also possible you could have a thermistor coming loose. I always use the cartridge types as they are the most reliable.


  • administrators

    @jottesman said in Heater Faults:

    @Phaedrux M307 H1 A359.0 C202.1 D4.8 S1.00 V12.4 B0

    If you send M307 H1, does it report those same values?



  • @dc42 Interestingly it did however I assumed you suspected that the values were either not applied / were overwritten.

    It turns out there was already a line in the config file specifying the parameters that occurred later that where I had included the correct ones. This was overriding the values and seems to have been what was causing the issues.

    Needs some testing to be sure but it seems likes its running smoothly again.