Z artifact that's time/speed related



  • Not sure what to make of this. it's a really regular Z artifact but the frequency is dependant on 'layer' time (this was printed in vase mode, so there's no layers, but still...) as the part gets wider and thus takes longer to go around, the frequency increases. Also if I speed up or slow down the print the frequency changes with it.

    I thought at first it was z banding but I put a straight edge on my screws and they're straight as far as I can tell, plus it wouldn't change the frequency with the speed, they would appear at the same z height regardless of speed.

    Then I thought maybe it's the extruder... so I completely changed the extruder and carriage, new parts, new design, went from DD to the nimble... so COMPLETELY different everything... didn't change.

    so if it's not Z and it's not E... I don't think it's X/Y because it's identical on all sides... that just leaves me screwing up something in the firmware configs. Seems most likely since this is my first duet.... really hoping someone has an idea what I've done wrong.

    tC2K1gs.jpg

    ; Configuration file for Duet Maestro (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sat Mar 02 2019 21:56:52 GMT-0800 (Pacific Standard Time)
    
    ; General preferences
    G90                                      ; Send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    
    M667 S1                                  ; Select CoreXY mode
    
    ; Network
    M550 P"Screwy CoreXY"                    ; Set machine name
    M552 P192.168.1.114 S1                   ; Enable network and set IP address
    M553 P255.255.255.0                      ; Set netmask
    M554 P192.168.1.1                        ; Set gateway
    M586 P0 S1                               ; Enable HTTP
    M586 P1 S0                               ; Disable FTP
    M586 P2 S0                               ; Disable Telnet
    
    ; Drives
    M569 P0 S1                               ; Drive 0 goes forwards
    M569 P1 S1                               ; Drive 1 goes forwards
    M569 P2 S1                               ; Drive 2 goes forwards
    M569 P3 S0                               ; Drive 3 goes forwards
    M569 P4 S0				 ; Drive 4 goes forwards (second Z)
    M350 X16 Y16 Z16:16 U16 E16 I1                  ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400:400 U400 E2700       ; Set steps per mm 509.3
    M566 X900.00 Y900.00 Z12:12 U12 E120.00      ; Set maximum instantaneous speed changes (mm/min)
    M203 X12000.00 Y12000.00 Z180:180 U180 E1200.00  ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z200:200 U200 E250.00      ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1200:1200 U1500 E1000.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                  ; Set idle timeout
    
    ; Motor remapping for dual Z
    M584 X0 Y1 Z2:4 U4 E3 P3 ; Driver 0 For X, 1 For Y, Z=2:4 U=4, Extruder 3
    
    ; Axis Limits
    M671 X125:125 Y-10:260 S0.5
    M208 X0 Y0 Z0 S1                         ; Set axis minima
    M208 X215 Y250 Z300 S0                   ; Set axis maxima
    
    ; Endstops
    M574 X1 Y1 S1                            ; Set active high endstops
    
    ; Z-Probe
    M574 Z1 U2 S2                               ; Set endstops controlled by probe
    M558 P5 H5 F120 T6000                    ; Set Z probe type to modulated and the dive height + speeds
    G31 P500 X23 Y5 Z1.25                    ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:195 S20                 ; Define mesh grid
    
    ; Heaters
    ;M307 H0 B0 S1.00                         ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R2200              ; Set thermistor + ADC parameters for heater 0
    ;M143 H0 S120                             ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R2200              ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                             ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1                 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                            ; Define tool 0
    G10 P0 X0 Y0 Z0                          ; Set tool 0 axis offsets
    G10 P0 R0 S0                             ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    
    
    

  • Moderator

    Is your Z axis skipping steps or binding occasionally and failing to drop the bed?



  • nothing seem out of the ordinary on the machine. it all seems to be working fine


  • Moderator

    @screwyluie Classic M584 error! M584 needs to be BEFORE all the motor settings. See https://duet3d.dozuki.com/Wiki/Gcode#Section_M584_Set_drive_mapping

    Order dependence
    M584 must come earlier in config.g than any M350 and M906 commands. If it creates new axes, it must also be earlier than any M92, M201, M203, M208, M350, M566, M574 , M667 and M669 commands.

    If it's after, it means that it's using standard settings for the second Z motor, on driver 4. Move your "Motor remapping for dual Z" section (with M584 command) up the config.g to before the "Drives" section. And don't worry, we've all done made this mistake, and now it's one of the first things I check!

    Edit: Also, no point setting parameters for each Z motor in M350, M92, M566, M203, M201 and M906. RepRapFirmware does not support individual motor settings where an axis has multiple motors connected to different stepper drivers. The first parameter specified will be used for all motors on the axis. You should use identical motors on any axis that has more than one motor to avoid unexpected behaviour. You can set these individually for each extruder axis, however.

    Ian



  • thank you for that, sounds like it could be the issue I will give it a shot when I get a chance



  • well I changed that and it didn't help. Thanks anyway though.



  • I tried a nimble extruder a few months ago and had similar diagonal lines, never seen it before with any other extruder. I thought that they may correlate with the turn of the flex cable but gave up and went to a BMG direct extruder which works just great. No more bowdens or flex cables for me.



  • Is your slicer modifying print speed or cooling based on predicted layer time?


  • Moderator

    @screwyluie said in Z artifact that's time/speed related:

    well I changed that and it didn't help. Thanks anyway though.

    Interesting. Can you post your current config?

    You are using the default thermistor settings B4138, which is likely not to be correct, so you might also be extruding too hot. The print possibly looks a bit overheated. With a slow extrusion of vase mode, there may be a build up of molten filament. In vase mode, when extrusion speed is consistent, this would release at regular intervals. What thermistor do you actually have?

    Otherwise, the frequency could relate to an eccentrically turning extruder drive. What drive are you using? Bowden or direct? Try extruding 50mm slowly into air, see if the extrusion is consistent, also if the feed into the drive is consistent.

    Does the filament have a consistent bulge in it?

    Ian



  • @zapta said in Z artifact that's time/speed related:

    I tried a nimble extruder a few months ago and had similar diagonal lines, never seen it before with any other extruder. I thought that they may correlate with the turn of the flex cable but gave up and went to a BMG direct extruder which works just great. No more bowdens or flex cables for me.

    I have a completely different extruder on here previously with the same result, so it's not that. But thanks.

    @bot said in Z artifact that's time/speed related:

    Is your slicer modifying print speed or cooling based on predicted layer time?

    most likely it is, I can look into that and see if it has any effect, thanks.

    @droftarts said in Z artifact that's time/speed related:

    @screwyluie said in Z artifact that's time/speed related:

    well I changed that and it didn't help. Thanks anyway though.

    Interesting. Can you post your current config?

    You are using the default thermistor settings B4138, which is likely not to be correct, so you might also be extruding too hot. The print possibly looks a bit overheated. With a slow extrusion of vase mode, there may be a build up of molten filament. In vase mode, when extrusion speed is consistent, this would release at regular intervals. What thermistor do you actually have?

    Otherwise, the frequency could relate to an eccentrically turning extruder drive. What drive are you using? Bowden or direct? Try extruding 50mm slowly into air, see if the extrusion is consistent, also if the feed into the drive is consistent.

    Does the filament have a consistent bulge in it?

    Ian

    it's an e3dv6 hotend and the standard thermistor for it.
    as for the extruder drive, I've completely replaced the entire extruder, so I really don't think it's the extruder. I'm currently using a nimble, I had a direct drive on previously... so entirely different hardware.
    I've used half a dozen different filaments in this process, so it's not that either.

    current config is the same as before except I moved the M584 command above the M350 command as instructed previously.



  • did you pid tune the hotend? temperature fluctuations might cause exactly that


  • Moderator

    @screwyluie said in Z artifact that's time/speed related:

    it's an e3dv6 hotend and the standard thermistor for it.

    Then your thermistor settings should be for Semitec 104, not the Honeywell. This can cause a significant difference at high temperature. I don’t have numbers/settings to hand, on phone, but they are in the firmware configuration tool.

    Ian



  • @droftarts said in Z artifact that's time/speed related:

    @screwyluie said in Z artifact that's time/speed related:

    it's an e3dv6 hotend and the standard thermistor for it.

    Then your thermistor settings should be for Semitec 104, not the Honeywell. This can cause a significant difference at high temperature. I don’t have numbers/settings to hand, on phone, but they are in the firmware configuration tool.

    Ian

    The wrong thermistor values would not cause variation in temperature however. once the temp is tuned, it should stay the same and not cause a variation. It is literally only the number on the display that is wrong.


  • Moderator

    @NitroFreak depends if he’s using the wrong display temperature to set the temperature! If it says 200 but is really 230C, it would cause regular filament vomiting like this. Hard to tell with a vase print if extrusion temperature is too high, as no moves that cause stringing. I’m looking at the print picture and it looks glossy and floppy, which says too hot extrusion to me.

    @screwyluie have you got any other prints you’ve done, to compare?

    Ian



  • @droftarts

    sorry with the holidays this has been on the backburner. I will be getting back to this soon. I appreciate the help, just wanted to update.



  • @droftarts ok after a long hiatus, working on it again... I have adjusted the thermistor settings, didn't fix it.

    @NitroFreak I did not pid tune it but it's rock solid at +-0.1

    I have tried modify stuff in the slicer, even tried several other slicers all with similar results. At this point I'm pretty convinced it's either mechanical or something in the duet config I've screwed up... but I have no idea where to start.


  • Moderator

    @screwyluie said in Z artifact that's time/speed related:

    At this point I'm pretty convinced it's either mechanical or something in the duet config I've screwed up... but I have no idea where to start.

    Your config looked ok. I'm inclined to think it's mechanical. I would start with disassembling the Z axis, checking things over, and reassembling.

    The pattern on the vase looks like something is slipping/binding every few layers. Maybe a loose coupler? Tight lead screw nut?



  • @Phaedrux except that it's not layer specific, it's time based. if I speed up the print they get further apart, and likewise if I slow it down they get closer together... so it's not your typical z banding


  • Moderator

    I notice in your config that the M307 line is commented out. Is your bed set to bang bang mode? This can lead to some bed warp that can cause fat layers like this.



  • @Phaedrux said in Z artifact that's time/speed related:

    M307 line is commented out

    honestly no idea. I do know that it heats up like it should and the temp is very steady.


Log in to reply