Duex5 problema



  • Hola, en duex5 solo me funciona el canal número 7 ,pongo cualquier motor en el 7 y sin problema lo xambio para 5 6,8 o 9 y da fallo de fases desconectadas , siempre cambiando en el m584 y en m569 claro.


  • administrators

    @froma1976 hola!

    (Using Google translate:

    Hello, in duex5 only the channel number 7 works, I put any motor in the 7 and without problem I change it to 5 6,8 or 9 and it fails of disconnected phases, always changing in the m584 and in clear m569.)

    Please post the config.g you are using.



  • @T3P3Tony ok, pero puede ser que la el cable de vaina de 50 pines esté al revés?



  • @T3P3Tony ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.4 on Fri Dec 20 2019 11:16:09 GMT+0100 (hora estándar de Europa central)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M584 X0 Y1 Z2:5:6:7 E3
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M569 P4 S1
    M569 P5 S1
    M569 P6 S1
    M569 P7 S1
    M350 X256 Y256 Z256 E256 I0 ; configure microstepping without interpolation
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X600 Y700 Z500 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T500000 B4723 C1.196220e-7 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S450 ; set temperature limit for heater 1 to 450C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H-1 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined



  • @froma1976 está sin acabar, pero solo estoy probando los z


  • administrators

    @froma1976 said in Duex5 problema:

    pero puede ser que la el cable de vaina de 50 pines esté al revés?

    Can you also upload a picture for your setup please. It should not be possible to fit the ribbon cable incorrectly.



  • This may or may not have anything to do with the problem but the steps per mm values are akin to what one might expect to see with 16X micro stepping and say 20 tooth pulleys and a Bondtech BMG or E3D Titan extruder. Yet the micro stepping has been set to 256X and that M350 command precedes the M92.

    Suggest setting M350 to 16X for now. Or if there is some reason why 256x is desired, put the M350 after the M92 (or multiply all the M92 values by 16).





  • Gnd wire too long?



  • @deckingman llegan 24v certamen a duex5


Log in to reply