Duet 3 + Pi HDMI Touchscreen



  • Several others have mentioned this in various places, starting a dedicated thread because I have a couple of questions: Obtained this for Duet 3 + Pi. Plugs in to HDMI and USB and is a display that emulates a mouse when you touch it. Works very well, just plugged in and immediately started working.

    https://www.amazon.com/gp/product/B07TXFPHM2/

    Question 1: The default DWC layout is small on this screen. Both hard to read and hard to hit the right button when they are crowded. Has anyone found an easy way to make the DWC layout larger?

    Question 2: Anyone have the STL for a case?

    69e69b31-b8b7-43c6-ba8d-ba4ab31dd73d-image.png



  • I don't use the DuetPi distribution so I can't say exactly but playing with the DPI setting somewhere in the desktop settings should do it.



  • @gtj0 no hast not the case.
    the question is of an alternative DWC layout which is more adopted to the screen size and touch.



  • DPI settings should remedy the two issues Danal mentione. Difficult to read and hard to touch - but if the screen is too small to fit DWC at a readable and touchable size, then the issue becomes removing stuff from the DWC layout not just making it bigger.

    I took half a glance at it a while ago, but i'm just not familiar enough with the framework used


  • administrators

    It's quite unfortunate that either Raspbian does not set the actual display DPI or that Chromium just doesn't respect this setting on Linux. It's worth trying to set the DPI via xrandr/xorg.conf.d (xrandr --dpi <actual DPI>) or to simply start Chromium with --force-device-scale-factor=1.25 where 1.25 is the zoom factor in per cent.

    I haven't tried it yet but it's probably what I'll do next for my own test setup. FYI the script that invokes Chromium on DuetPi is /usr/bin/launch-dwc.



  • Chris, perfect, THANKS... I will try a couple of those things. Especially because changing pixel (screen) size seems to have no effect when this monitor is plugged in.

    My usual ways are:

    /boot/config.txt
    \# uncomment to force a specific HDMI mode (this will force VGA)
    hdmi_group=2
    hdmi_mode=nn   (85 is 1280x1024, for bigger icons I was trying 4 for 640x480)
    

    And/or

    /boot/config.txt
    \# uncomment to force a console size. By default it will be display's size minus
    \# overscan.
    framebuffer_width=640
    framebuffer_height=480
    

    and those do not change anything with this touchscreen plugged in.



  • @chrishamm I went the scale factor route, and that works quite well. I ended up at 2.


Log in to reply