RepRap ver 3 upgrade - oh my ....



  • Just attempted to upgrade to version 3. For some reason I had it in my mind that there would be a way to automatically upgrade ,with some minor intervention on my part.
    Sadly, that doesn't seem to be the case 😞
    It looks like some major head meets wall will be required but thankfully I upgraded on a spare memory card so I can easily revert to the old system.

    Not complaining or anything, just venting a bit of frustration that things can't be a bit easier ....
    I will climb the mountain, I just didn't expect it to be such a steep trail.


  • Moderator

    I feel your pain. I still think most people would be best served by staying on 2.05 for the time being unless there is a feature of 3.x that you really want.



  • @jens55 said in RepRap ver 3 upgrade - oh my ....:

    ... but thankfully I upgraded on a spare memory card so I can easily revert to the old system.

    Is there an easy downgrade path? I got a new duet with my e3d toolchanger and immediately flashed it to the latest firmware (bad habit, apparently). At that point I was dead in the water, as I kept getting javascript-error/disconnect in dwc (and therefore had no easy downgrade path).

    In the end, I built/installed duetWebControl 2.0 which resolved the javascript errors, but all the toolchanger scripts need to be updated/modified to work. I'm partway through (it homes now...)

    Is downgrading the firmware as simple as uploading the 2.05 version of Duet2CombinedFirmware.bin from https://github.com/dc42/RepRapFirmware/releases/tag/2.05, clicking "upgrade", and rebooting? I have a Duet2Ethernet if it matters.



  • That's why the original memory card stayed untouched ... I am soooo happy that I decided to go that route 🙂 Now I have the opportunity to fiddle with 3.0 knowing that if I need to print something I can just pop in the original setup.


  • Moderator

    @pmeyer If you still have access to the DWC, yes, you can simply upload the version of firmware you want, and it should flash it for you. You will need the iap files for that version, so if you get an error message about iap files, just find the file in the github release.

    If you don't have access to the DWC anymore, but still have USB console, you can place the firmware bin file on the SD card and send the command to update the firmware. DWC files would need to be placed in the /www folder.

    If you have neither of those, you can still use the fallback procedure using bossa on your PC to write the firmware over USB.



  • @pmeyer said in RepRap ver 3 upgrade - oh my ....:

    Is there an easy downgrade path?

    I am guessing here but all the various files seem to be intact after the upgrade so I would try to just install the 2.05 firmware as you are suggesting. You can't get into more trouble 🙂


  • Moderator

    That's right, all the config files will stay the same.

    The easiest way to swap between 2.x and 3.x on the same board is to use M505 to use separate /sys folders and config files for each.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M505_Set_configuration_file_folder

    You can have a folder called sys2x and sys3x and swap between them. The config in the default /sys can just contain the bare basics.

    Then just flash between the firmware versions and load the config.g from the right folder.



  • I was lucky when I started with duet the 3beta was already out so I never tried 2.x but also the configurator was not there .. now the configurator support 3 so maybe (have not tried it but..) you could load your config into configurator from 2.x and then export it as 3.0 ?



  • @smece, you can load the .json file into the configurator but looking at the results, it looks like a lot of stuff is not carried over. I don't actually know what is in the .json file but it appears to be just basic machine parameters like sizes.



  • @jens55 have not tried it myself (was not supporting rrf3 at the time), so I just hoped it works..



  • @Phaedrux

    It was the IAP file that was messing me up. It asked for the IAP file which did not exist in the 2.05 release. I wasn’t confident enough to mix in the IAP file from the 3.0 release with my 2.05 bin. Reading elsewhere, that is the way to do it.

    I’ll try the swapping back and forth approach and see if I can get it working. I do have access to DWC now (after some work...)



  • I haven't tested all functions yet but I think I have sorted most things out. The one thing that I haven't been able to solve is operation of the bltouch.
    I have attached my config.g file in case there is something obviously wrong.config.g



  • @jens55
    We continue doing that over the chat we have started.......



  • @jens55: RRF3 is more flexible and more logical in the way it handles I/O, imho. Maybe no benefits for you today, but someday it will benefit you and then you will want to do the RRF2->RRF3 update anyway.

    It is a one-time pain only. If you start with the configurator it won't be that bad. For me personally it was a fairly painless upgrade with a small number of bumps that were easily sorted out by reading the docs.



  • Yes, things are moving along nicely. With the help of DIY-O-Sphere, I now have the bltouch pin moving. I will still need to see if it functions properly but there is progress !



  • In case it helps you or someone else searching for BLtouch and RRF3: the Zprobe part of my config.g:

    ; Z-Probe
    M950 S0 C"exp.heater3"                                 ; create servo pin 0 for BLTouch
    M558 P9 C"zprobe.in" H4 F240 T6000                     ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X-7 Y34 Z3                                    ; set Z probe trigger value, offset and trigger height
    

    I am using the heater3 pin on the expansion header to control the BLTouch.

    Then: deployprobe.g:

    M280 P0 S10 ; deploy BLTouch
    

    and retractprobe.g:

    M280 P0 S90 ; retract BLTouch
    


  • Yes, I did see that and used it in my attempts at figuring things out.

    I am about to do an actual test print as all my ducks seem to be waddling in a nice straight line here 🙂



  • I am happy to report that the beast is ALIVE!!!!
    I have to do some fine tuning for speeds and extrusion rates and things as they seem to be out of whack for some reason but yes, everything seems to be working just peachy !

    Thanks for all the help guys ! (and gals if present)

    Woooo Hoooooo !


Log in to reply