Ender 3 Pro - RRF 2.04 - can't get 12864 LCD to work



  • Re: Maestro and 12864 startup
    I bought the Maestro a couple months back, worked through the Dozuki guide for Duet/Ender 3 and got all setup, except for the LCD display. Didn't immediately work, so I blew it off and been using DWC. I'm revisiting that now, and having no luck at all getting the little OEM display to work.
    I've got the ten-wire cables "reversed", have put the M918 P1 E4 line in my config, even tried a G4 P400 in front of it ..... got nothing but a bright, blank screen.
    I've also hooked up a RepRap Discount Smart Controller salvaged from a Tevo Tarantula and got the same thing - nice bright screen, no text or characters.
    Also tried all possible permutations of cable flipping, tried different cables, etc etc.
    Totally stumped here - need a clue sheet, please ? What do I need to check, measure, probe or poke to get a diagnosis ?


  • Moderator

    So the LCD lights up?

    Do you have menu files present on the SD card?

    Can you post your config?

    Maybe a photo of the wiring?



  • LCD(s) are bright from edge to edge.
    I've uploaded files from mudcruzr to menu directory on SD card
    verified LCD enabled via M918 gcode query

    ; Configuration file for Duet Maestro (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.3 on Sat Nov 23 2019 22:46:07 GMT-0600 (Central Standard Time)
    ; annotated and rearranged by CCluck Sat Jan 11 2020 09;26;00 GMT-0600 (Central Standard Time)
    ; this configuration tailored for Ender 3 Pro with Duet Maestro and Zesty Nimble

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Ender 3PRO++" ; set printer name
    G4 P400
    M918 P1 E4 F2000000 ; configure direct-connect display

    ; Network
    M552 P0.0.0.0 S1 ; enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; XYZ Drives P0,P1,P2
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S0 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes forwards
    M584 X0 Y1 Z2 ; set drive mapping
    M92 X80.00 Y80.00 Z1600.00 ; set steps per mm - Z axis has dual lead screws 2mm pitch
    M566 X900 Y900 Z24.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z1200 ; set maximum speeds (mm/min)
    M201 X900 Y900.00 Z100.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 I50 ; set XYZ motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Extruder Drive P3
    M569 P3 S0 ; physical drive 3 goes forwards - geared Nimble Extruder
    M584 E3 ; set drive mapping - Stepper Driver 3 drives extruder
    M350 E32 I1 ; configure microstepping WITH interpolation

    M92 E2750.00    					               ; set steps per mm
    M566 E40.00    							       ; set maximum instantaneous speed changes (mm/min)
    M203 E3000.00						               ; set maximum speeds (mm/min)
    M201 E120.00						               ; set accelerations (mm/s^2)
    M906 E500 I50	   		   		         	       ; set Extruder motor current(ma) and motor idle factor in per cent
    M84 S30                                            	; Set idle timeout
    

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X235 Y235 Z260 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Runout Sensor
    M582 T1 ; check external trigger #1
    M591 D0 C3 P2 S1 ; configure filament monitor ( simple runout switch on Extruder 0 )
    M581 E0:1 T1 S1 C0 ; configure external trigger ( if runout occurs, invoke pause.g macro )
    M582 T1 ; check external trigger #1

    ; Z-Probe
    M558 i1 P5 H5 F120 T6000 ; set Z probe type to switch and the dive height + speeds
    G31 P500 X-50 Y-10 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X30:215 Y30:215 S15 ; define mesh grid

    ; Bed Heater H0
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T98801 B4185 R2200 ; set thermistor + ADC parameters for heater 0
    M143 H0 S90 ; set temperature limit for heater 0 to 90C

    ; Hotend H1
    M307 H1 A364.8 C192.5 D3.77 S1.0 ; PID settings - E3D V6
    M305 P1 T98801 B4185 R2200 ; set thermistor + ADC parameters for heater 1
    M 143 S280 ; set Hotend MAX temp to 280C

    ; Fans
    M106 P0 S0 I0 F100 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Tools
    M563 P0 S"Hotend" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings
    ; M593 F39 ; Dynamic Acceleration Adjustment
    ; M572 D0 S0.06 ; Extruder Pressure Advance

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0 ; select first tool



  • Oddball accel, jerk and esteps settings are due to the Ender 3 Pro, Zesty Nimble combo


  • Moderator

    Can you send M98 Pconfig.g in the console? See if it reports any errors.



  • 7:56:58 PMM98 PCONFIG.G
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Error: Bad command: M 143 S280


  • Moderator

    Well the M143 is an important one to fix but I don't think it's our problem.

    I would suggest trying to move the M918 command to the end of the config.g.

    Otherwise config looks ok. I suspect wiring.



  • @Phaedrux said in Ender 3 Pro - RRF 2.04 - can't get 12864 LCD to work:

    M98 Pconfig.g

    I'll move it now and reboot ..... standby



  • @ccluck
    OK, moved M918 line to bottom of config.g, rebooted FW, same situation - LCD screen is fully lit up but no sign of characters or images despite rotating knob, pushing knob, shaking the hell out of it and cursing or sweet-talking to it.
    I've got three ribbon cables here, and moved them around in each position .... it's like the Maestro just doesn't want anything to do with some down-market cheap RepRap display. Snooty little bastard, eh ?


  • Moderator

    Can you post a photo of the cable orientation just to verify its connected the right way?

    I know it would be a pain but are you able to connect the creality board to test if the display is actually working?



  • @Phaedrux , well, I have some challenges uploading photos over this DSL line, but maybe... it'll take me awhile to power up the Creality board, but I'll get started on that. The OEM display worked just fine when I did the big swap, for what its worth. I'll get back to you in a little while. Thanks for your time and attention thus far, and for the guide you wrote. Worked out just fine except for this part.



  • Well, a quick and dirty power connect to the OEM Creality board brings up a perfectly legible LCD start up screen. Looks just like it used to before we migrated to Duet.



  • @ccluck ![alt text](Duet LCD Connect.JPG image url)







  • @DIY-O-Sphere , thanks. I'm using the two-ribbon option as described there in the guide.
    The connectors have been reversed exactly as described and illustrated in steps 13 and 14. I've got three ribbons available, so have alternated their use to (nearly) eliminate the possibility of a bad cable. I think it must be in the software. My reading on this topic indicates that all hookup details were figured out a year or so ago, when RRF 2.02 was the stable version. Any chance that 2.04 is different somehow ?



  • In the spirit of science, I've connected the recalcitrant LCD to another Maestro with the same results. Maybe I have the menu files in the wrong place .... they are in the Display Directory, accessible from the Display Editor Tab on the DWC Settings page. Is that correct ?



  • @ccluck said in Ender 3 Pro - RRF 2.04 - can't get 12864 LCD to work:

    when RRF 2.02 was the stable version. Any chance that 2.04 is different somehow ?

    there were a lot of changes regarding lcd in 2.03 and 2.04. and the menu files are not compatible with the old firmware.

    for testing please edit the main file and put this in
    text R0 C0 F1 T"Test"


  • administrators

    If there are no menu files at all, the screen should display a message. Also it displays "Updating firmware" any time you update the firmware via DWC, or manually using M997.



  • I have zipped up my working menu structure which is mostly MudCruzrs with some tweaks of my own.
    Rename the file from a .txt to .zip
    Extract to a folder and then upload using the upload Menu files in the Display tab.
    These were working with firmware 2.04 and now rrf3 with DWC 2.07
    Menufiles.txt

    HTH
    Paul.


Log in to reply