Bed heating too slowly



  • Hi all,

    I'm setting up a duet 2 wifi on a CR10s5, which has a 500x500mm bed. when I pre-heat the bed i get the error "Error: Heating fault on heater 0, temperature rising much more slowly than the expected 1.8°C/sec"

    I can see that the temperature is going up, just not as quickly as the firmware wants but i think that's because of the size of it. How can i change this tolerance?

    Board: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0 (2020-01-03b3)
    Duet WiFi Server Version: 1.23

    Thanks



  • run a M303 H0 S70 to tune the pid for 70°C. It resolve the issue.



  • Have you done a heater tune on the bed ?
    You will find that the standard CR10-S5 is WAY underpowered to the tune of being almost useless ... but you should be able to get the bed hot enough for PLA



  • I doubt the bed will be able to reach 70C ... I'd try for 60


  • Moderator

    @ashtonwatts You need to tune the bed heater with M303 H0 S60, for example (assuming H0 is your bed heater, and 60ºC is your target temperature), then save the output to config-override.g with M500. Then either have M501 at the end of config.g (to load config-override.g) or copy the M307 command into config.g where the heaters are defined. Note that tuning will set the bed to PWM control rather than bang-bang, so if you want to keep it on bang-bang, change B0 to B1. eg on my heated bed (12V 200x200mm Prusa 2a red heated bed PCB), M303 tune created:
    M307 H0 A215.5 C661.6 D5.8 S1.00 V11.6 B0
    For bang-bang, change to:
    M307 H0 A215.5 C661.6 D5.8 S1.00 V11.6 B1

    I tend to run the heater tuning 3 times, to home in on the best settings. Make sure the bed is at room temperature between each tune. Also tune the hot end. See https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control

    Ian


Log in to reply