Duet 0.6 and BLTouch



  • I've been out of 3d printing for about 2/3 years (or when Piezo was starting out or new). I have recently bought a Ender 3 and I'm keen to put my Duet 0.6 i had for my old Delta in/on it once I have got the basics of marlin back in my head and set up so I know it's printing fine before changing boards.

    I bought a BLTouch and have set that up with the current Ender 3 board, but I am unable to find if it is possible to connect it to the 0.6 board (Not the 4.7K version).

    The 3 questions I have;
    1, is it possible to connect the BLTocuh to a Duet 0.6 board?
    2, If not which is the cheapest board I can get which will connect?
    3. I still have my Piezo20 board from x amount of years ago, am I able to connect that to an Ender 3.

    Thanks all, good to be back 🙂


  • administrators

    1. Yes it should be possible. Connection would be as for the Duet WiFi except that the expansion connector pinout is different, and the Z probe input (output from BLTouch) is on the expansion connector too.

    2. Duet Maestro


  • Moderator

    @Gilly First, update to the latest firmware 1.26.1 https://github.com/dc42/RepRapFirmware/releases/tag/2.05.1

    To connect BLTouch to Duet 0.6, see table here: https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Z_Probe_Header_Expansion_header_pins to see pin mapping from Duet 2 WiFi to Duet 0.6.

    Then https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Duet_2_WiFi_Ethernet_without_a_Duex_2_or_Duex_5_expansion_board for pin connections (on Duet 2 WiFi, so use table above to map pins to Duet 0.6)

    Software configuration should then be the same as Duet 2 Wifi: https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Software_setup_Duet_2_WiFi_Ethernet_running_RepRapFirmware_Num_2

    Ian



  • @droftarts I am trying to use the latest BL Touch v3.1 with the Duet .6. I have updated and verified the firmware is 1.26.1. I also used the online tool to update my config.g. I have tried several different wiring configurations and still no response when sending M280 codes to deploy the pin. I think my wiring is incorrect. Do I hook up the black wire ground from the BL Touch or not? The diagram on the ANTCLABS website show it disconnected for the Duet. Is this correct? Duet.6.jpg


  • Moderator

    I've always hooked up the ground wire. I'm not much of a sparky wiz but I can't see why it would be left disconnected.

    Does the BLTouch power on with the Duet? Should light up and do a self test.



  • @Phaedrux Ground wire makes sense to me too, just strange that on ANTCLABS they show it disconnected.

    Yes it turns on, solid red LED, and performs the self test. It's unresponsive to codes. My config.g is setup by default to use heater3 like all the info online says to use but I don't think this is right for the v0.6 board because the expansion pins are totally different.


  • Moderator

    Please post your configuration so we may double check. Config.g, deployprobe.g, config-override.g



  • @Phaedrux

    config.g

    io; Configuration file for Duet 0.6 (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun Mar 29 2020 15:14:57 GMT-0600 (Mountain Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"huXLeY" ; set printer name

    ; Network
    M552 P0.0.0.0 S1 ; enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M92 X80.00 Y80.00 Z4000.00 E420.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X138 Y140 Z95 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; set active high endstops
    M574 Z1 S2 ; set endstops controlled by probe

    ; Z-Probe
    M307 H3 A-1 C-1 D-1 ; disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M556 S50 X0 Y0 Z0 ; set orthogonal axis compensation parameters
    M557 X15:138 Y15:140 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    deployprobe.g

    ; deployprobe.g
    ; called to deploy a physical Z probe
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun Mar 29 2020 15:14:57 GMT-0600 (Mountain Daylight Time)
    M280 P3 S10 I1 ; deploy BLTouch

    I don't have a config-override.g


  • Moderator

    @cadsys at startup, the probe should deploy and retract, which shows power is getting to that mechanism. Does it do that? If not check, the continuity of those wires, and double check where you have connected them.

    Ian



  • @droftarts Yes. It does deploy and retract at startup.



  • @cadsys Ok I got it working by moving the control wire to physical pin 21 as shown on ANTCLABS's website. I finally found the correct pinouts here: https://reprap.org/wiki/Duet_pinout for the 0.6 board. It shows heater 3 on pin 21. Deploy and retract now working via M280 commands.



  • I figure I would just post this for any other idiots like myself trying to hookup the BLTouch to the Duet v0.6. Strangely enough it works without hooking up the Black Ground wire as shown on ANTCLABS's website.Duet.6_correct.jpg


  • Moderator

    @cadsys Thanks for this! Glad you got it working. I think I can see where the confusion was, in that pin 41 is the Z_PROBE_MOD_PIN, which isn't used by BLTouch. The servo needs a PWM pin, so the heater pin is ideal, but it's not specified. The black and brown wires are, apparently, a shared ground, so you only need to connect one of them.

    I'm about to update the BLTouch documentation, which has outgrown the 'Connecting a probe' page, so is going to get a page on it's own, and I'll add this info.

    Nice to see a RepRapPro Mendel still going, even if you have reprinted some of the parts! I probably crimped the wiring looms on it...

    Ian


Log in to reply