printer goes into home mode without printing anything



  • HI, how to print, I upload files, the one mode, with Cura4.4 connected to duet2wifi printer (duetRRF conection), the other mode, upload files directly through DWC G-code file.
    After that printer BED prepares for heating to 60C, and threat extruder to 200C.
    Then z axis moves up, Y axis forward, X axis in side slightly. After that, the printer goes into home mode without printing anything
    What a mistake i make?

    Print Duet2wifi.png Printduet2wifi2.png

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Feb 20 2020 13:12:07 GMT+0100 (centraleuropeisk normaltid)
    
    ; General preferences
    G90                                     ; send absolute coordinates...
    M83                                     ; ...but relative extruder moves
    M550 P"My Printer"                      ; set printer name
    
    ; Network
    M552 S1                                 ; enable network
    M586 P0 S1                              ; enable HTTP
    M586 P1 S0                              ; disable FTP
    M586 P2 S0                              ; disable Telnet
    
    ; Drives
    M569 P0 S1                              ; physical drive 0 goes forwards
    M569 P1 S1                              ; physical drive 1 goes forwards
    M569 P2 S0                              ; physical drive 2 goes backwards
    M569 P3 S1                              ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                        ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                 ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z2560.00 E873.08    ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00     ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X400.00 Y500.00 Z20.00 E250.00     ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30            ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                 ; Set idle timeout
    
    ; Axis Limits
    M208 X-33 Y-10 Z0 S1                    ; set axis minima
    M208 X230 Y230 Z240 S0                  ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z1 S0                        ; set active high endstops
    
    ; Z-Probe
    M558 P0 H5 F120 T6000                   ; disable Z probe but set dive height, probe speed and travel speed
    M557 X-18:215 Y5:195 S20                ; define mesh grid
    
    ; Heaters
    M305 P0 T100000 B4138 R4700             ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                            ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700             ; set thermistor + ADC parameters for heater 1
    M143 H1 S280                            ; set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                  ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45               ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 S"TitanAero" H1 F0                        ; define tool 0
    G10 P0 X0 Y0 Z0                         ; set tool 0 axis offsets
    G10 P0 R0 S0
    M302 ; Report current state
    M302 P1 ; Allow cold extrusion
    M375 ; Load height map                            ; set initial tool 0 active and standby temperatures to 0C
    T0
    ; Custom settings are not defined
    

    Thanks again!



  • please provide a sliced gcode file With this problem



  • Hi, here it comes.

    ;FLAVOR:Marlin
    ;TIME:4104
    ;Filament used: 2.36321m
    ;Layer height: 0.1
    ;MINX:54.213
    ;MINY:61.735
    ;MINZ:0.3
    ;MAXX:136.813
    ;MAXY:82.335
    ;MAXZ:40
    ;Generated with Cura_SteamEngine 4.4.0
    M140 S60
    M105
    M190 S60
    M104 S200
    M105
    M109 S200
    M82 ;absolute extrusion mode
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 X0 Y0 ;move X/Y to min endstops
    G28 Z0 ;move Z to min endstops
    M84 ;steppers off
    M0 S12 ;wait 12 seconds
    M17 ;turn steppers on
    G1 Z10.0 F300 ;move the platform down 10mm
    G92 E0 ;zero the extruded length
    G1 F200 E8 ;extrude 8mm of feed stock
    G92 E0 ;zero the extruded length again
    M0 S5 ;wait 5 seconds
    G1 F9000
    M117 Printing...
    G92 E0
    G92 E0
    G1 F1500 E-6.5
    ;LAYER_COUNT:398
    ;LAYER:0
    M107
    G0 F3600 X56.636 Y63.9 Z0.3
    ;TYPE:SKIRT
    G1 F1500 E0
    G1 F1800 X57.235 Y63.385 E0.03941
    G1 X57.883 Y62.934 E0.0788
    G1 X58.574 Y62.55 E0.11824
    G1 X59.299 Y62.238 E0.15762
    G1 X60.052 Y62.001 E0.197
    G1 X60.826 Y61.842 E0.23642
    G1 X61.611 Y61.761 E0.27579
    G1 X62.01 Y61.751 E0.29571
    G1 X102.01 Y61.735 E2.29131
    
    .......
    G0 F7200 X63.192 Y71.44
    G1 F1800 X63.928 Y70.704 E2363.20115
    G0 F7200 X63.363 Y70.704
    G1 F1800 X63.19 Y70.876 E2363.20521
    ;TIME_ELAPSED:4104.556897
    G1 F1500 E2356.70521
    M140 S0
    M107
    M104 S0 ;extruder heater off
    M140 S0 ;heated bed heater off (if you have it)
    G91 ;relative positioning
    G1 E-1 F300  ;retract the filament a bit before lifting the nozzle, to release some of the pressure
    G1 Z+4 E-5 X-20 Y-20 F9000 ;move Z up a bit and retract filament even more
    G28 X0 Y0 ;move X/Y to min endstops, so the head is out of the way
    G1 Y210 F9000 ;move out to get part off
    M84 ;steppers off
    G90 ;absolute positioning
    M82 ;absolute extrusion mode
    M104 S0
    ;End of Gcode
    
    


  • @chris4 said in printer goes into home mode without printing anything:

    M84 ;steppers off

    Remove the M84 M0 and the M17 from your startscript





  • @SIam
    HI again,
    I have to remove every time M84, M0, M17, after slicing to print, isn't there in CURA that I can do to avoid it?


  • Moderator

    Check your printer profile in cura to see what it uses for start gcode.

    It also appears that you have your gcode flavor set to marlin, it should be set to reprap.

    Goto Settings > Printers > Manage printers > Select your printer > click machine settings



  • Thanks. I change it.



  • Hi, has changed in CURA but it will be the same.
    need more changes in CURA to print?

    ;FLAVOR:RepRap
    ;TIME:3750
    ;Filament used: 2.19156m
    ;Layer height: 0.1
    ;MINX:87.2
    ;MINY:80.2
    ;MINZ:0.3
    ;MAXX:132.8
    ;MAXY:139.8
    ;MAXZ:30.1
    ;Generated with Cura_SteamEngine 4.4.0
    T0
    M190 S60
    M104 S200
    M109 S200
    M82 ;absolute extrusion mode
    G21 ;metric values
    G90 ;absolute positioning
    M82 ;set extruder to absolute mode
    M107 ;start with the fan off
    G28 X0 Y0 ;move X/Y to min endstops
    G28 Z0 ;move Z to min endstops
    M84 ;steppers off
    M0 S12 ;wait 12 seconds
    M17 ;turn steppers on
    G1 Z10.0 F300 ;move the platform down 10mm
    G92 E0 ;zero the extruded length
    G1 F200 E8 ;extrude 8mm of feed stock
    G92 E0 ;zero the extruded length again
    M0 S5 ;wait 5 seconds
    G1 F9000
    M117 Printing...
    M83 ;relative extrusion mode
    G1 F1500 E-6.5
    ;LAYER_COUNT:299
    ;LAYER:0
    M107
    G0 F3600 X89.08 Y82.929 Z0.3
    ;TYPE:SKIRT
    G1 F1500 E6.5
    G1 F1800 X89.623 Y82.356 E0.03938
    G1 X90.222 Y81.841 E0.03941
    G1 X90.87 Y81.39 E0.03939
    G1 X91.561 Y81.006 E0.03944
    G1 X92.286 Y80.694 E0.03938
    G1 X93.039 Y80.457 E0.03938
    G1 X93.813 Y80.298 E0.03942
    G1 X94.598 Y80.217 E0.03937
    G1 X94.998 Y80.207 E0.01996
    G1 X124.998 Y80.2 E1.49671
    G1 X125.787 Y80.24 E0.03941
    G1 X126.567 Y80.359 E0.03936
    G1 X127.332 Y80.557 E0.03942
    G1 X128.073 Y80.831 E0.03942
    G1 X128.782 Y81.178 E0.03938
    G1 X129.452 Y81.595 E0.03937
    

  • Moderator

    @chris4 said in printer goes into home mode without printing anything:

    M84 ;steppers off
    M0 S12 ;wait 12 seconds
    M17 ;turn steppers on

    You still haven't changed the start gcode in Cura. It's in the same window as the reprap flavor change in a text box.



  • @Phaedrux said in printer goes into home mode without printing anything:

    M84 ;steppers off
    M0 S12 ;wait 12 seconds
    M17 ;turn steppers on

    This changed should be done every time you print, CURA. "Goto Settings> Printers> Manage printers> Select your printer> click machine settings" and change, M84; steppers off
    M0 S12; wait 12 seconds
    M17; turn steppers on?

    OK! excuse me, NOW I get it



  • Why in the world is Cura defaulting to turning the motors off then on again AFTER homing the axes, and right before printing?


  • Moderator

    @bot Maybe it's a marlin thing? Or a profile from someone else?


Log in to reply