Y axis skipping after many hours printing



  • Thanks, I'll try that.

    My Pangolin print finished in 5-7 hours without any failures. Both annoyed and happy at the same time.

    And now I need to start going over all wiring. And I need to make a mark on the Y rod and pulley so I can see if is slips. And on the belt as well to eliminate mechanical failure.



  • After printing fine for a month now it started acting up again. Just started a long print with the debug on on the same gcode that failed last time now. Not sure what I'm hoping for really.



  • Does it juts act up on one particular file? I'm still thinking it's the print head catching on a "blob".



  • Hmm, just had en slight skew on Y axis and I paused then stopped print.

    there are a bunch of lines like this,

    2017-06-28 19:32:10,261 - Recv: DM0 ERR: dir=F steps=782 next=741 rev=762 interval=10314398 sstcda=74840 acmadtcdts=9606 tstcdapdsc=361687 2dtstc2diva=83482472448

    I have put it on Dropbox here: https://dl.dropboxusercontent.com/u/513954/serial.log


  • administrators

    Thanks for providing that log. I'll look at it in more detail tomorrow and run the moves through the simulator, but for now I can see that the step errors all relate to the first extruder drive (DM0). So they have not affected Y movement, just caused a small amount of under-extrusion.



  • Thanks,

    you can actually simulate whats in the serial logs?

    Here is the gcode file as well: https://dl.dropboxusercontent.com/u/513954/pad_mount_final_x_fast.gcode

    Don't know if you can see this in the serial logs. On the web control I set speed to 50% before layer 1 and increased to 100% soon after layer 1 was finished. The Y shift looks to be in one of the last layers before I stopped print.


  • administrators

    I just spent the afternoon tracking this down. There was a bug in the pressure advance calculation, which was causing the calculation to schedule too many steps if the move had a lot more acceleration than deceleration. A check in the step timing function found that the extra steps didn't make sense, so they were thrown away. Net result was no difference in the actual motion, just some step errors logged because the check failed. I've fixed this in firmware 1.19beta8.



  • You are talking about extrusion now? Or Y-movement as well?

    Can 1.19beta8 fix my Y shift issues?



  • @strips:

    …...............Can 1.19beta8 fix my Y shift issues?

    No. (because it's a mechanical issue, not firmware).



  • @strips:

    You are talking about extrusion now? Or Y-movement as well?

    Can 1.19beta8 fix my Y shift issues?

    It sounds like he's fixed the StepErrors number, which was incorrectly reporting step errors that weren't actually occurring.


  • administrators

    The fix prevents the superfluous extruder steps being scheduled. Previously they were scheduled, but cancelled and a step error recorded when the firmware found that they were scheduled to take place after the move was supposed to be complete. Axis movements were not affected at all.

    I agree that the Y axis shift problem is probably mechanical, most likely caused by the nozzle catching on a blob or on a small overhang that is curling up, or possibly by a problem in the motion system..



  • Ah well. Good you found one other bug from this 🙂

    Back to the planning board. What really bugs me is how intermittent this is. A month of several 10 - 20 hours prints an not a single issue then I get maybe 3 - 10 "skips" in 10 hours.

    Need to find something to mark all the belts and pulleys to see if I can spot any mechanical skips. I did this on the pulley on the rear Y shaft and it's still where it should be.

    One spot that's very difficult to see is the Y motor shaft and its pulley.



  • The chances are high that the nozzle catches on a blob or part of the print that, for whatever reason, has been over extruded and is sticking up. This will cause a collision and in any collision, something has to give. In extreme cases, if everything is tight and the motor doesn't stall or skip steps, then it'll dislodge the print form the bed. So rather than trying to find what is giving when the collision occurs, it is generally better to rectify whatever is causing the collision to occur in the first place. i.e eliminate any source of over extrusion or a build up of filament around the nozzle that falls off onto the print.



  • Hi Strips,

    did you check your wiring for the y-stepper ?

    I had a similar issue , one with the also the y-stepper and one somewhere with the power supply setup.
    After I crimpt the cable with new connectors, my issues disappeared completly.
    I used already a good crimping tool, but it looked like I worked not good enough on the first time.

    Just from my expierence.

    Regards
    Pumlux



  • Vacation over and I will start troubleshooting this printing a new x carriage for a dual zesty nimble.

    Printing some hight narrow parts that should not warp enough to cause any skipping.

    Did a quick check on the wiring a few months back and can not find any problems. But worth a try to re-crimp the connectors.



  • I'm still no viser about this issue.

    I have a few OK prints now and a few that has shifts in Y. I even removed a drooping fan shroud as I thought it might be the culprit. Have now spent some hours printing a new part and suddenly the two last layers are slightly shifted.

    Can still not find anything wrong with the wiring. Cables seem intact and pulling on them while printing.

    I can not find any lifting of bed at all. The only slight curl happened after the initial shift in Y so this could not cause the first shift.

    New desperate try. Beefing up the current on Y motor. Lowering max speed, acc and jerk substantially. Lets try again.



  • Hi,
    More then a month now since this happened.
    How much current do you use on your BB, as I just had this issue on 1.19.2 and this at 600mA. Y axis only.
    Really strange, started happing since 1st Layer at a nearly 45° angle. And became very agressive after layer 35 (1h in the print).
    Have to say, I have been printing the entire day, nothing but small prints. 1st big one since moving from Rumba to DuetWifi.
    Greetz
    T.


  • administrators

    Tim

    Things to try:

    • Turn up the Y axis current.
    • Check and possibly turn down the Y axis acceleration and max speeds.

Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.