BlTouch setup on Duet 3. Probe will not deploy with G30



  • Hi,
    I am trying to set up a BLtouch with my DUET 3. I used the configuration tool and read the trouble shooting guide. My deploy and retract files are right and I can manually deploy and retract with the M280 commands. The M401 and M402 command do not work.

    I cannot figure out what I am missing here. Please help.

    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun Mar 22 2020 13:02:56 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet 3" ; set printer name

    ; Drives
    M569 P0.0 S0 ; physical drive 0.0 goes backwards
    M569 P0.1 S1 ; physical drive 0.1 goes forwards
    M569 P0.3 S0 ; physical drive 0.3 goes backwards
    M569 P0.2 S1 ; physical drive 0.2 goes forwards
    M569 P0.4 S0 ; physical drive 0.4 goes backwards
    M584 X0.0 Y0.1 Z0.3 E0.2:0.4 ; set drive mapping
    M350 X16 Y16 Z16 E16:16 I1 ; configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E420.00:400.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X60000.00 Y60000.00 Z6000.00 E36000.00:6000.00 ; set maximum speeds (mm/min)
    M201 X700.00 Y700.00 Z200.00 E800.00:200.00 ; set accelerations (mm/s^2)
    M906 X1200 Y1200 Z1200 E800:1200 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X300 Y300 Z500 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"io1.in" ; configure active-high endstop for low end on X via pin io1.in
    M574 Y1 S1 P"io2.in" ; configure active-high endstop for low end on Y via pin io2.in
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"io7.out" ; create servo pin 0 for BLTouch
    M558 P9 C"io7.in" H5 F120 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X30 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X0:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B4092 ; configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0 ; create bed heater output on out0 and map it to sensor 0
    M143 H0 S80 ; set temperature limit for heater 0 to 80C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"temp1" Y"thermistor" T100000 B4092 ; configure sensor 1 as thermistor on pin temp1
    M950 H1 C"out1" T1 ; create nozzle heater output on out1 and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"out7" Q500 ; create fan 0 on pin out7 and set its frequency
    M106 P0 S0 H-1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"out8" Q500 ; create fan 1 on pin out8 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"out9" Q500 ; create fan 2 on pin out9 and set its frequency
    M106 P2 S1 H-1 ; set fan 2 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings
    M584 X0.0 Y0.1 Z0.3:04 E0.2 ; set drive mapping


  • administrators

    You need to tell or show us with photos how you have connected the BLTouch to the Duet 3. Also tell us exactly which firmware version you are running, as reported by M115.


  • Moderator

    @jdumoulin said in BlTouch setup on Duet 3. Probe will not deploy with G30:

    My deploy and retract files are right and I can manually deploy and retract with the M280 commands. The M401 and M402 command do not work.

    I recenetly saw someone had to rename their deploy and retract files to deployprobe0.g and retractprobe0.g


  • administrators

    @Phaedrux said in BlTouch setup on Duet 3. Probe will not deploy with G30:

    I recenetly saw someone had to rename their deploy and retract files to deployprobe0.g and retractprobe0.g

    That will be the case if you install RRF 3.01-RC4 on a Duet 3 with attached SBC and you don't also upgrade to DSF 1.2.5.


  • Moderator

    @dc42 Thanks for clarifying.



  • @dc42 said in BlTouch setup on Duet 3. Probe will not deploy with G30:

    You need to tell or show us with photos how you have connected the BLTouch to the Duet 3. Also tell us exactly which firmware version you are running, as reported by M115.

    Firmware: RepRapFirmware for Duet 3 MB6HC 3.01-RC4 (2020-03-16b1)

    IO_7 IN to BLtouch OUt (white)
    IO_7 GND to BLTOUCH gnd Black + brown wire
    IO_7 OUT to bltouch control (yellow)
    IO_7 5+ to bltouch 5+ orange

    The unit works when I issue M280 P0 S10 manually. It will detect 0 it just doesnt deploy or retract



  • @Phaedrux

    Duet 3 MB6HC v0.6 or 1.0 (MB6HC)
    DSF Version: 1.1.0.5
    Firmware: RepRapFirmware for Duet 3 MB6HC 3.01-RC4 (2020-03-16b1)

    @dc42 said in BlTouch setup on Duet 3. Probe will not deploy with G30:

    That will be the case if you install RRF 3.01-RC4 on a Duet 3 with attached SBC and you don't also upgrade to DSF 1.2.5.

    It sounds like I need to upgrade my DSF



  • @dc42

    I did upgrade DSF but no luck

    Board: Duet 3 MB6HC (MB6HC)
    DSF Version: 1.2.4.0
    Firmware: RepRapFirmware for Duet 3 MB6HC v0.6 or 1.0 3.0 (2020-01-03b3)



  • BINGO!
    I recreated the config from scratch after updating DSF. The probe is deploying and retracting now.

    THANK YOU!!!!!!!!!!!!!!!!!!!!!!



  • @jdumoulin
    Hey
    Can you share Tour g.code?
    I have the same problem.
    Thanks


Log in to reply