Keep losing Z offset



  • I don't know what happened but now I keep losing my z offset each time the printer is homed, restarted or ends a print. I can't make sense of the thing.



  • do you have the offset defined in the config.g file? the line should start with a G31 and look something like

    G31 X0 Y23 Z0.650 P25
    

    or

    G31 P500 X55 Y10 Z1.05
    

    The main parameter is gonna be the z value.



  • @Turbo Yes, here it is:
    G31 P500 X-38 Y0 Z0.95
    But the head is too close to the bed now. I don't know what happened.



  • try an extreme. Set the z offset to be way too high, in this case 0 or less, and see if where z=0 is too high. if its still contacting the bed, try a negative value (not sure if bltouch will take a negative value but its worth a shot if 0 doesnt work.)
    I always have to make a note in my config file which way goes which with a value change, like so:

    G31 X0 Y23 Z0.650 P25             ; Probe Offset - Increase for Nozzle down, Decrease for Nozzle up
    

    Report back when you finish



  • @Turbo I'll be damned. I threw a negative sign in front of the value and that seems to work. I am fine tuning now. Thanks.



  • Awesome!



  • @Turbo It appears to still be an issue. I lost Z offset after last night's print. The settings are still there in config.g. Simply saving the file again without any changes restores the Z offset. Something is resetting my G31 numbers.


  • Moderator

    What firmware are you using? What duet?
    Can you post your config.g and homeall?
    What do you have in your slicer start and end gcode?



  • @Phaedrux
    Board: Duet 3 MB6HC v0.6 or 1.0
    Firmware: RepRapFirmware for Duet 3 MB6HC 3.01-RC4 (2020-03-16b1)

    Config.g:
    G90
    M83
    M550 P"MYTH3D"

    M667 S1

    ; Networking
    M552 P192.168.1.14 S1
    M553 P255.255.255.0
    M554 192.168.1.1
    M586 P1 S1
    M586 P2 S
    M552 S1

    ; Drives
    M569 P0.0 S1
    M569 P0.1 S0
    M569 P0.2 S1
    M569 P0.5 S1
    M569 P0.3 S1
    M569 P0.4 S1
    M584 X0.0 Y0.1 Z0.2:0.3:0.4 E0.5
    M350 X16 Y16 Z16 E16 I1
    M92 X78.74 Y78.65 Z394.04 E494.74
    M566 X900.00 Y900.00 Z12.00 E120.00
    M203 X6000.00 Y6000.00 Z180.00 E1200.00
    M201 X500.00 Y500.00 Z20.00 E250.00
    M906 X800 Y800 Z800 E800
    M84 S30
    M671 X-15:150:310 Y50:310:150 1S0.5

    ; Axis Limits
    M208 X0 Y0 Z0 S1
    M208 X300 Y300 Z500 S0

    ; Endstops
    M574 X2 S1 P"io5.in"
    M574 Y1 S1 P"io2.in"

    ; Z-Probe
    M950 S0 C"io7.out"
    M558 P9 C"io7.in" H5 F120 T6000
    G31 P500 X-38 Y0 Z0.75
    M557 X15:227 Y5:210 S50

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B4138
    M950 H1 C"out1" T0
    M143 H0 S280

    ; Fans
    M950 F1 C"out7" Q500
    M106 P1 S1 H T45
    M950 F0 C"out8" Q500
    M106 P0 S255

    ; Custom settings are not defined

    ; Miscellaneous
    M501
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000"

    ; Tools
    M563 P0 S"MYTHprint" D0 H1 F0
    M563 P0 D0 H1 F0
    G10 P0 X0 Y0 Z0
    G10 P0 R0 S0
    T0

    Homeall.g:
    G91
    G1 H2 Z5 F6000
    G1 H1 X305 Y-305 F2000
    G1 H1 X305
    G1 H1 Y-305
    G1 X-5 Y5 F6000
    G1 H1 X305 F360
    G1 H1 Y-305
    G1 X-150 Y150 F6000
    M558 F500
    G30
    M558 F50
    G30
    G32

    Slicer start code:
    G28

    Slicer end code:
    G91
    G1 H2 Z5 F6000
    G1 H1 X305 Y-305 F2000
    G1 H1 X305
    G1 H1 Y-305
    G1 X-5 Y5 F6000
    G1 H1 X305 F360
    G1 H1 Y-305
    M104 S0
    M140 S0
    M84



  • Hi,

    You can always reset in your "slicer start code" to be sure it is correct.

    Frederick


  • Moderator

    You've got g32 in your home all. What is in bed.g?



  • @Phaedrux Bed.g:

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Thu Feb 20 2020 16:55:51 GMT-0800 (Pacific Standard Time)
    M561 ; clear any bed transform
    G29 ; probe the bed and enable compensation



  • I'm no expert with firmware but comparing your homeall to mine, I have a G90 before calling any G30 commands...maybe an issue with relative vs absolute positioning???

    This is my homeall.g

    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-350 Y350 F1800 ; move quickly to X or Y endstop and stop there (first pass)
    G1 S1 X-350 ; home X axis
    G1 S1 Y350 ; home Y axis
    G1 X5 Y5 F600 ; go back a few mm
    G1 S1 X-10 ; move slowly to X axis endstop once more (second pass)
    G1 S1 Y-10 ; then move slowly to Y axis endstop
    G90 ; absolute positioning
    G1 X170 Y160 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed



  • @JamesM Thanks, I'll try that.



  • @JamesM That one change threw the homing off. I reverted back to the original settings. Thanks anyway for the suggesstion.


  • Moderator

    @Weevil said in Keep losing Z offset:

    I don't know what happened but now I keep losing my z offset each time the printer is homed, restarted or ends a print. I can't make sense of the thing.

    What exactly do you mean by this? Do you mean that the first layer isn't good? Do you mean that G31 is literally blank?

    @Weevil said in Keep losing Z offset:

    But the head is too close to the bed now. I don't know what happened.

    Head crash? Loose print head? Probe mount shifted?

    I'd recommend removing G32 from your homeall. All it does is clear the current transform and then runs mesh compensation. May be overkill to re probe the entire bed every time you homeall. You could use G29 S1 instead at the end of homeall which would load a saved heightmap.

    G31 P500 X-38 Y0 Z0.75

    Change the P500 to P25 to make the BLTouch trigger a bit more sensitive.



  • @Phaedrux I'll try that. Thanks.


Log in to reply