Duet Wifi Wlan vs WPA2 = Connection Error



  • As the titled say: i got a connection problem with my Duet Wifi. A friend and i configured the Board and linked it up to his home w-lan without any problem. We do all the necessary things to get the printer started and it worked.

    When i get home, i just entering the commands as shown:

    M552 S-1
    M552
    M552 S0
    M552
    M587 S“My SSID“ P“ My Password“
    M587
    M552 S1

    After that i get connection error (see protocol below). Several attempts later I changed the SSID and passwords but nothing worked.

    So I decided to set up a WiFi HotSpot with my Galaxy S7 and zoom … the Duet connected to the Smartphone after 3 Secs.

    So I tried to connected back to my home Wifi and get the typical message: error

    I retry the Smartphone which was working fine and then decided to try a connection to my neighbors WiFi and again: zooom connection after 3 secs (ask for his Password and SSID)

    I went further and enabled MAC in my Router Option … nothing … the only way for connecting was to disable the WPA / WPA2 protocol in my router and surprise: we get a stable connection after 3 secs …

    Hopefully someone has a idea to fix this, I use a Vodafone Router with the newest firmware. Other devices as our smartphones, the normal HP printer and Smart- TV / TV- Stick work still fine with the router settings.

    YAT Protocol

    M552 S-1
    WiFi module stopped
    ok
    M552 S-1
    ok
    M552 S0
    ok
    WiFi module started
    M552 S1
    ok
    WiFi reported error: Timed out while trying to connect to DWTN
    WiFi module is idle
    WiFi reported error: no known networks found
    WiFi module is idle
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet WiFi 1.02 or later
    Board ID: 08DJM-9178L-L2MSD-6JKD0-3S46Q-TTFGP
    Used output buffers: 2 of 24 (3 max)
    === RTOS ===
    Static ram: 25712
    Dynamic ram: 93176 of which 0 recycled
    Exception stack ram used: 304
    Never used ram: 11880
    Tasks: NETWORK(ready,1280) HEAT(blocked,1232) MAIN(running,3824) IDLE(ready,160)
    Owned mutexes:
    === Platform ===
    Last reset 01:35:48 ago, cause: power up
    Last software reset time unknown, reason: User, spinning module GCodes, available RAM 11872 bytes (slot 3)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 24.0, current 26.2, max 27.0
    Supply voltage: min 0.1, current 0.5, max 0.7, under voltage events: 0, over voltage events: 0, power good: no
    Driver 0: ok, SG min/max not available
    Driver 1: ok, SG min/max not available
    Driver 2: ok, SG min/max not available
    Driver 3: ok, SG min/max not available
    Driver 4: ok, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 4294967295
    Slowest loop: 99.79ms; fastest: 0.05ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 160, MinFreeDm: 160, MaxWait: 0ms
    Bed compensation in use: mesh, comp offset 0.000
    === DDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is ready with "M122" in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 15.34ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8

    • WiFi -
      Network state is changing mode
      WiFi module is idle
      Failed messages: pending 0, notready 0, noresp 0
      Failed to get WiFi status
      Socket states: 0 0 0 0 0 0 0 0
      ok
      Error retrieving WiFi status message: bad reply format version
      WiFi module is idle
      Failed to change WiFi mode (code -4)


  • i think this is the second report of an incompatbility with vodafone routers. no solution as far as I know.

    Doubt its relevant, but any special characters in the key?



  • No, just a standard Key like "A1234567b" (was my testing Key)



  • is the SSID hidden? that can sometimes cause issues



  • WiFi reported error: Timed out while trying to connect to DWTN

    it wouldn't try to connect to DWTN without it specified on the M552 command if it was hidden



  • SSID is broadcasted
    The Router know the MAC of the Duet
    The Duet is remembering the SSID (and Password)

    Executing config.g...Error: M587: Failed to add SSID to remembered list
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    M552 S-1
    WiFi module stopped
    ok
    M552 S0
    ok
    WiFi module started
    M587
    Remembered networks:
    DWTN IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0

    ok


  • Moderator

    @Warstone as @bearer said, there seems to be an issue with Vodafone Station routers. This may be related to an obscure bug in the Duet WiFi firmware. See this thread https://forum.duet3d.com/topic/14993/cannot-connect-duet-wifi-to-new-wifi-router

    Ideally, use an access point to connect for now.

    Ian



  • Hooked up my old D-Link Wifi router between the Vodafon router and my PC. It slows down my connection a bit, but the Duet is connecting without any problems to the D-Link instead of the Vodafon Router.


Log in to reply