Bed Heater Error



  • I have a small heated bed on an Ender 2 runnning a Duet Maestro RRF3.01-RC9

    Whenever I set the bed to heat up I get the
    Error: Heater 0 fault: temperature rising much more slowly than expected 1.5°C/sec

    However the bed actually seems to be heating at a fairly normal pace. I've run a PID autotune on the heater (Gets up to 70+ degrees just fine without the safety net of heater fault codes. Temperature validated with IR thermometer) . However as soon as I hit about 30 degrees normally the error shows up.

    Previously my heater faults have been caused by a hidden PID tune M307 command later in the config file but that doesn't appear to be the case this time.[0_1587743726845_200424_164332.mp4](Uploading 100%)

    Relevant snippet from Config.g:

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138     ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                              ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120                                       ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00                                   ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                            ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138      ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                               ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280                                       ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00                                   ; disable bang-bang mode for heater  and set PWM limit
    

    config-override.g:

    ; Heater model parameters
    M307 H0 A109.4 C501.1 D0.2 S1.00 V11.9 B0
    M307 H1 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    

    [0_1587743741822_200424_164332.mp4](Uploading 100%) [0_1587743777640_200424_164332.mp4](Uploading 100%) 200424_165726.gif


  • Moderator

    Try copying the M307 commands from config-override into your config.g

    Do you have an M501 at the end of the config.g to load the config-override?

    The dead time (D) on that M307 H0 command looks very low at 0.2 seconds. Try increasing it to 2 seconds.


  • Moderator

    Also, can you post your full config.g please?



  • hello,

    I have the same problem, the same error appear to me:
    Error: Heater 0 fault: temperature rising much more slowly than expected 1.8°C/sec
    I changed my heated bed, I bought a new heated bed to use 12 volts instead the old heated bed thath operated in 24 Volts, the reason is thath in Brazil it is very complicated and expensive to buy things from other country, then I decided to produced my own heated bed. ( the same model works very well in other cartesian printer). The problem start around at 30 celsius degrees.
    I have a difference in the hardware now. The new heated bed has 250 watts and I am using a solid state relay controlled by the duet2wifi board because I need approximately 21 amps of current and the duet board does not have this capacity.
    My Config.g in Heaters is:
    Config.g:
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    And my config-override.g:

    ; Heater model parameters
    M307 H0 A109.4 C501.1 D2 S1.00 V11.9 B0
    M307 H1 A340.0 C140.0 D5.5 S1.00 V0.0 B0

    I do not have an M501 at the end of the config.g to load the config-override. I already tried to put the 307 commands in config.g but the problem
    has not disappeared


  • Moderator

    @Milke Please start a new thread. Include your firmware version, what board you're using, etc



  • @Phaedrux :
    I solved my problem, I add the command M501 at the end of my config.g.

    I use in my Duet2WiFi the firmware version 3, RepRapFirmware Configuration Tool v2.1.8.

    I made the autotune in the BED and I add the Heater model parameters at the config-override.g.

    Now it's working well, thanks for the support.
    thank you for your support. I read your previous recommendations on the topic.