Newbie Seeking Help



  • Hi
    Im trying to get my Duet 2 v2.0 running. I can connect via YAT USB COM8 port. I've tried sending my wifi details & the M587 command seems to accept but when i request register, it comes back with IP NULL.

    I have my IP set for 192.168.1.120 & it receive "Your Duet rejected the HTTP request: page not found".

    Blue light is ON solid. i.e. not flashing. The band i am connecting the Duet 2 is 2G.

    I did a DuetWiFiServer.bin update but same problem exists.

    I have been trying for days to get the http working & updating the firmware to V3.01 RC1 without success.

    4de7c878-376c-43e4-87a2-c3887ddf9d41-image.png

    i also have a microsd car with /www & /sys folder in the root section.

    What can i do now?

    Thanks,

    Tony.



  • @turbo3000

    Have you extracted the latest DWC into the /www folder?

    Can you should the contents of that folder?



  • b02fc369-b7e9-4e15-a478-41e9869f1556-image.png

    5eb21912-f77f-4348-9206-9ad8b24cadb3-image.png

    Is it correct?



  • That looks correct.

    Your config files should be part of the sys folder and not in their own separate directory.

    Can you get an output of M122 and M115? That can be done through YAT


  • administrators

    I suggest you check that the files in /www are accessible on the Duet. To do this, send the following command from YAT:

    M20 P"/www"



  • @dc42 said in Newbie Seeking Help:

    M20 P"/www"

    395b212b-5505-4ea6-94d5-097a0019ea36-image.png

    054c743e-434f-4a86-a125-9f4751fe7265-image.png

    b446cd23-7470-4f10-a669-3c3676a68fc0-image.png

    1c6491b9-679c-488a-ad78-7935f20405d0-image.png

    Thanks guys but im stumoed on this one.



  • 5d00b20f-55b0-4aa3-a902-0a34dcf780f9-image.png

    So i have /www separate & /sys separate.

    The /config/sys & /config/www directory & files, i was just trying to see if that would solve the problem.



  • This post is deleted!


  • 79bb7472-d875-4c0e-ad05-30dccf179a09-image.png

    It does remember my SSID, just not my IP address.

    Do i need to port forward? i have an Asus GT-AC5300 router.



  • 056299a5-14c7-40e6-a061-0eae0dd8e902-image.png

    This is interesting. Does this mean i can't see my /sys files?

    If so why?



  • They should not be sub-directories of /config.



  • It does imply that.

    I would suggest copying everything off the SD card and formatting it with the SD card formatter https://www.sdcard.org/downloads/formatter/

    I would also suggest only copying across the /sys and /www folders.



  • Thankyou. I have deleted those other files. Checked /sys folder again.

    2205c03a-3917-41be-8970-c08cdf9a26a7-image.png

    But still no DWC !!!!



  • @turbo3000 I would go back to basics. Please post your config.g just incase.....
    M588 "*"

    M587 with only the S & P parameters, so it gets the address from the router as opposed to being defined, just incase........................

    Get DWC working first then progress from that.

    So M20 "/www" does not show anything? It did on your post @ 16:40.:confused:

    Regards,
    Paul



  • ; Configuration file for Duet WiFi (firmware version 2.00)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Fri May 01 2020 01:28:58 GMT+1000 (Australian Eastern Standard Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network

    ;M552 P192.168.1.120
    ;M554 P192.168.1.255
    ;M553 P225.255.255.0

    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes backwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z4000.00 E98.00 ; set steps per mm
    M566 X600.00 Y600.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E1500.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X950 Y950 Z950 E950 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X330 Y330 Z400 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; set active low and disabled endstops

    ; Z-Probe
    M558 P5 H5 F0 T6000 ; set Z probe type to switch and the dive height + speeds
    G31 P600 X0 Y0 Z0 ; set Z probe trigger value, offset and trigger height
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss


  • administrators

    Which browser are you using?

    Does it work any better if you enter this in the address bar:

    http://192.168.1.120/index.html

    PS - firmware version 2.0 is rather old!



  • 7a7c1ed0-8a6d-47b5-bac8-0c542ac7f53d-image.png

    i got something !!!!


  • administrators

    I think the reason may be that the version of Duet Web Control you are using is much later than the version of the main firmware. Firmware 2.0 was designed to work with a much older version of DWC.

    I suggest you upgrade to firmware 2.05.1. Download Duet2CombinedFirmware from https://github.com/dc42/RepRapFirmware/releases/tag/2.05.1 and copy it into /sys on the SD card. Put the card back in the Duet, start the Duet, and send M997 from YAT. After 30 seconds, reconnect form YAT and send M115 to see if the update was successful.



  • @dc42 said in Newbie Seeking Help:

    M115

    6e3cad42-b183-4a75-80fc-06b83c059eb4-image.png

    Ok the firmware update worked perfectly, however, this problem remains!

    85b79122-5be2-47c3-86fc-68f2fb8c8c34-image.png



  • should i force the static IP in the config.h file?


Log in to reply