Bed temperature rising much more slowly 1.8°C/sec



  • Hello ,
    I have a CORE XY with a 24V heated bed .
    It was working correctly in RRF2.

    After upgrading to RRF 3.1.1 now I have the following :
    Error: Heater 0 fault: temperature rising much more slowly than the expected 1.8°C/sec

    Any Idea ?
    Extract of the config file below 🙂
    Thanks a lot in advance.

    Chris
    -------------RRF 2.x configuration---------------
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120

    -----------RRF3.1.1 configuration------------
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0

    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120



  • PID tune your bed.

    E.g M303 H0 S60



  • Ok, I did M303 HO S60.
    Results were added in the config.g with the M304 command.
    I also changed the bangbang mode to PID in the M307 ...

    and I still have the same issue...



  • The last time I saw this error it was because one of the part-cooling fans was blowing on the bed and that was slowing the temperature increase.

    The time before that it was because one of the heater wires wasn't tightly secured.

    It's not something simple (but easily overlooked) like that, is it?


  • Moderator

    What does your temp graph look like?

    What is your bed heater?

    What is your PSU?

    How is it wired?

    What is the thermistor?



  • @Phaedrux said in Bed temperature rising much more slowly 1.8°C/sec:

    What is the thermistor?

    Hello and thanks to all.
    It is a bed from a Tronxy X5s.
    The bed is power by a separated PSU 24V , driven by a Mosfet.
    The PSU is configured to be 20V approximatively to have a current of 15A.
    All wires are silicon coated wire 12AWG.
    The mosfet is connected to the duet wifi , which is powered by a 12V PSU.
    Thermistor is the one that came with the bed.

    The thing is that it worked out of the box with RRF2.x .....
    I did not change anything...so must be in the configuration....


  • administrators

    @zoidberg38 said in Bed temperature rising much more slowly 1.8°C/sec:

    Ok, I did M303 HO S60.
    Results were added in the config.g with the M304 command.
    I also changed the bangbang mode to PID in the M307 ...

    and I still have the same issue...

    Tuning the bed heater doesn't generate a M304 command, it generates a M307 command, which you can save to config-overridd.g using M500.



  • @dc42 said in Bed temperature rising much more slowly 1.8°C/sec:

    verridd.g using M500.

    Hi , Yes , I did that too 🙂
    I am still getting :

    Error: Heater 0 fault: temperature rising much more slowly than the expected 1.8°C/sec

    Is there a way to disable the check of the 1.8degC/sec ?



  • @zoidberg38 said in Bed temperature rising much more slowly 1.8°C/sec:

    @Phaedrux said in Bed temperature rising much more slowly 1.8°C/sec:

    What is the thermistor?

    Hello and thanks to all.
    It is a bed from a Tronxy X5s.
    The bed is power by a separated PSU 24V , driven by a Mosfet.
    The PSU is configured to be 20V approximatively to have a current of 15A.
    All wires are silicon coated wire 12AWG.
    The mosfet is connected to the duet wifi , which is powered by a 12V PSU.
    Thermistor is the one that came with the bed.

    The thing is that it worked out of the box with RRF2.x .....
    I did not change anything...so must be in the configuration....

    This may be a silly Question but why have you turned the PSU down to 20V you would be better having it at 24V at reduced current. If you do that you will probable find it will heat considerably faster as well.

    Doug



  • Solved thanks !

    Not sure why the initial M500 did not put the right values in the config overide .g.

    M307 H0 A183.0 C1149.1 D7.0 S1.00 V12.2 B0


Log in to reply