Burned board?



  • Hello,

    I have issue with board.
    Board: Duet WiFi 1.02 or later + DueX2 (duetwifi102)
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 3.0 (2020-01-03b3)
    Duet WiFi Server Version: 1.23

    Both bed and nozzle temperature are -273,1C.
    Whatever I would do in a config it does not change.

    My heaters looks like:
    M308 S0 P"bed_temp" Y"thermistor" A"Bed" T100000 B3950 ; define bed temperature sensor
    M950 H0 C"bed_heat" T0 ; heater 0 uses the bed_heat pin, sensor 0
    M308 S1 P"e0_temp" Y"thermistor" A"Nozzle" T100000 B4725 C7.06e-8 R4700; define E0 temperature sensor for nozzle
    M950 H1 C"e0_heat" T1 ; heater 1 uses the e0_heat pin and sensor 1

    VSSA fuse looks ok (I dont have open circuit).
    How can I check if board is burned? I have 3 more burned boards, maybe I can fix it?



  • change your pin names from bed_temp to bedtemp and so on.



  • Changed it to:

    M308 S0 P"bedtemp" Y"thermistor" T100000 B4725 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.06e-8 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    Still the same



  • -273.1c

    looks very much like the thermistors are not physically connected thus not being seen by the board.

    I would recommend you double check any connections between the board and the location of the thermistors for continuity.

    For testing/diagnostic purposes I have a spare thermistor wired up with a short leads to a duet connector, this allows you to plug in a known good thermistor and eliminate it being the printers thermistor or confirm you have a board/config issue.

    Here is a copy of a WORKING heaters section of code on a standard i3 style printer on a Duet2-Wifi board


    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bed-temp
    M950 H0 C"bedheat" T0 ; create bed heater output on bed-heat and map it to sensor 0
    M143 H0 S100 ; set temperature limit for the bed to 100C
    M307 H0 A78.8 C572.2 D4.9 V24.1 B0 ; settings for the bed after auto-tune
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 ; set temperature limit for the hot end to 280C
    M307 H1 A296.7 C79.4 D4.9 V24.1 B0 ; settings for the hot-end after auto-tune




  • @CaLviNx said in Burned board?:

    -273.1c
    looks very much like the thermistors are not physically connected thus not being seen by the board.

    a short perhaps, i think an open circuit reports 2000c due to the negative coefficient -273.1 would probably be a short - but thats all theory and speculation from my end



  • @bearer

    possible but i have seen open circuit thermistors show the -273.1 value along with 2000 and an odd 3xxxx

    either way diagnostics on those circuits are required checking for continuity (and shorts)



  • @CaLviNx You are right.
    It was 2 faulty thermistors! Who could have thought :))

    Made a short wired spare thermistor both chanells works fine 🙂

    CASE CLOSED


  • Moderator

    @CaLviNx said in Burned board?:

    M143 H0 S100 ; set temperature limit for the bed to 100C
    M307 H0 A78.8 C572.2 D4.9 V24.1 B0 ; settings for the bed after auto-tune
    M140 H0 ; map heated bed to heater 0

    M140 H0 must come before you set the max temp with M143

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                          ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00                               ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                        ; map heated bed to heater 0
    M143 H0 S120                                   ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                               ; disable bang-bang mode for heater  and set PWM limit
    


  • @Phaedrux said in Burned board?:

    @CaLviNx said in Burned board?:

    M143 H0 S100 ; set temperature limit for the bed to 100C
    M307 H0 A78.8 C572.2 D4.9 V24.1 B0 ; settings for the bed after auto-tune
    M140 H0 ; map heated bed to heater 0

    M140 H0 must come before you set the max temp with M143

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                          ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00                               ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                        ; map heated bed to heater 0
    M143 H0 S120                                   ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                               ; disable bang-bang mode for heater  and set PWM limit
    

    if that's the case you might want to tell that to the guys who put the online config tool together, as that is where that list of code came from.....


  • administrators

    The current config tool does put the M140 H0 command before the M143 H0 command. It has been updated recently, so perhaps it didn't when you ran it.


  • Moderator

    @CaLviNx said in Burned board?:

    @Phaedrux said in Burned board?:

    @CaLviNx said in Burned board?:

    M143 H0 S100 ; set temperature limit for the bed to 100C
    M307 H0 A78.8 C572.2 D4.9 V24.1 B0 ; settings for the bed after auto-tune
    M140 H0 ; map heated bed to heater 0

    M140 H0 must come before you set the max temp with M143

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0                          ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B0 S1.00                               ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0                                        ; map heated bed to heater 0
    M143 H0 S120                                   ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00                               ; disable bang-bang mode for heater  and set PWM limit
    

    if that's the case you might want to tell that to the guys who put the online config tool together, as that is where that list of code came from.....

    That came straight out of the config tool today, so it has been fixed.



  • @dc42

    I ran that last week, I'm still not convinced to fully make the jump over to RRF3 but I have to keep an open mind so I play with it when I have time, and as I'm getting older (or old fart as recently called...) I have learned to not remember everything for fear of overload (that's my excuse and i'm sticking to it)

    I'm still using the online tool to generate the RRF3 config.g to help me compare the differences between the old/new code, and I dont remember shifting any heater code around.

    I see the mention of it being required to come before the M143 command on the G code dozuki page, what is the official reason for this order requirement.


  • administrators

    @CaLviNx said in Burned board?:

    I see the mention of it being required to come before the M143 command on the G code dozuki page, what is the official reason for this order requirement.

    So that we can set a lower default maximum temperature for a bed or chamber heater than we do for an extruder.


Log in to reply