Creality BLtouch kit compatibility and wiring



  • On a previous upgrade to my stock Cr10 S5 I purchased and installed the official Creality BLtouch kit. I've tried following the wiring diagram on betrue3d website but the colors of the wires are different than on a normal Antclab version (yellow, red, and blue). It should also be noted I have them plugged into a series of two antclabs official extension cables (brown, red, and orange). I've cut the connecting pins off of both cables now and have tried every combination of wires with each other.
    I know the wiring of the kit was meant for the stock Creality board but now I've successfully installed a duet wifi and duex5 board. Is the Creality kit completely incompatible or is there some possible way of making the wiring work with the duet?



  • I should also mention I'm using pwm channel 1 on the duex5 board and I set up the configurator with the bltouch. Everything looks correct as far as I can tell but here's my config.g file for review. config (1).g
    I've also confirmed there's not a break in any of the wires or extensions. I can connect the brown cable coming from the extension on the board to either the yellow or red creality cables and it will change the z probe value in the Duet web Control from 0 to 1000. The bltouch simply won't light up or extend the probe.
    I'm running reprap version 2.0 software (apparently all later software stops my endstops from working).



  • @usescoasters one problem I see in your config file is the line
    M557 X5:485 Y5:485 S5
    which means a probe spacing every 5 points, which is (485-5)/5 = about 100 probes in every direction, so 10000 in total. You should set S value higher or use the P parameter. The limit is "There is a firmware-dependent maximum number of probe points supported. Currently this is 121 on the Duet 06/085 (enough for a 11x11 grid) and 441 for the Duet 2 WiFi and Duet 2 Ethernet (enough for a 21x21 grid)" from https://duet3d.dozuki.com/Wiki/Gcode#Section_M557_Set_Z_probe_point_or_define_probing_grid

    The deploy and retract of the Z proble is handled in the deployprobe.g and retractprobe.g, can you publish them please?



  • Here's the deployprobe.g. Here's the retractprobe.g .



  • @usescoasters from the documentation for my BLTOUCH, the colours are:
    3pin: brown = GND, red = 5+V, orange=control signal
    2pin: black=GND, white=Zmin

    In the link you published is a picture of the electronics (PCB) backside, you can check which color of the cable belongs to which pin.



  • @usescoasters the deployprobe and retractprobe look ok. You can test the M280 commands very fast by putting them into DWC in the "Send GCode" field. Before probing, the BLTouch shall be in retract position.

    Documentation for BLTouch is in https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_BLTouch
    There is also a chapter about Duex5.





  • @JoergS5 Already tried that with every wiring configuration possible, no movement. The bltouch is just totally unresponsive as if it weren't plugged in. Isn't there supposed to be a red or blue LED that lights up when powered on?



  • @usescoasters I have only a BLTouch from antlabs, not Creality. But according to the description of the Creality, if the LED blinks, this means an error in the selftest or during operation.

    I would not try every wiring combination. According to the Duet documentation, something on the controller board could be damaged.

    Can you make a few pictures, then we can discuss how to find out the correct colors.

    There is an additional possibility why your BLTouch doesn't work. Older versions are 5V based and a modification must be made, see e.g. https://forum.duet3d.com/topic/14781/bltouch-3-1-creality-on-duet-2
    and please check https://forum.duet3d.com/topic/9591/bltouch-logic-conversion/4 also



  • @JoergS5 According the the description on the amazon page, as well as a video from Teaching Tech, the kit comes with a genuine v3.1 bltouch. The documentation seems to say it should be plug'n'play with my version (duet wifi 1.04+)
    Brown being ground was what I first surmised. Although I only have very basic electrical skills it's my understanding that generally the darkest color wire is usually Ground. In the photos below you'll see how I have the extension cable plugged in left to right, according to the pinout they line up as Brown being Ground-then red-then orange. The very first order of wire combinations I tried was-brown to blue, red to red, orange to yellow as seen below.
    No matter what combination I wire them in the M280 command does nothing at all.
    20200612_175912.jpg
    20200612_175924.jpg
    20200612_180004.jpg
    20200612_180013.jpg
    20200612_180025.jpg
    The thing is totally unresponsive except for touching Ground from the board to either the yellow or red wire connected to the Creality cord on the bltouch. Doing so changes the z probe value in the DWC to 1000. I don't have the coding or electrical knowledge to know what that means except there is some kind of signal being sent back to the board.



  • @usescoasters at my bltouch I see a pair of cables and three cales come out, so the two are the endstop, the three the sensor. The sensor the middle being vcc.

    looking at your 5 cables coming out, i would expect white and brown being the endstop, the other three the sensor with middle orange being vcc. Which of yellow or blue are ground and signal - I dont know.

    but to be sure, I would open the bltouch (2 very little screws) and check. I searched a bit whether it is possible to measure with a voltage meter without opening, but I did not find information yet. Do you have one, then I can give you my values tomorrow.



  • @JoergS5 I do have a voltmeter but that would be my absolute last resort as I'm sure I would damage it. I can't be certain but according to betrue3d.com the pair of black and white wires go into the last two pins of the duet wifi's z probe input (next to the paneldue connector) with the black (Ground) in the pin closer to the 40 pin expansion header. I can't be sure if this is correct or if the article is outdated. The kit came with them physically separated to their own two pin connection away from the other three of the 5 total wires in the creality kit cable
    As for the other three (yellow, red, and blue) they would seem to go into the pwm 1 channel input on the duex. I set this up in the configurator and according to my config.g that corresponds heating channel three.

    I'm a little confused at what you said about brown and white. Those two are not on the same cable. If you mean black and white then yes I agree they correspond to the endstop signal but again the documentation says to connect z probes to a different set of 4 pins. (above last picture)

    To be clear, the creality cable coming off the bltouch itself-from left to right-is yellow, red, blue. The brown Ground cable is on the other extension cable plugged into duex5. (above) If I connect that brown (Ground) wire of the extension cable from the board to the red or yellow leads of the creality cable I get a value of 1000 for z probe.

    On each of the cables the middle wire is red and orange respectively. Acccording the the pinout above that is 5v AUX. The amazon store page also states that the bltouch itself is 5v. AS I have it now these two middle cables are wired to each other, and the blue cable is wired to Ground. So what your calling the sensor vcc cable is wired to the 5v AUX pin.

    The last wire on either cable is yellow (creality) and orange (extension cable on duex board) and they are wired together. on the board pinout that is E2 PWM.
    Here's another picture if it helps.



  • Here's some more pictures.
    20200612_195202.jpg
    20200612_195219.jpg
    20200612_195251.jpg
    20200612_195134.jpg



  • @usescoasters the cable seemed to be brown, but at second view I agree black.

    I lost the overview now, seems to be too late to concentrate.

    To be sure, I would open the bltouch and check the pin labels.



  • @usescoasters I looked at your cabling, seems to be ok.

    Comparing to https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Software_setup_Duet_2_WiFi_Ethernet_running_RepRapFirmware_Num_2 your P vaue for G31 is very high, I would try a P25 value.

    I have only one idea left: maybe you damaged something with the wiring tries and should try other pins. If you use the servo on the main board instead of Duex, you may then need the I1 parameter in the deploy and retract M280 commands.

    And another: I would try updating to RRF3. The endstop problem can come from: sometimes you need to use ^ and ! signs now and S0 is replaced by those signs (but you use only S1), but it's documented good.



  • This post is deleted!


  • @JoergS5 It's been a few days now and after waiting for a new bltouch altogether from a different manufacturer with the official antclabs cord included I got the thing 90% working. It powers on and delivers a signal to the board when touched which registers in the DWC. I've also got a homing macro working to so I can get the probe to 0,0,0 and accurately report the position of the nozzle with the x, y, and z offset. Now I'm at the stage where it's mounted on the machine and will stop the xz bar when triggered.

    The only problem left is that the mechanical pin will not deploy still. I can use the M280 P3 S10 I1 command to turn on the orange power LED and set the signal input to 0 (which seems to mean plugged in as with the pins pulled out it's 1000 and flashes red on screen to indicate an open ciruit). But the pin won't move at all, I still have to do that by hand.

    I've tested the orange wire coming from the pwm pin on the duex5 board with a multimeter and its only putting out 1.97 mA. According the Antclabs website they list the consumption current of the Smart V3.1 as 20 mA. I'm not sure exactly how to interpret that other than that the pwm signal is way too low for the bltouch to pick up. I've already Tried an M280 P3 S140 I1 command to put in 5v logic mode to see if that makes any difference and it doesn't seem to. Due to my lack of electrical experience I'm not sure what to do.

    I've read in some places that a resistor used to be needed to get the older models of bltouch working with the board. Would that be worth trying?


  • Moderator

    Please post your current config.g, homeall.g, as well as deploy and retract probe files. Also please indicate again where you have the BLTouch wires connected? And what firmware version?

    If you are using the Duex pwm pins it may be as simple as removing the I1 from your deploy and retract commands. But I'd like to have your full information to say for sure.



  • @usescoasters in addition to Phaedrux's comment I have found two interesting possibilities:

    • https://www.antclabs.com/bltouch-v3 is a good information page about the bltouch and I read, the different versions of BLtouch have different pin lengths, 3.1 1.6 mm longer than a 2.0 version. Maybe you have to correct some parameters (maybe M558 H parameter?)
      and there is the following comment in an image (so I can only store the screenshot here):
      bltouchcomment.jpg
    • one problem came from the BLTouch being on the same side as the hotend and hotend fan, being disturbed by them


  • @Phaedrux i'm not absolutely sure what firmware version I have running on the board anymore as I've gone through and tried virtually every supported version but I think it's 2.0.

    In regards to the deployprobe.g and retractprobe.g I can't seem to get them to work without using the I1 command in spite of the fact they are plugged into the pwm channel 1 slot on the duex 5 board. I also customized the homez.g file as follows:
    M280 P3 S10 I1 ; clear the value stored and deploy pin for measurement
    M280 P3 S160 I1 ; clear the alarm that is triggered when the self test fails
    G30 ; probe the bed
    Do a Z hop
    G92 Z8 ; set the z value as that which I measured with a caliper between the tip of the probe and the end of the nozzle (so as to accurately report the position of the nozzle itself)

    As of right now my wiring corresponds correctly to everything in the official documentation as well as the betrue3d website tutorial with all colors matching the original antclabs color scheme (Orange PWM, Red 5v Aux pin, Brown to Ground, and black and white into the z probe input on the duet wifi).

    For some reason my phone's mobile hotspot is being buggy and my connection to the server is going out repeatedly when I try to post anything like a picture or file. I'll try try to post pictures, gcode files, and a video of the homing sequence later.



  • @Phaedrux The connection is sort of working now. Here are my gcode files and photos
    config.g
    config-override.g
    deployprobe.g
    homeall.g
    retractprobe.g
    homez.g
    20200618_161543.jpg
    The brown wire had a tear in the lining so I cut, spliced, and twist tied it for good contact
    20200618_161603.jpg
    It's a little hard to see but the header is definately in the pwm 1 channel slot.
    20200618_161638.jpg
    It looks like a genuine bltouch I think.



  • @JoergS5

    • one problem came from the BLTouch being on the same side as the hotend and hotend fan, being disturbed by them
      rom end of allen in direction to bltouch) allen key diminishes movement, counterclockwise (seen from right in direction to bltouch) make movement bigger.

    What precisely do you mean by being on the same side as the hotend? I know the current from the wires as well as the heat from the hotend can interfere with the Hall Effect sensor but the hotend is completely off when I run my tests.

    Are you saying the bltouch should be mounted on the other side of the x carriage or that it should be on the other side of the bar entirely?



  • @usescoasters I read that if the heater is on it can disturb (or it's fan), but it your is off this cannot be a problem.

    I tested turning the allen-key, at the clone I can turn many times so it is from no deploy-retract movement, to maximal movement. My genuine BLtouch Smart 2.0 has only limited turning, the mentioned 180°. How 3.1 behaves, I don't know.



  • @JoergS5 On the first of the two bltouch's I've had I decided to look inside to check the traces as you suggested and I started by completely undoing the metal core part you mentioned. It came out with almost no trouble. This allowed the pin itself to fall out the back hole. When I was done looking I put the pin and the metal screw back in place. I'm not sure how many times I turned it.

    To be honest, I'm not entirely sure which of the two bltouch's I have is actually on the machine right now - the first one in the creality kit or the second manufacturer. In my efforts to first get either one working I tested their sensitivity to touch side by side and one was much more responsive. This was the one I equipped.

    If I try turning the screw with an allen wrench I can turn it numerous times in 360 degrees in both directions. So far neither tightening it or loosening it has made it any more responsive to the S10 or S90 commands. It does have a red/orangish LED that slowly flashes whenever I deploy it. I can't be sure if this is the error code saying it has failed the self test or if this is normal behavior when it is turned on. The LED glows brighter or fainter in correspondence to whether the pin is pushed in or not. So far I've assumed that was a good sign of normal behavior as it happened on the both of the ones I tested.

    Another somewhat consistent problem is that the sensor is almost too sensitive. It triggers within just a second of the gantry beginning to lower from any height. I'll still try to make a video of the homing process with my phone.



  • @usescoasters I could turn my clone several times and the genuine only one time, so your numerous-360 may be the clone also.

    I saw in your image that the connector is not fully inserted into the socket, this was a problem in another thread also, please check. Maybe you pull it out first and check, maybe a pin is bent.


Log in to reply