Thermistor showing 2000



  • Need help diagnosing a thermistor problem I am having. I recently built a new printer using an existing Duet Wifi board that I had on hand and paired it with a new Duex5 board. I did all of the movement tests and all is working fine so I moved on to the hotend. Once I got my hotend installed I did a test to heat it up to 100c to make sure the fans were working but once it got heated up I got a heater fault and now the temperature reads 2000 which is usually when it is not detecting a thermistor. I tried a different thermistor in case I had a bad one with the same results so I moved that hotend over to my other printer and all reads fine.

    Could this mean that this is a board issue?
    If so, is there a way to check to verify there is an issue with my board?

    682d00c7-e10d-4d00-92c9-a962413221b5-image.png

    ;Heaters*******************************************************************
    M305 P0 S"BED" T100000 B4138 C0 ; Set thermistor
    M143 H0 S110 ; Set temperature limit for heater 0 to 225C

    M305 P1 R4700 T100000 B4388 ; Set thermistor
    M143 H1 S280 ; Set temperature limit for heater 1 to 300C
    M307 H1 A452.5 C154.2 D6.2 V24.1 ; Set PID parameters for heater 1

    M305 P2 R4700 T100000 B4388 ; Set thermistor
    M143 H2 S280 ; Set temperature limit for heater 2 to 300C
    M307 H2 A527.5 C194.1 D8.9 V24.1 ; Set PID parameters for heater 2

    M305 P3 R4700 T100000 B4388 ; Set thermistor
    M143 H3 S280 ; Set temperature limit for heater 3 to 300C
    ;M307 H3 A527.5 C194.1 D8.9 V24.1 ; Set PID parameters for heater 3

    ;Tools*******************************************************************
    M563 P0 D0 H1 F4 ; Define tool 0
    G10 P0 R0 S0 ; Reset initial tool 0 active and standby temperatures to 0C

    M563 P1 D1 H2 F6 ; Define tool 1
    G10 P1 R0 S0 ; Reset initial tool 1 active and standby temperatures to 0C

    M563 P2 D2 H3 F8 ; Define tool 1
    G10 P1 R0 S0 ; Reset initial tool 1 active and standby temperatures to 0C

    ;Fans*******************************************************************
    ;M106 P0 S0 I0 F500 H-1 ; UNUSED
    M106 C"T0 FAN" P3 S1 I0 F500 H1 T70 ; T0 HE
    M106 C"T0 LAY FAN" P4 S0 ; T0 PCF
    M106 C"T1 FAN" P5 S1 I0 F500 H2 T70 ; T1 HE
    M106 C"T1 LAY FAN" P6 S0 ; T1 PCF
    M106 C"T2 FAN" P7 S1 I0 F500 H2 T70 ; T2 HE
    M106 C"T2 LAY FAN" P8 S0 ; T2 PCF


  • Moderator

    Is it showing 2000 all the time, or only after you try heating it?
    Just to clarify, you've tested another working thermistor on the duet and it does the same thing? And/or you've tried the thermistor on another printer and it works fine?

    Can you see any visible damage on the board itself?



  • Yeah, it was showing a temperature and I was watching it rise from around 24 up to the 100 mark when it then went to heater fault. I should have looked in the DWC to see what the error was for but I was using the LCD panel on the printer at the time and did not think to check that before I reset the printer. After that it shows 2000 all the time.

    I have tried two different thermistors on that board with the same results and tried those same thermistors on my other printer and they work fine.

    Not seeing any apparent visible damage on the board but not sure where I should be looking.
    I was thinking I could try using the thermistor inputs on the Duex5 but have not figured out how to set the tool/heater to use a different thermistor input.

    Is there some kind of test I can do on the board using a multi-meter?



  • Not sure if this is helpful or not but here are some pictures of measuring the resistance on both boards, one that works and the one that doesn't

    Working board:
    a7c7b0a6-a587-4c10-966c-ab2377f130c4-image.png

    Not working board:
    80cabac8-809e-4198-97f0-bb1e7c246a4b-image.png



  • Small update
    I decided to erase the firmware on this board and get everything to exactly the same on this board as my other one.

    07b581b8-2c1f-4c10-a313-898abc50495a-image.png

    5ec94e0d-27f8-4c2e-92cf-a02856ad88ee-image.png

    Still getting this. Heater 1 and 3 are the only ones with thermistors plugged into them at the moment but still shows 2000. Heater 3 is coming from the Duex5 which is a brand new board.

    31292d7a-a47e-43c3-a352-6e4eeaa07ff4-image.png



  • Looks like one of the older revisions, can you tell which one?

    And measure the resistance from the left thermistor pin to ground (in the same orientation as in your previous photos)



  • Like this? Sorry for the slightly blurry picture hard to hold the multi-meter and probes with one hand and take a picture with the other. The red probe is clipped to the left pin on T0 and the black probe is on the ground of the power in block.
    Board version is 1.01

    dd87cdcd-3c8a-4150-a168-ec638511ab78-image.png



  • Don't need the picture, the value is enough, 10.4 ohms? no kilo or other prefixes?

    And the revision of the board? Should be part of the silkscreen near by the red probe. says something like pcb revision 1.nn(x)?



  • Oh sorry didn't notice that it cut the bottom of the meter off showing the setting. It was 10.4 kohm
    Board version is 1.01



  • @cdl1701yahoo-com said in Thermistor showing 2000:

    It was 10.4 kohm

    oh, thats your problem i think, it should be close to 0.

    ref https://duet3d.dozuki.com/Wiki/Connector_and_spare_part_numbers#Section_VSSA_fuse



  • @bearer Oh you know what.. you just sparked a memory from about 3 years ago. I had to replace the F1 fuse on this board before because of this issue. I checked it with my multi-meter and sure enough it is blown. I bought 5 of those last time... now I wonder where I put those.. haha



  • tape the bag to board when you find them?



  • Holy crap I found them.. And my wife thinks I keep too much junk from my 3D printer builds.. haha



  • Success!!

    aa259f6d-5ed6-4d5d-b6ee-638ba83540b0-image.png

    No heaters installed for Heater 2 or Bed yet so those are good.



  • Awesome!

    (btw if your wife really thought you kept too much junk I don't think you would have found them;)


Log in to reply