Macro not sent from PanelDue (but works ok from Web interface)



  • Hi all,

    For quite some time I have been having some problems with my Workbee CNC machine in which one macro does not work. The macro is a very simple command that moves the tool to the WCS #1 origin (only on the X and Y) axis:

    G28 Z
    G54 G1 X0 Y0 F1500
    

    I control my machine via the PanelDue Display and I use the Web Interface only to upload Gcodes and other housekeeping stuff. For some estrange reason, the macro would not work. I had to restart the Duet and then I could send the command. Today however I noticed that if I execute the macro from the web interface, it works just fine and as expected. No problem whatsoever.

    On my machine I have a CNC pendant like the ones developed here:
    https://forum.duet3d.com/topic/11389/cnc-style-pendant

    I don't know if it has something to do with it, but I felt it was important to mention.
    Sending the equivalent Gcode from the PanelDue's terminal also doesn't work.
    Running Ooznest's modified Firmware (I think it's only interface??).

    I have many other Macros (https://github.com/FelixHauser/macros-Workbee) but all the others work as expected (setting WCS mostly, turning Router ON and OFF, etc.)

    Any help is appreciated and welcome !


  • Moderator

    Interesting. Firmware versions? Duet board? PanelDue version?



  • @Phaedrux oh yeah... sorry



  • well, I just made a short test in which I unplugged the Pendant and plugged the PanelDue as usual. The Macro in this configuration works just fine. So, apparently, it is a problem with the Pendant. I will post the problem over the Pendant post.



  • well, if anyone is following this thread, I just want to mention that it has been solved.

    The issue was the name of the macro together with the firmware version of the Paneldue. I changed the name of the macro to be just text and it worked fine. And just for the sake of it, I updated the firmware to the latest version. Everything works just fine now.


Log in to reply