Attempting to extrude with no tool selected



  • I have a Anycubic Kossel and I'm trying to extrude filament for the first time. The extruder stepper motor does not turn.
    this is in config.g

    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 E256 I0 ; configure microstepping without interpolation
    M350 X16 Y16 Z16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E96.00 ; set steps per mm
    M566 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X720000.00 Y720000.00 Z720000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z3000.00 E3000.00 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E1000 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30
    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    I got this error.

    G10 P0 S0
    Error: Attempting to extrude with no tool selected.
    M120 M83 G1 E-50 F3600 M121
    Error: Attempting to extrude with no tool selected.
    27/07/2020, 23:11:13T-1
    Error: Attempting to extrude with no tool selected.27/07/2020,
    23:11:13T-1
    Error: Attempting to extrude with no tool selected



  • Hi,

    Did you select a tool first?

    You can do this from the web interface.

    Or you can add a T0 command to the end of your config.g file.

    Frederick



  • I'm not sure how to do this. What command do I use? Thanks for the help



  • I'm assuming you know how to navigate around in the Duet Web Control (DWC) interface.

    See attached to where you can click to select a tool.

    Or you can execute a T0 command from the DWC or add it to your config.g file.

    Frederick

    DWC Tool Select.jpg



  • Just open your config.g file and add T0 at the bottom of your config.g



  • Thanks guys, I'm such a noob lol. Well I'm learning.


  • Moderator

    @Elvis0z said in Attempting to extrude with no tool selected:

    M350 E256 I0 ; configure microstepping without interpolation
    M350 X16 Y16 Z16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E96.00 ; set steps per mm

    I think you may also have an issue with your steps per mm and using x256 microstepping. I suggest you change to x16 microstepping with interpolation enabled on E for now.



  • @Phaedrux said in Attempting to extrude with no tool selected:

    M350 X16 Y16 Z16 I1 ; configure microstepping with interpolation

    How would I do that?



  • @Elvis0z said in Attempting to extrude with no tool selected:

    @Phaedrux said in Attempting to extrude with no tool selected:

    M350 X16 Y16 Z16 I1 ; configure microstepping with interpolation

    How would I do that?

    You have a command M350 E256 I0

    Simply delete that line and add E16 after the Z16 in the M350 line below.

    Frederick



  • Thanks heaps Phaedrux.



  • @fcwilt Thanks fcwilt


Log in to reply