DuetWifi; no tool selected



  • So, in hopes of using variables, I updated my DuetWiFi to 3.1.1. The upgrade seemed to work fine, except now, using the same gcode, I get an error "No tool selected".

    I have a T1 in the code, and do not see a change in tool selection, and m563 is still used.

    Any "obvious" place to look?

    Thanks!



  • Maybe run the code with M98 and see if there are errors before the T1 which prevents execution?



  • @bearer
    Thank you for the suggestion. I tried running a macro file, and had a copy in both the Macros folder as well as the Jobs folder, and I got an error "File not Found".



  • I was able to get the macro to run by entering the full file path. I still get the error "Attempting to extrude with no tool selected."

    I also tried issuing a tool command in the Console, as well as through the terminal, and even included another one in the "macro call" file. Still, no extruder moving.


  • Moderator

    @tenaja maybe you have T0 defined rather than T1? Post your config so we can see if everything is defined correctly.

    Ian



  • @droftarts said in DuetWifi; no tool selected:

    @tenaja maybe you have T0 defined rather than T1? Post your config so we can see if everything is defined correctly.

    Ian

    I did not change this after the FW update, so unless tool numbering changed, it has to be something else. But, despite this, I had already considered and tried T0, and it gave the same error.

    Here is my config. I deleted the network setup, but it does work, both before and after the 3.1.1 update. Note, I am not using any heaters.

    
    ; Communication and general
    M111 S0                            		; Debug off
    
    ;*** Networking
    M552 S1						; Turn network on
    
    M555 P2						; Set output to look like Marlin
    G20						; (Edit) Work in INCHES (Edit)
    G90						; (Edit) Send absolute coordinates... for xyz axes (Edit)
    M83						; (Edit) ...but relative SPINDLE moves (Edit)
    
    ; Disable Fan 1 thermostatic mode
    M106 P1 H-1
    
    ; Axis and motor configuration
    
    ; M584 Z0 A4					; (Edit) M584: Set drive mapping
    
    
    M569 P0 S1					; Drive 0 goes forwards
    M569 P1 S1					; Drive 1 goes forwards
    M569 P2 S1					; Drive 2 goes forwards
    M569 P3 S1					; Drive 3 goes forwards
    M569 P4 S1					; Drive 4 goes forwards
    M574 X2 Y2 Z2 S1				; set endstop configuration (all endstops at high end, active high)
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
    ;M665 R105.6 L215.0 B85 H250			; (Edit commented out) set delta radius, diagonal rod length, printable radius and homed height (Edit)
    M666 X0 Y0 Z0					; put your endstop adjustments here, or let auto calibration find them
    M350 Z64 A64 E64 I1				; (Edit) MICROSTEPS: Set 32x & 16x microstepping with interpolation (Edit)
    
    M92  Z10078.74				; (Edit) Set axis steps/mm(Edit)
    
    M906 X1000 Y1000 Z1000 E1000 I50		; (Edit) Set motor currents (mA) and increase idle current to 60%--1.68A/phase max for OpenBuilds (Edit)
    M201 X1 Y1 Z10 A40 E40			; Accelerations (mm/s^2)
    M203 X40 Y40 Z35 A3200 E3200			; (Edit) Maximum speeds (INCH/min) (Edit)
    M566 X10 Y10 Z10 A100 E100			; Maximum instant speed changes mm/minute
    
    ; Tool definitions
    M563 P1 D1 				; Define Tool with with E1 as the driver no fan or heaters
    M92 E503.937 				; Edit: Set "extruder" spindle steps per mm, which gets multiplied by 2.54 for steps/inch; use for steps/rev.
    
    ; Z probe and compensation definition
    ;*** If you have a switch instead of an IR probe, change P1 to P4 in the following M558 command. 
    M558 P4 F100 T6000 X0 Y0 Z0 H3			; (Edit) Z probe is a Smart Effector and is not used for homing any axes R0.4 not used. Reduced F300 to 100
    G31 P100 X0 Y0 Z-0.25				; Set the zprobe height and threshold for Smart Effector
    
    ; M208 S1 Z-0.2					; set minimum Z
    
    T1						; select first hot end (required)
    M302 						; allow cold extrude.
    
    
    ; M117 Use https://configurator.reprapfirmware.org/ to set up your printer config
    

  • Moderator

    @tenaja your config.g is not sufficiently updated for RRF 3. You need to define the motors with M584, and update your endstop settings. See https://duet3d.dozuki.com/Wiki/RepRapFirmware_3_overview#Section_Summary_of_what_you_need_to_do_to_convert_your_configuration_and_other_files

    Edit: in other words, define the extruder motor with M584, because it isn’t defined at the moment, so there’s no tool as you have defined it only with a non-existent extruder drive. You’ll have more success if you use the configuration tool. Run M98 P”config.g” to show errors in config.g, though this won’t show missing commands.

    Ian


  • Moderator

    Might want to generate a config set using the web tool to get a good example of the syntax for RRF3 to compare against.

    https://configtool.reprapfirmware.org/Start



  • @droftarts said in DuetWifi; no tool selected:

    M584

    Ian,
    Thank you for the suggestions. I ran through the config, and filled in the blanks as possible, but received the same error.

    I believe my biggest problem is this is not a printer, and the config tools (and help files) are not really setup to handle devices that are not printers. There are numerous configurations required in setup that simply do not exist--such as "tools", heaters, endstops, and all the other goodies that a 2-axis "cnc machine" simply does not have or need.

    The way I arrived at my original config was to use the config tool, and deleted the unnecessary "clutter".

    Re-running the config with the new version did not produce a functioning config file. I could not get the E axis to move regardless... so I just remapped it to A, and now it works. I prefer not to do things like that, but sometimes you just have to quit wasting time.

    I really do appreciate the time you took to help me. This forum has always had people willing to assist.


  • Moderator

    @tenaja If you could describe your machine requirements (you say 2 axis CNC, but with one rotation axis?), and post your config.g as it stands now, I'll have a look and see if it can be improved. Do you need to use the extruder axis? It looks like you're trying to use it as a spindle? Or is it to turn the spindle to follow a line (so not really a spindle, more to turn the cutter in the correct direction)?

    Also, you said earlier when you posted your config.g:

    I deleted the network setup

    If you mean you have M587 in your config.g, you need to remove this from your config anyway. As well as being a security hazard, writing the access point parameters to WiFi chip every time you start the Duet may eventually wear out the flash memory. See https://duet3d.dozuki.com/Wiki/Gcode?revisionid=HEAD#Section_M587_Add_WiFi_host_network_to_remembered_list_or_list_remembered_networks

    Ian


  • administrators

    @tenaja said in DuetWifi; no tool selected:

    @bearer
    Thank you for the suggestion. I tried running a macro file, and had a copy in both the Macros folder as well as the Jobs folder, and I got an error "File not Found".

    try running config.g after boot up and see what errors you get:

    M98 P"0:/sys/config.g"
    

Log in to reply