Heater fault on heater 0



  • When trying to heat up the print bed on my Ender 3 I set it to 80°C and when it reaches 80° it automatically gives me a fault message. I didn't have this problem when I was running early update of 2.05, but I think that when I last updated the firmware that is scrued everything up with the bed heating unit.



  • @Asabol please post the config to be able to check, and which hardware and exact firmware is used?



  • @JoergS5 ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Sun May 03 2020 19:34:06 GMT-0400 (Eastern Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes goes forwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E741.00 ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z600.00 E6000.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z120.00 E5000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E900 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X235 Y235 Z260 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S1 ; set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X10:220 Y10:220 S20 ; define mesh grid

    ; Heaters
    M305 P0 T98801 B4185 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; set temperature limit for heater 0 to 80C
    M305 P1 T98801 B4185 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S255 ; set temperature limit for heater 1 to 255C

    ; Fans
    M106 P0 S0.45 I0 F20 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S0 I0 F20 H1 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F20 H1:0 T45 ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 S"Hotend" D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; load saved parameters from non-volatile memory
    M911 S21 R23 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0 ; select first tool



  • Your temp limit for bed heater is 80. So when you set its temp to 80, its probably overshoots it by 1-2c and gives you fault or at leat warning message. If you want to heat your bed to 80, rise max limit of it by lets say 10C and all should be fine.
    Also let as know what firmware version are you using, from console send M115 and post result here.



  • @aidar The printer says that I am using version 2.03.


  • Moderator

    I think aidar pinpointed the cause of your problem, but you should still consider updating your firmware to 2.05.1.

    Easiest way is to download this zip file and upload it as is to the /sys folder via DWC.

    https://github.com/Duet3D/RepRapFirmware/releases/download/2.05.1/Duet2Firmware-2.05.1.zip



  • @Phaedrux Ok thank you to both you and Aidar the printer works correctly know and it doesn't give me an error when I get up to 80°C.


Log in to reply