Duet 2 Wifi speeds



  • We purchased a Modix 3D printer which utilizes a Duet 2 WiFi. To keep things simple since this is installed in a corporate lab, we purchased a Netgear Nighthawk RAX20 router to act as an access point between the dedicated laptop and the 3D printer. The router is NOT connected to the internet, it's strictly for creating a wireless network between the laptop and printer.

    We regularly upload files that are in the 40-80MB range, however, the upload speeds we are getting are in the 20-35kbs range....aka super slow! I realize the Duet 2 WiFi is only 2.4ghz compatible, but shouldn't we expect faster speeds than this??

    I did try connecting the laptop directly to the router via the ethernet cable and sending files this way to isolate the speed to just the router and printer...it did get better, but not great. 60-75kbs range.

    Any ideas? I'm not an IT person and i'm already pushing what i know about this stuff, so any help would be appreciated.



  • the duet can act as its own access point.

    see
    https://forum.duet3d.com/topic/3107/duet-wifi-in-access-point-mode



  • Thank you for the link! I wonder why the 3D printer manufacturer hasn't told me about this option.

    What sort of transfer speeds should i expect from the Duet with this method?



  • @kre8
    sorry cant tell you, i use ethernet.



  • I wish there was a way to hardwire into this printer...the wifi thing has been a big pain!





  • @kre8 I run a Duet WiFi. Its connected to my home WiFi via a couple of extenders/repeaters as I'm a long way from the router, but still get 10× the speeds you're seeing (just got 250-300 kbps uploading a 10MB file).

    First thing to check would be what is the WiFi signal strength? My interface and uploads were incredibly slow before I got the repeaters as the signal was so weak. (Send M122 in the Web Control console and scroll down to near then end). Ideally you want better than -55dB. Anything less than about -60 and you will notice it.

    Setting the Duet up as an access point t may be better if the laptop is closer to the printer than your router. Might also be worth checking the Duet board mounting. Is there a bunch of metal around it shielding the antenna?



  • I use an access point connection to my sand table via wifi and typically get about 300 kbps transfer rate. It's about the same as the wired ethernet connection I use on my printer.



  • @kre8 maybe it has a different reason like the maximum write speed of the SD card. I would try a different, fast card, like a Class 10 card.


  • Moderator

    It may help if you provide the results of M122 so we can see firmware versions and wifi signal strength and SD card speeds.

    Using Access Point Mode might be a good option. Using a router like that can actually be a bit of a limiting factor since wifi requires free air time to transfer data. So when the laptop is talking to the router everyone has to be quiet, and then the router sends the data to the duet. So the router would constantly be buffering frames and then forwarding them on. Setting up the Duet to act as it's access point means there is less air time contention.

    There may be some settings on the router that might help, but I'm not really familiar with it. Setting up a dedicated 2.4ghz SSID is a good start, but if you're able to use the Duet AP mode then all the better.



  • The router is about 7' from the printer.

    The wifi speed per the M122 command is -42dBm....in that same command it says the SD card interface speed is 20mbytes/sec.


  • Moderator

    Signal strength is fine, but as I said, there's a lot more to wifi. If you're in a crowded wifi environment with a lot of cross talk speeds can be impacted because if there is interruption during the transfer, the packets must be resent.

    Are there a lot of access points/SSIDs showing up in the area? Doing a wifi scan and seeing what channels they are using can be insightful. If possible, choose a channel as far away from the predominant channels. Otherwise, choose the same channel. This may seem counter intuitive, but in a crowded environment being on the same channel allows for better scheduling and less interruptions and therefore less resending of data and better transfer rates.

    Copy and paste the full M122 report so we can see some additional information. Perhaps your firmware version is out of date or the wifi server is a mismatch. I can't tell without seeing it.



  • Ok, so i aborted the router altogether.

    I setup the Duet 2 WiFi to be an access point like @Veti linked. Fortunately since that post was so old they apparently rolled that feature into the version of firmware that was already installed on the printer. Not sure why the printer manufacturer doesn't suggest this option.

    So far my speeds have been in the ~100Kibs speeds which is better than where i was so. I'm still going to look into the Ethernet upgrade that @Veti also linked.


  • Moderator

    Condensed instructions for access point mode are here: https://duet3d.dozuki.com/Wiki/Gcode#Section_M589_Configure_access_point_parameters

    In case anyone is looking at this in future.

    @kre8 I think it would be worth experimenting with different channels (M589 C) to see if you can get even better performance in your environment. Common recommended channels are 1, 6, or 11.


  • administrators

    With a strong WiFi signal, no contention for the router and a good SD card, upload speeds of 700 to 800kbytes/sec to a Duet WiFi are usual. I believe the Modix uses the Duet WiFi with external antenna, so signal strength is less likely to be a problem.

    If the WiFi environment is congested, it often helps to configure the router to use a different channel.

    You can test the write speed to the SD card using the M122 P104 command. The reported write speed is normally 3Mbytes/sec or better.



  • @Phaedrux So so i just type M589 C, hit enter and then type in a channel number??

    @dc42 On Friday we actually replaced the ~3" Modix antenna with one closer to ~11" long and that helped. I'll have to do the SD write test today and see what we get. As for the channels...i can try others once i know how to change it.



  • @dc42 I did the write test and it came back at 2.03Mbytes/sec for a 10.0 Mbyte file.



  • Just tried sending a 75mb file to the printer using the duet wifi as an access point and i'm barely getting 100kbytes/sec 😧


  • Moderator

    @kre8 said in Duet 2 Wifi speeds:

    @Phaedrux So so i just type M589 C, hit enter and then type in a channel number??

    Not exactly. M589 C1 as a single command would set channel 1. M589 C11 would set channel 11.



  • @Phaedrux Got it...i'll give that a try.

    Is there someplace to check that the channel was changed after i do that command?


  • Moderator

    If you have a windows 10 laptop you can try this wifi analyzer to get some more information on your wifi environment.

    https://www.microsoft.com/en-ca/p/wifi-analyzer/9nblggh33n0n?activetab=pivot:overviewtab

    If you have a Mac laptop you can use the built in wifi diagnostics tool.

    https://support.apple.com/en-za/guide/mac-help/mchlf4de377f/mac#:~:text=Press and hold the Option,Fi status in menu bar”.


  • Moderator

    @kre8 said in Duet 2 Wifi speeds:

    Is there someplace to check that the channel was changed after i do that command?

    You can send most gcodes by themselves without any parameters and it will echo back what the current values are. So send M589 by itself.



  • So i've got the Duet set to channel 1 and then ran the analyzer. Signal looks good however im still on transferring at 70-100kbs....and actually now that i've spec'd a channel, it seems to constantly error out during a file upload.

    Modix Signal 2.jpg
    Modix Signal 1.jpg


  • Moderator

    @kre8 said in Duet 2 Wifi speeds:

    So i've got the Duet set to channel 1 and then ran the analyzer.

    According to the photo you're still on channel 6. (and it looks like some miscreant is on channel 7, tsk tsk)

    Try including the C parameter when sending the M589 to create the access point mode.

    M589 S"yourssid" P"password" C"1"



  • @Phaedrux said in Duet 2 Wifi speeds:

    Try including the C parameter when sending the M589 to create the access point mode.
    M589 S"yourssid" P"password" C"1"

    When i follow this sequence substituting my details, i get a error for bad or missing parameters

    M589 S"MODIX" P"KRE8LABS" C"1" is what i entered.


Log in to reply