Constant 'connection interrupted'



  • My main printer is a HEVO, run by DuetWifi v2, which sits about 20' from my router and has excellent WIFI coverage. It has been there for over a year without issue, however recently I started to get a huge number of network drop outs when I didn't get any before. I have a laptop in the same location as the DuetWifi and on the same SSID and it never has any issues, nor is it hogging the WIFI.

    So I decided to start a fresh with the DuetWiFi and the Duet2and3Firmware-3.1.1.zip

    Disconnected mains power from DuetWifi and then connected it via USB to my laptop, which uses the same SSID and has no issues. Pressed Eraze button, then reset button

    Ran Bossa on laptop and wrote Duet2CombinedFirmware.bin to it selecting Erase all, Lock, and Boot from Flash – verified once complete – all OK

    Disconnected from laptop and power up DuetWifi, console showed update progress and all was well. Still disconnecting almost constantly.

    Re-did the above process and, after rebooting copied these files to the sys folder (whilst SD was in my laptop)

    Picture1.png

    Connected DuetWifi to laptop and from console issued M997 S0:1:2. Console showed upgrade process completed OK. Rebooted and still almost costant network disconnects. Not once did my laptop have any issues, it’s on the same SSID and is right next to the DuetWifi.

    Checked SD card, have tried 16 & 32GB, in Windows and it is OK – formatted as FAT32

    Typically connection issue
    Picture3.png

    Version info reported

    Picture4.png Picture5.png

    Files on SD card
    Picture6.png Picture7.png

    Diagnostic Report
    11/8/2020, 3:08:54 PM: Connected to 192.168.1.52
    11/8/2020, 3:11:45 PM: Connection interrupted, attempting to reconnect...: Network error
    11/8/2020, 3:11:47 PM: Connection established

    11/8/2020, 3:12:37 PM: M122: === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet WiFi 1.02 or later
    Board ID: 08DDM-9FAM2-LW4S8-6J9FD-3S86R-9MYVX
    Used output buffers: 3 of 24 (24 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 93868 of which 52 recycled
    Exception stack ram used: 552
    Never used ram: 8620
    Tasks: NETWORK(ready,308) HEAT(blocked,1224) MAIN(running,1852) IDLE(ready,80)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:10:11 ago, cause: software
    Last software reset time unknown, reason: User, spinning module GCodes, available RAM 8956 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 27.7, current 29.9, max 32.3
    Supply voltage: min 24.4, current 24.6, max 24.8, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max 0/90
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max 0/745
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-11-08 15:12:37
    Cache data hit count 1012732619
    Slowest loop: 5.50ms; fastest: 0.13ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 10
    SD card 0 detected, interface speed: 30.0MBytes/sec
    SD card longest read time 1.0ms, write time 0.0ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 167, MaxWait: 81144ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 36, completed moves: 36, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 204.50ms; fastest: 0.00ms
    Responder states: HTTP(2) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 2 of 8

    • WiFi -
      Network state is active
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address ec:fa:bc:0b:ef:f2
      WiFi Vcc 3.45, reset reason Unknown
      WiFi flash size 4194304, free heap 20976
      WiFi IP address 192.168.1.52
      WiFi signal strength -52dBm, reconnections 0, sleep mode modem
      Socket states: 4 0 0 0 0 0 0 0

    I usually stay away from beta firmware but may try 3.2beta to see if the issue remains.

    Just trying Duet WiFiServer.bin v1.24 first


  • Moderator

    From the usb terminal console can you send M997 S1 and report the results?

    It should show the wifi module flash progress.

    When you lose connection, does the wifi module light go out?

    Can you also test the Duet in Access point mode for a while to see if the module works without disconnections in that mode? That would isolate the problem with the router side.

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M589_Configure_access_point_parameters



  • Hi

    Just doing a test print on it. After uploading Duet WiFiServer.bin v1.24 (15 mins ago) I have not had a single dropout - which is 100% better already. Likely the kiss of death I know.....

    Will feedback on your requests shortly. Pretty much 100% guarantee it's not the router side - IT rather than 3D is my thing and I've double checked that side

    Hadn't read the part about putting the Duet into AP mode - what is the benefit/purpose to that feature



  • M997 S1 shows that it is erasing the firmware and the counts in 5% increments up to 100% at which point it says Upgrade, or update, complete and the WIFI comes back on

    The drop outs have returned sadly

    Not sure if blue WIFI goes out or not - will need to sit at it and glare at it for awhile on that one

    Update (good timing) - just went to glare at it and it dropped out right away

    No - the WiFi light does not go out when it reports
    Connection interrupted, attempting to reconnect...
    HTTP request timed out



  • Setting AP mode 'appears' to work but I don't see the SSID 'DUETTEST'

    Picture8.png


  • Moderator

    The SSID would be duet according to your image.



  • Yes, 'DUET' sorry, does not show, which I presume isn't a good sign


  • Moderator

    Does the module light up when in ap mode?



  • @Phaedrux Yes it does


  • Moderator

    And nothing shows up on your phone or laptop?



  • Nothing new at all


  • Moderator

    Could be a failing module. Do you have the means to replace it?



  • Not really, would need hot air soldering tool and at least the WIFI module I guess. Not something I've done before, have soldered quite a lot but don't fancy completely frying the board though. Probably have to live with it until it dies and then figure something out. Do you know off-hand if the WIFI module is still either ESP-12S or ESP-07S (from an old dc42 post)



  • OMG - I'm sooooo sorry about the AP test. Seems my brain is stuck in DFU mode as I did NOT send M552 S2 to enable the AP SSID. Oddly enough when I do i can see it. I was able to sign into it briefly too



  • Able to sign into in on my laptop, but still get drops

    I noticed in the diagnostics that i do NOT see what I should, I see

    WiFi Vcc 3.45, reset reason Unknown

    rather than

    WiFi Vcc 3.42, reset reason Turned on by main processor



  • Although there weren't any reported issues with either sd card I reformatted my 32Gb one, 64k clusters and did NOT use the quick option and then copied back the files. Left the Duet off overnight, plugged in the sd card and powered it on and left it alone for an hour - 0 drops - ran a couple of G39's to warm up the MCU and again 0 drops
    (forgot to mention Duet is enclosed in a case with a fan for cooling-https://www.thingiverse.com/thing:2812834)

    Had more drops now, very few when it's completely idle. Just for shiggles I plugged in a WiFi extender right next to the printer. Once firmware has been updated we'll see if that makes any difference


  • Moderator

    So it seems like an SD card issue?



  • @Phaedrux Sadly no, even when the printer is idle I get drop outs. I have a Wi-Fi extender 12" away from the Duet, and it's connected to it. Still get drop outs. Connection stats for the Duet to the Wi-Fi extender are -21dbm 53Mbps.

    So.... looks like your initial prognosis was correct πŸ˜– Wi-Fi module is fubar'd and on it's way out and needs to be replaced 😞

    I will try another, 3rd, SD card to triple check


  • Moderator

    Just to clarify because I may have missed it in some edits, but were you able to get access point mode working? And were the drops still happening?

    If that was the case, then yes, it's likely the module is failing given that your signal strength is good, no other devices in the area are having issues, and it happens even with the router removed from the equation. We've tried reflashing the wifi server and new SD card.

    Replacing the wifi module isn't the most difficult process but it's not for beginners either.

    Here's an example of it being done with an external antenna version, but it's basically the same.

    https://forum.duet3d.com/topic/2825/converting-the-duet-wifi-to-use-an-external-antenna



  • @Foden Same issue with 3 different sd cards, all error checked and formatted FAT32



  • @Phaedrux Yes, was able to get the AP mode working and connected to it, same network drop problem. Will take a look at the link - thanks again

    I think this is an indication of an issue "WiFi Vcc 3.45, reset reason Unknown" as it doesn't match the expected output



  • I left the Wi-Fi extender, for now, blasting into the ear of the DuetWiFi, as I don't see it hurting anything - other than the folks across the street 😁
    In desperation, as I don't really want to have to replace the Wi-Fi module - but will if required, I spent the morning redoing everything from scratch, just in case - no change. UNTIL I changed the "Number of maximum AJAX retries" from 3 to 4. No drops in the last 4 hours, for the first 1 1/2hrs I was re-leveling the bed - I mean why not - to see if raising the MCU temp was an issue - seems it was not.

    Usual KOD statement, but looks like the issue, possibly symptom only, was AJAX retry # brought about with a recent upgrade to Duet Wi-Fi 3.1.1. Which I had completely overlooked as a possible culprit. I had upgraded it but then not used the HEVO for awhile as I was using my MakerSelect IIIP.

    Will see if I get any more connection drop outs now I have tempted fate again



  • Last post on this, I know everyone will be pleased

    So, indeed it was the KOD - 30 mins ago back to constant drops again. Best get out the hairdryer, solder and BBQ tongs then......

    Can you turn the DuetWifi into a DuetEthernet?


  • Moderator

    @Foden said in Constant 'connection interrupted':

    Can you turn the DuetWifi into a DuetEthernet?

    Yes I believe so. Instead of soldering on a replacement module you could install the socket for the ethernet module.

    https://www.duet3d.com/DuetAddons/DuetEthernet_Module



  • Hmm, OK that's an option then, except for the hole I'd have to put in my case 😞 Oh well

    Thanks again Phaedrux


Log in to reply