delta effector tilt during print only



  • i have a weird issue. after tweaking all the settings. i noticed that the effector ONLY tilts during an actually print. the file was sliced using prusaslicer 2.2. i do not notice any tilting when doing a delta calibration with 6 outer and 6inner points and 9 factors. nor do i see any tilt during mesh compensation.

    another thing is, when the effector tilts, i also do not noticed the carriage trolleys twisting or rotating.

    second question: what does the effect of a shorter thsn expected delta radius and longer than expected delta radius have on effector motion and first layer?

    this is a kossel mino with wheeled carriages. not linear rails and it printed fine on marlin but i changed to magball rods and effector setup. i used a jig to measure all the rods to be the same length and the bearing spacings are identical for all 6 segments in CAD.



  • @tekstyle said in delta effector tilt during print only:

    9 factors

    did you start with 9 or did you arrive there?
    its better to start with 6, if its not accurate with 8, and 9 only to verify the rod length.


  • administrators

    How are you detecting or measuring the tilt?

    Are you using the Smart Effector, if not then what type of Z probe are you using?



  • @dc42

    i can see an obvious tilt when it's printing. i am using a printed effector with the joints at the level of the groove mount and hot end well below it. zprobe is an optical end stop with allenkey



  • it could be motors missing step.

    have you set the correct current? around 75% of the rated current.



  • @Veti

    here is my config.g. i believe the stock motors are rated for 1.5a. i set them to 1.275a

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Tue Aug 11 2020 10:57:06 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Anycubic Kossel Mini" ; set printer name
    M665 R94.19 L220 B85 H248.29 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X1.284 Y0.201 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S1 ; physical drive 2 goes forwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E142.549 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X2000.00 Y2000.00 Z2000.00 E1000.00 ; set accelerations (mm/s^2)
    M906 X1275 Y1275 Z1275 E1428 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; set minimum Z

    ; Endstops
    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"zstop" ; configure active-high endstop for high end on Y via pin zstop
    ;M574 Z1 S1 P"null" ; configure active-high endstop for low end on Z via pin null

    ; Z-Probe
    M558 P1 C"zprobe.in" H20 F1200 T4000 ; set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y-19.17 z9.467 ; set Z probe trigger value, offset and trigger height
    M557 R70 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B3950 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 h0 A133.6 C714.8 D2.1 S1 B0 V12.2 ; Heater 0 model: gain 133.6, time constant 714.8, dead time 2.1, max PWM 1.00, calibration voltage 12.2, mode PID
    ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C

    M308 S1 P"e0temp" Y"thermistor" T100000 B3950 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 A740 C220.4 D5.6 B0 S1.00 V12.2 ;Heater 1 model: gain 740.0, time constant 220.4, dead time 5.6, max PWM 1.00, calibration voltage 12.2, mode PID
    ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1 C"Parts" ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q250 ; create fan 1 on pin fan1 and set its frequency
    M106 P2 S0 H-1 C"LED" ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined
    M307 H0 A116.7 C650.3 D1.4 S1.00 V11.5 B0
    M307 H1 A370.2 C150.1 D7.3 S1.00 V11.7 B0

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    T0 ; select first tool

    ;m501



  • @tekstyle said in delta effector tilt during print only:

    M906 X1275 Y1275 Z1275 E1428 I30 ; set motor currents (mA) and motor idle factor in per cent

    i have a anycubic kossel plus and the motors current are a lot less

    M906 X1000 Y1000 Z1000 E1200 I30 ; set motor currents (mA) and motor idle factor in per cent

    and even at that current they get hot.

    so check the temperature with your fingers if they get hot.


  • administrators

    Motors missing steps will not cause the effector to tilt. You can find causes of effector tilt described at https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer#Section_Make_sure_your_build_is_accurate.



  • @dc42
    my smart effector just arrived and i have went ahead and installed it. havent figured out all the hotend and fan electronics yet but so far it looks good with the spirit level. i also swapped out the trolley with more rigid ones. been playing with delta calibration and mesh and it looks way better than the saddle height map i have been getting before. right now, i have a dome shaped height map. i have been messing with delta length using the M665 command to see what results ill get. been going as far as -3mm to +3mm and it still looks the same.

    did my first xyz cube and came out to be 20.6mmX x 20.3 Y 20.06mm Z. corners appear to be squared. I think the tilt might have been the inaccuracy with the printed parts. I did print new pulley trolleys and replaced the wheels with Vslots and seems to be much more rigid with nearly no slop even when I tug with my hand.

    h**ps://i.ibb.co/TBTpzMs/Screenshot-20201207-232842.jpg
    [link text](link url)


Log in to reply