Incredibly slow print speed



  • Hi Chaps, finally got my corexy printer working and new "genuine paneldue " after ali express refunded my faulty clone. Im running the duet2 ether, I purchased simplify 3d and run test print but got bad warping with pla , with same hardware as before which never warped, so I went back to Cura slicer to test same print, problem is , printing is now incredibly slow ??? cura slicer says 50mm/sec but printing is more like 1mm / sec any help appreciated.



  • I've made the mistake of having the speeds in Simplify 3D set to mm/minute instead of mm/second.

    50mm/minute is about 1mm/second.

    Is that your problem?



  • @alankilian Thanks for reply this test piece was sliced in Cura and Ive just checked and it is set at 50mm / sec in cura so not sure if thats the answer or no



  • @GG Post both your GCODE files. That will tell for sure.

    Or at least one G1 move with an extrusion from each file.


  • Moderator

    I would bet that your cure slicer start gcode has some speed limits defined which are limiting your speeds.



  • @alankilian ;FLAVOR:Marlin
    ;TIME:6876
    ;Filament used: 5.53586m
    ;Layer height: 0.15
    ;MINX:116.513
    ;MINY:116.511
    ;MINZ:0.3
    ;MAXX:213.486
    ;MAXY:213.489
    ;MAXZ:15
    ;Generated with Cura_SteamEngine 4.8.0
    M140 S55
    M105
    M190 S55
    M104 S200
    M105
    M109 S200
    M82 ;absolute extrusion mode
    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate

    G28 ;Home

    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

    G92 E0
    G92 E0
    G1 F1500 E-6.5
    ;LAYER_COUNT:99
    ;LAYER:0
    M107
    G0 F6000 X130.894 Y130.531 Z0.3
    ;TYPE:SKIRT
    Hi this is the cura gcode , having trouble getting simplify 3d code



  • @GG said in Incredibly slow print speed:

    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate

    you are setting the speed to about 8mm/sec here

    Delete the M201 M203 and M204 lines and restart your printer



  • @Veti You beat me to it!

    What a great community we have here.


  • Moderator

    @GG said in Incredibly slow print speed:

    ;FLAVOR:Marlin

    Also change your gcode flavour to reprap


  • Moderator

    @GG said in Incredibly slow print speed:

    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk

    Delete M205 as well.



  • @Phaedrux I removed the sugggested above gcode from the start gcode in cura in machine settings and akso changed gcode flavour to reprap but still runs at snailpace



  • @GG

    did you restart the printer afterwards?


  • Moderator

    Post your config.g as well.



  • @GG said in Incredibly slow print speed:

    I removed the sugggested above gcode from the start gcode in cura

    If you post your GCODE we can take a look again.



  • @Phaedrux ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Wed May 06 2020 16:21:04 GMT+0800 (中国标准时间)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"My Printer" ; set printer name
    M669 K1 ; core xy mode
    M555 P2 ; set output to look like marlin
    G21 ; work in mm,s
    ; Network
    M552 S1 ; enable network
    M552P 192.168.1.12 ;
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes backwards
    M569 P4 S0 ; physical drive 4 goes backwards
    ;Dual Z
    M584 X0 Y1 Z2:4 E3 ;
    M671 X-100:415 Y160:160 S2.0 ;
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E396.00 ; set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z1000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X 0 Y-15 Z0 S1 ; set axis minima
    M208 X310 Y310 Z380 S0 ; set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; set active low and disabled endstops
    ;Filament Run Out Sensor
    M591 D0 P1 C4 S1; Filament run out sensor for extruder E0 on E1 end stop input P1 = signal HIGH .
    ; Z-Probe
    M574 Z1 S2;

    M558 P1 H5 F600 T6000 A10 S0.03 I1 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20 ; define mesh grid

    ; Heaters
    M305 P0 T100000 B3950 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B3950 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M305 P2 T100000 B3950 R4700 ; set thermistor + ADC parameters for heater 2
    M143 H2 S280 ; set temperature limit for heater 2 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45 ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 S"Extruder" ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    G31 .65; set z offset

    T0; This is curent gcode
    M302 P1;FLAVOR:RepRap
    ;TIME:6876
    ;Filament used: 5.53586m
    ;Layer height: 0.15
    ;MINX:116.513
    ;MINY:116.511
    ;MINZ:0.3
    ;MAXX:213.486
    ;MAXY:213.489
    ;MAXZ:15
    ;Generated with Cura_SteamEngine 4.8.0
    T0
    M190 S55
    M104 S200
    M109 S200
    M82 ;absolute extrusion mode
    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate

    G28 ;Home

    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

    M83 ;relative extrusion mode
    G1 F1500 E-6.5
    ;LAYER_COUNT:99
    ;LAYER:0
    M107
    G0 F6000 X130.894 Y130.531 Z0.3
    ;TYPE:SKIRT
    G1 F1500 E6.5
    ; Custom settings are not defined
    M575 P1 S1 B57600; Enable paneldue

    This is the curent config g and yes I did restart machine, just tried it again with same result. Strage thing is the printer worked fine when slicing with simplify 3d but the print warped and the vertical sides of the cylinder were wasted in the middle , I ve never had warping before with the old cheapo mini chitu board ??? atached below is current start gcode


  • Moderator

    @GG said in Incredibly slow print speed:

    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk

    If this is the same gcode file as before you would need to delete it and re-slice after you've removed those lines from the start gcode.



  • @Phaedrux that seemed to solve the speed issue, so I printed same cylinder shape but the print quality is awful, as I saids the vertical sides of the cylinder are waisted in the middle , scalloped I guess when they shoule be strait, the old mini board used to print these fine, coule it be the mother board the problem I wouldnt have thought so. ???


  • Moderator

    M566 X900.00 Y900.00 Z12.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z1000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; set accelerations (mm/s^2)

    In your config.g file change the Z acceleration and jerk values to be a bit higher. As they are now they would cause some problems with mesh compensation.

    Try
    M566 Z60
    M201 Z200

    Can you share a photo of what you mean about the quality issues?


Log in to reply