BLTouch Probe Not Deploying.



  • Hello,

    I have an Ender 3 V2 with BLTouch from ANTCLabs. It was set up and printing fine for a while, then I changed the nozzle, attempting an auto home. When I did that the print plate went farther back then it should have and started crashing against the rear. I turned the printer off, powered it back on, and my BLtouch has not worked since.

    I cannot get the printer to move down on the Z axis. I have tried reflashing the firmware. When my printer starts up the probe for the BLTouch does not deploy anymore. When I run an m119 through pronterface it shows the Z probe as triggered when its not and open when it is triggered.

    I cannot find a way to reverse this. I have a video of my machine starting up that I will post below

    https://imgur.com/a/zQ65DT2

    It will also give me this error [ERROR] Error:!! STOP called because of BLTouch error - restart with M999



  • Please post you homeall.g and config.g files. What version of the firmware are you running?

    When you apply power does the BLtouch do a self test where it deploys and retracts a couple of times?

    Edit: I just realized you might not be running a duet controller/reprap firmware. If you are running the stock controller there are probably more appropriate forums than this one as it is generally dedicated to reprap firmware and the duet product line. But I can try and help.


  • Moderator

    Are you even running A duet board and RRF on there? It looks like the stock LCD and menu system.



  • Indeed looks like a stock set up and from what the video shows you need to invert the Z direction and the Z min input at least.
    My guess is youve flashed a "clean" version of the firmware and you need to complie again using the presets for the Ender 3
    Probably best go to the Ender face book group
    Good luck



  • @Alex-cr It does not do the self test of deploying and retracting. I am also realizing this is the wrong forum sorry. This has just been a nightmare and I'm looking for help from all sides



  • I don’t have any direct experience with an Ender 3 and I gave up on Marlin a long time ago but it sounds like a combination of things. @Phil-Maddox is probably right in the post above about flashing the wrong firmware.

    I would also bet the BLtouch became disconnected somehow. I would check the wiring to make sure it is all sound. Does it light up at all?


Log in to reply