Z axis endstop not working



  • As said above, it will not work for me. The light comes on, and if I trigger it by hand it will go off but it will not stop the axis from moving when homing. The X and Y work fine. I've tried this with an opto and mechanical endstop now. At first, i believed it was just issues with badly designed opto switches as described elsewhere, so I switched and it still does not work.

    My switches are wired to NC, low end of the axis and set to active high in the firmware. Any help would really be appreciated


  • administrators

    You probably have your homez.g and homeall.g to use a Z probe instead of an endstop for Z homing. See https://duet3d.com/wiki/Configuring_RepRapFirmware_for_a_Cartesian_printer#Homing_files. Also make sure you declare your Z endstop switch in the M574 command in config.g.



  • Thanks for the quick reply! That is exactly the issue it would seem…. I set up the firmware via the online configuration tool and that has a lot of options for Z probing, but at no point does it have the option of not using a z probe.



  • I also used the configuration tool, on my Cartesian printer and there is no option for not using a probe. My x and y endstops work, now, but z will not. I know the wiring is correct, but theres something in the config.g file that doesnt work or something not in there. The documentation doesnt cover this problem effectively. Someone must know how to fix this i'm sure.



  • @brian:

    I also used the configuration tool, on my Cartesian printer and there is no option for not using a probe.

    Isn't this an option for not using a probe?

    @brian:

    My x and y endstops work, now, but z will not. I know the wiring is correct, but theres something in the config.g file that doesnt work or something not in there. The documentation doesnt cover this problem effectively. Someone must know how to fix this i'm sure.

    Homing with a microswitch instead of a probe is in the wiki, in fact it is linked two posts up.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.