BLtouch not retracting



  • Hello all, I thought it was a defective BLtouch so I had it replaced, but then the same thing is still happening. Basically on startup, the BLtouch would extend the pin, but not able to retract it, and then give the alarm. I can turn off the alarm, and I am certain my wires are wired correctly. I did this at first without cutting the logic, then cutting the 3.3V logic on the BLtouch (newest smart version). However, when I connected the BLtouch to my TEVO tornado (which has another BLtouch) to check, it works perfectly and can extend and retract. I have checked my retractprobe.g file, and it is just the code as written in the wiki which is M280 P3 S90 I1. Here is my config.g file:

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Sun Oct 08 2017 12:13:50 GMT-0500 (Central Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin

    M667 S1 ; Select CoreXY mode
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y300 Z260 S0 ; Set axis maxima

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 Z0 Y1 S1 ; Define active high microswitches
    M558 P5 X0 Y0 Z1 H5 F100 T2000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 X27.25Y0 Z1.20 P25 ; Set Z probe trigger value, offset and trigger height
    M557 X15:285 Y15:285 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.84 Y80.84 Z400 E804 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z180 E1200 ; Set maximum speeds (mm/min)
    M201 X500 Y20 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X1500 Y1500 Z1200 E1200 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S280 ; Set maximum heater temperature to 280C
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PHEVO (Hypercube Evolution) ; Set machine name
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    M307 H3 A-1 C-1 D-1 ;

    T0

    I have also tried changing M558 P5 X0 Y0 Z1 H5 F100 T2000 to M558 P4 X0 Y0 Z1 H5 F100 T2000 and connected the white and black to the E0 Endstop but still the same thing. At an absolute loss now what to do. The coding and wiring all seem correct. I'm wondering if I have a defective Duet Wifi (it did have the reporting the 24V from PS as 29V issue before, so the Power SUpply is currently at 21V, but duet wifi reports as 24V)



  • Just a quick glance over your config and I see a double up of the M574.



  • Oh which one should I delete? or modify?

    EDIT: I deleted the z0 in the second M574 but still same thing, here is an update though on when I turn off the alarm and try the self test. it extends the pin and the z probe says 0, however, I push the pin to retract it, the z probe still says 0 instead of 1000 (meaning it's retracted). I then try the same thing but then run the gcode command to retract, the red light quickly flashes twice, then goes into alarm mode because it can't retract it.

    Another interesting to note is that if I set the BLtouch horizontally instead of vertically, it can then retract the pin but still gives alarm. However as I've mentioned before the BLtouch works perfectly fine on my TEVO Tornado.



  • Hi,

    I followed this guide to get my BLTouch smart working:
    https://betrue3d.dk/bltouch-on-duet-wifi-duetreprapfirmware

    Maybe you are missing the 5v connection for powering your BLtouch and you are using 3.3v instead ?



  • Hmm read through most of it and noticed some interesting things. Unfortunately it's almost midnight here, and I have work tomorrow so can't try it until I get back from home tomorrow but I will try some of the things mentioned in there and see how it goes and will then update.

    Btw I tried both the 5V and the 3.3V to the red on the BLtouch, same thing.


  • administrators

    Are you running with external power applied to the Duet and the internal 5V regulator enabled? If you are providing USB power only, there may be insufficient voltage or current on the 5V rail to power the Bltouch.



  • No I'm using the 24V power supply (currently at 21V because of the weird problem of the Duet reporting 4V higher than it actually is while multimeter confirmed PS is supplying 24V). What is the internal 5V regulator and how do I check if it is enabled? xD. Not using the USB at all.

    EDIT: Checked and the jumper is set to enable the internal 5V supply.


  • administrators

    If the Duet is reporting 24V when VIN is only 21V, that suggests to me that your 3.3V rail is only at 2.9V which is out of tolerance. Have you measured it? Is the 3.3V regulator on the Duet getting hot? What external devices are you powering from 3.3V?



  • Hi dc42 apologies for the long wait, was at work and my multimeter ran out of juice (I forgot to turn it off from something I was using). You are right, I think I may have a defective unit (would like your confirmation though). I mentioned the 5V AND 3.3V. The 5V was worst, my Multimeter says only 2.8-2.9V was coming out of them (all the 5V I can test on the board) and also for the 3,3V it's reporting only 2.7-2.8V. Where is the 3.3V regulator on the duet? I don't know where it is, but I touched all the chips on the board and with my laser temp sensor and none seem to be 40C. Right now since it's for my HEVO, just the usual 5 stepper motors, the heatbed, nozzle, fan, etc. and they aren't being used.


  • administrators

    If the 5V is only reporting 2.7-2.8V that explains why the 3.3V rail is low, because the 3.3V rail is derived from the 5V rail. Please disconnect your BLtouch, also disconnect PanelDue if you have one connected, then power up and measure the 5V rail again. If it's still at 2.8-2.9V, ask for your Duet to be replaced.



  • Thanks dc42. Just disconnected literally everything almost (except the stepper motors as I don't think they make that much of a difference especially when they aren't being used). Tested all the 5V again, this time it's pretty much the same, 2.85 V for the 5V and 2.76V for the 3.3V. I'll provide the pics as proof but since I bought it from spool3d, I'll contact them and supply the proof and they should offer me a replacement?

    Man my luck with electronics…


  • administrators

    I'm sorry, it does appear that you have received a faulty Duet. Spool3D, please replace it under warranty.



  • Np np dc42 at least it's solved now, here is a link of the pics/vids that I took as proof. https://www.dropbox.com/sh/umybmf99e6ixpkr/AADDpfFzZDImk8G-eTygOleGa?dl=0 a lot so I put them in a folder, hope that's okay.



  • What's the problem? And how solved?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.