Puzzled by Z0 position and first layer print



  • hmm I'm a bit confused here. after z homing, I told head to go to Z0 and I can still run through a sheet of paper between tip of nozzle and the bed surface. but when I print with 0.24 first layer thickness, the nozzle actually dropped down way off that it touches the bed surface and would not even extrude creating a tremendous back pressure. Is this behavior odd?

    Stephen



  • Yes unless there is some sort of Z offset being applied, check your slicer, some have a z offset setting which might be lowering the nozzle. ALso load the gcode and look at the z coordinates in it. If they are not Z0.24 but something else then it is not the printer but the gcode.

    Do you have a G31 Z-offset defined? Are you using bed levelling/grid levelling? Do you have a probe?



  • Checked slicser (S3D) no z offset applied. Checked the sliced gcode, first layer height noted at Z0.24 hmm

    It might be setting in duet side
    I do use FSR probe for homing only. No mesh leveling.


  • administrators

    Please post the first 50 or so lines (excluding comment lines) of your gcode file.



  • here you go. Also for some reason S3D keep inserting M106 and I don't know how to tell it not to do that…

    G90
    M83
    M106 S0
    M104 S205 T0
    M109 S205 T0
    G10 P0 R160 S205
    G10 P1 R160 S205
    G90 ; set absolute
    G1 X0 Y119 F9000 ; move head to far left bed for purging
    G1 F1500 ; set feedrate
    G1 Z0.24 ; drop z to printing 1st layer height
    G1 X100 E8 ; purge 8mm filament on to opposite edge of bed while running 100mm toward T0 parking position.
    T1
    G90 ; set absolute
    G1 X0 Y0 F9000 ; move head to far right bed for purging
    G1 F1500 ; set feedrate
    G1 Z0.24 ; drop z to printing 1st layer height
    G1 X100 E8 ; purge 8mm filament on to edge of bed while running 100mm toward T1 parking position.
    G1 E-1.4000 F3600
    G1 Z0.240 F1002
    ; process T0 left
    ; layer 1, Z = 0.240
    T0
    ; tool H0.240 W0.312
    ; skirt
    G1 X24.351 Y39.633 F12000
    G1 E1.3500 F1080
    G1 X25.984 Y38.720 E0.0582 F1200
    G1 X25.993 Y38.716 E0.0003
    G1 X27.245 Y38.222 E0.0419
    G1 X27.254 Y38.219 E0.0003
    G1 X28.786 Y37.839 E0.0491
    G1 X28.791 Y37.838 E0.0002
    G1 X29.474 Y37.718 E0.0216
    G1 X29.480 Y37.717 E0.0002
    G1 X35.167 Y37.117 E0.1780
    G1 X42.982 Y36.127 E0.2453
    G1 X48.168 Y35.362 E0.1632
    G1 X57.263 Y33.857 E0.2870
    G1 X57.265 Y33.856 E0.0001
    G1 X57.519 Y33.821 E0.0080
    G1 X57.520 Y33.821 E0.0001
    G1 X59.717 Y33.571 E0.0688
    G1 X59.719 Y33.571 E0.0001
    G1 X59.941 Y33.551 E0.0070
    G1 X59.943 Y33.550 E0.0001
    G1 X61.825 Y33.421 E0.0587
    G1 X61.826 Y33.421 E0.0001
    G1 X62.043 Y33.410 E0.0068
    G1 X62.045 Y33.410 E0.0001
    G1 X64.320 Y33.352 E0.0708


  • administrators

    1. Do you have any tool change files (tpre0, tpost0, tfree0 etc.), and if so what do you have in them?

    2. Is this an IDEX machine?

    3. Which firmware version are you running?



  • Are you setting the Z height with the paper when the printer is heated up or not? Heat can greatly affect the Z height, depending on printer setup and construction material.



  • Yes I have a slightly different idex build. Nothing fancy on my tpre and tpost just regular park head to far end of arm and M116. Picture below for reference as you can see I actually have been printing for a while with T0 only and no first layer problem Now that I have finished installing T1 and tried dual printing, I get that first layer issue. I'm on frmware 19. Something I forgot will check later tonight



  • Firmware version 1.19.2

    My tfree0.g
    G90
    G1 X127 F12000

    My tfree1.g
    G90
    G1 X132.2 F12000


  • administrators

    Please upgrade to firmware 1.19.2. Also, to work around a known issue that is fixed in firmware 1.20, please add one M400 command right at the start of every tool change file that includes movement, and another at the end.



  • @stephenc.
    In another thread you mention that you have this in the start code of S3D.

    G10 P0 R160 S200
    G10 P1 R160 S200

    From the wiki, it states:

    "Remember that any parameter that you don't specify will automatically be set to the last value for that parameter. That usually means that you want explicitly to set Z0.0…................"

    So, I'm just wondering if it's those G10 commands in your start gcode that are applying an offset.
    HTH


  • administrators

    @deckingman:

    @stephenc.
    In another thread you mention that you have this in the start code of S3D.

    G10 P0 R160 S200
    G10 P1 R160 S200

    From the wiki, it states:

    "Remember that any parameter that you don't specify will automatically be set to the last value for that parameter. That usually means that you want explicitly to set Z0.0…................"

    So, I'm just wondering if it's those G10 commands in your start gcode that are applying an offset.
    HTH

    Those commands should leave the Z offset of each tool alone, so I don't think that's likely to be the problem. The tool offsets default to zero if they are never set.



  • in my config I have G31 set as follow for z offset after probing which works perfectly when I have T0 printing only

    ; Endstops
    M574 Z0 S0 ; Define active low and unused microswitches
    M574 X1 U1 Y1 S1 ; Define active high microswitches
    M558 P6 X0 Y0 Z1 H5 F120 T12000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P600 X0 Y0 Z0.148 ; Set Z probe trigger value, offset and trigger height



  • went back and reviewed my Drives section (posted below) in config.g
    do I need to do this for my 2nd Z?

    Z16:16 ; for microstepping
    Z800:800 ; for step per mm
    Z800:800 ; for motor current
    and so on?

    –------------------------
    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards X
    M569 P1 S0 ; Drive 1 goes forwards Y
    M569 P2 S1 ; Drive 2 goes forwards Z
    M569 P3 S0 ; Drive 3 goes forwards extruder T0
    M569 P4 S0 ; Drive 4 goes forwards extruder T1
    M569 P5 S1 ; Drive 5 goes forwards Uz
    M569 P6 S1 ; Drive 6 goes forwards Ux
    M350 X16 U16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80 U80 Y53.33 Z800 E830:415 ; Set steps per mm
    M566 X2000 U2000 Y2000 Z60 E1500:1500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X15000 U15000 Y15000 Z180 E6000:6000 ; Set maximum speeds (mm/min)
    M201 X2500 U2500 Y2500 Z250 E1000:1000 ; Set accelerations (mm/s^2)
    M906 X950 U950 Y950 Z800 E800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout



  • can't remember if I've posted this video here… but this is how I home the 2 towers. After this homing, I manually confirm the two heads when move to same spot they both have the same distance between nozzle to top of bed surface. When printing, T0 (the one on the left and is the primary extruder) would print as expected in the correct layer height. But, T1 is problematic for some odd reason it appear to dive more in Z resulting the nozzle touching the bed surface perfectly thus nothing is extruding resulting in backpressure...

    it's almost as if my G31 below as defined in my config.g is only applying to the left tower only...
    G31 P600 X0 Y0 Z0.148 ; Set Z probe trigger value, offset and trigger height

    https://youtu.be/PqQjZGIJ1rw


  • administrators

    @stephenc:

    went back and reviewed my Drives section (posted below) in config.g
    do I need to do this for my 2nd Z?

    Z16:16 ; for microstepping
    Z800:800 ; for step per mm
    Z800:800 ; for motor current
    and so on?

    No; but your M906 and M350 commands must come after the M584 command, so that they are applied to both the Z drivers.

    Have you added M400 commands to your tool change files as per my previous response?



  • yes I did add M400 though it doesn't appear to have any impact

    my M584 is way up there under "general preferences" in the beginning of my config.g so both M906 and M350 have been placed after. or are you suggesting reversing this order?


  • administrators

    The order you have is correct: M584 early, M350 and M906 later.



  • in a very strange work around. I actually managed to get it to work. both print head print at the correct first layer now and more importantly same height

    since my G31 has z offset of 0.15 all I did were:

    • update my homez.g after T1 touches FSR instead of it goes up 5mm i changed it to 5.15mm ( I kept T0 go up at 5mm)
    • After homez.g finish running, I ended up with Z5.30. now if I print this way I will end up with the issue I started this post with. so I went to console and did G92 Z5.15

    then problem solved although this seems like a band aid solution…


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.