Mesh bed and bltouch



  • Hey,
    my bltouch works,
    only now I have something that I do not understand well yet.
    I use G29 for mesh bed
    he does this neatly only when he is done he shows this

    G29
    49 points probed, mean error -0.423, deviation 0.771
    Height map saved to file heightmap.csv

    what means mean error -0.423
    and how can I fix this
    I used this link https://www.duet3d.com/wiki/Using_mesh_bed_compensation#Summary_of_gcode_commands_related_to_mesh_bed_compensation
    to set the trigger height etc,

    and the picture height map looks strange after my opinion.
    ]
    who could help me with this

    Best regards
    gideon



  • I dont know what type of Printer you use, but if it is like my a D-Bot or something with 2 Leadscews it could be that on the left Side the bed is more down than on the right side. 😉

    My looks like this: https://i.gyazo.com/63ffba61ad041de3afed527bebcb9fa1.png
    But i don't know what Mean error or RMS error is.



  • @AS-3D:

    I dont know what type of Printer you use, but if it is like my a D-Bot or something with 2 Leadscews it could be that on the left Side the bed is more down than on the right side. 😉

    My looks like this: https://i.gyazo.com/63ffba61ad041de3afed527bebcb9fa1.png
    But i don't know what Mean error or RMS error is.

    sorry i for get the type, a have a hypercube


  • administrators

    Yes that does look odd. What M557 command are you using to define the grid?

    Mean error is the average error. A lage mean error could indicate that your Z homing position is not accurate. RMS error is the root-mean-square (a type of average) deviation from the mean, which indicates how much the bed or printing plane deviates from being flat.



  • hello, dc42
    I use this, in the config
    ; Endstops
    M574 X1 Y1 S0; Set of active low endstops
    M574 Z1 S2; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1; bltouch
    M558 P5 X0 Y0 Z1 H3 F100 T5000; bltouch
    ;M558 P5 X0 Y0 Z1 H4 F400 T2000
    ;G31 P25 X0 Y0 Z2.32
    G31 X0 Y0 Z0.47 P25; bltouch
    M557 X5: 395 Y5: 395 S85; Define mesh grid

    and do G29
    if I do this several times in a row I get to see different values each time

    I also have my height map
    RepRapFirmware height map file v2, mean error -0.330, deviation 0.278
    xmin, xmax, ymin, ymax, radius, xspacing, yspacing, xnum, ynum
    5.00,395.00,5.00,395.00, -1.00,85.00,85.00,5,5
     -0,345, -0,352, -0,480, -0,640, -0,987
     -0.400, -0.270, -0.227, -0.252, -0.412
     -0.502, -0.285, -0.115, 0.012, -0.042
     -0.725, -0.460, -0.240, -0.010, 0.162
     -0.827, -0.548, -0.322, -0.065, 0.090

    if I do 2x G29 consecutively then it is different every time.
    this normally would not matter much with each other.

    I would like to receive advice on what can not be right,
    my printer is a hypercube a corey xy
    with 2z motors not separately fed
    Best regards
    gideon


  • administrators

    If you are getting different results every time, I can see two likely causes:

    1. Your bltouch is not triggering at a consistent height.

    2. Your motion system is not repositioning the probe at a consistent position and height.

    Here is a script (my thanks to Russ Gries for it) to test the reproducibility of the probe trigger height, by probing the same point 32 times:

    ; Probe testing single point. 
    G30 P0 X0 Y0 Z-99999 F2000 
    G30 P1 X0 Y0 Z-99999 F2000 
    G30 P2 X0 Y0 Z-99999 F2000 
    G30 P3 X0 Y0 Z-99999 F2000 
    G30 P4 X0 Y0 Z-99999 F2000
    G30 P5 X0 Y0 Z-99999 F2000 
    G30 P6 X0 Y0 Z-99999 F2000 
    G30 P7 X0 Y0 Z-99999 F2000 
    G30 P8 X0 Y0 Z-99999 F2000 
    G30 P9 X0 Y0 Z-99999 F2000
    G30 P10 X0 Y0 Z-99999 F2000 
    G30 P11 X0 Y0 Z-99999 F2000 
    G30 P12 X0 Y0 Z-99999 F2000 
    G30 P13 X0 Y0 Z-99999 F2000 
    G30 P14 X0 Y0 Z-99999 F2000
    G30 P15 X0 Y0 Z-99999 F2000 
    G30 P16 X0 Y0 Z-99999 F2000 
    G30 P17 X0 Y0 Z-99999 F2000 
    G30 P18 X0 Y0 Z-99999 F2000 
    G30 P19 X0 Y0 Z-99999 F2000
    G30 P20 X0 Y0 Z-99999 F2000 
    G30 P21 X0 Y0 Z-99999 F2000 
    G30 P22 X0 Y0 Z-99999 F2000 
    G30 P23 X0 Y0 Z-99999 F2000 
    G30 P24 X0 Y0 Z-99999 F2000
    G30 P25 X0 Y0 Z-99999 F2000 
    G30 P26 X0 Y0 Z-99999 F2000 
    G30 P27 X0 Y0 Z-99999 F2000 
    G30 P28 X0 Y0 Z-99999 F2000 
    G30 P29 X0 Y0 Z-99999 F2000
    G30 P30 X0 Y0 Z-99999 F2000 
    G30 P31 X0 Y0 Z-99999 F2000 S-1
    
    

    Save it as a macro and run it. If X0 Y0 is not a good point to probe on your printer, change those coordinates in every line to something that is.



  • hello dc42
    thanks for your reply.
    I'm going to try out the macro tomorrow and I'll let you know if my bltouch works well,
    if not then I am going to think about the ir probe https://www.duet3d.com/DuetAddons/IRProbe
    to purchase, and hope it works better than the bltouch,



  • @dc42:

    If you are getting different results every time, I can see two likely causes:

    1. Your bltouch is not triggering at a consistent height.

    2. Your motion system is not repositioning the probe at a consistent position and height.

    Here is a script (my thanks to Russ Gries for it) to test the reproducibility of the probe trigger height, by probing the same point 32 times:

    ; Probe testing single point. 
    G30 P0 X0 Y0 Z-99999 F2000 
    G30 P1 X0 Y0 Z-99999 F2000 
    G30 P2 X0 Y0 Z-99999 F2000 
    G30 P3 X0 Y0 Z-99999 F2000 
    G30 P4 X0 Y0 Z-99999 F2000
    G30 P5 X0 Y0 Z-99999 F2000 
    G30 P6 X0 Y0 Z-99999 F2000 
    G30 P7 X0 Y0 Z-99999 F2000 
    G30 P8 X0 Y0 Z-99999 F2000 
    G30 P9 X0 Y0 Z-99999 F2000
    G30 P10 X0 Y0 Z-99999 F2000 
    G30 P11 X0 Y0 Z-99999 F2000 
    G30 P12 X0 Y0 Z-99999 F2000 
    G30 P13 X0 Y0 Z-99999 F2000 
    G30 P14 X0 Y0 Z-99999 F2000
    G30 P15 X0 Y0 Z-99999 F2000 
    G30 P16 X0 Y0 Z-99999 F2000 
    G30 P17 X0 Y0 Z-99999 F2000 
    G30 P18 X0 Y0 Z-99999 F2000 
    G30 P19 X0 Y0 Z-99999 F2000
    G30 P20 X0 Y0 Z-99999 F2000 
    G30 P21 X0 Y0 Z-99999 F2000 
    G30 P22 X0 Y0 Z-99999 F2000 
    G30 P23 X0 Y0 Z-99999 F2000 
    G30 P24 X0 Y0 Z-99999 F2000
    G30 P25 X0 Y0 Z-99999 F2000 
    G30 P26 X0 Y0 Z-99999 F2000 
    G30 P27 X0 Y0 Z-99999 F2000 
    G30 P28 X0 Y0 Z-99999 F2000 
    G30 P29 X0 Y0 Z-99999 F2000
    G30 P30 X0 Y0 Z-99999 F2000 
    G30 P31 X0 Y0 Z-99999 F2000 S-1
    
    

    Save it as a macro and run it. If X0 Y0 is not a good point to probe on your printer, change those coordinates in every line to something that is.

    F2000 is the speed right? Isn't that too fast for the bltouch?

    I have found that if you want to run G29 consecutively, for the next run you should first Disable Bed Compensation and then re-home Z. Else, you will get different results.


  • administrators

    I don't know the BLTouch, but i agree, F2000 is rather high. Try 300 or 600.



  • Hello i will try F3 a 600. Towmorrow. Thanks for the advise



  • Hey,
    I ran the macro,
    see here what came out
    F300
    G32 bed probe heights: -0.007 -0.002 0.000 -0.020 -0.010 0.010 0.007 0.007 0.010 0.010 -0.007 -0.012 -0.007 -0.012 -0.007 -0.002 -0.007 -0.012 -0.010 -0.010 -0.010 -0.012 -0.012 -0.015 -0.002 -0.020 -0.025 0.002 -0.007 0.002 0.042 0.023, mean -0.004, devi
    I do not think this is all right, I see the same value a number of times but also many different ones
    does anyone have an idea where it can be,

    F100
    M98 P0:/macros/test
    G32 bed probe heights: -0.060 -0.035 -0.032 -0.062 -0.032 -0.040 -0.037 -0.047 -0.037 -0.062 -0.040 -0.030 -0.060 -0.055 -0.045 -0.067 -0.045 -0.060 -0.062 -0.060 -0.060 -0.062 -0.065 -0.060 -0.060 -0.070 -0.050 -0.060 -0.055 -0.060 -0.053 -0.037, mean -0



  • Here's mine with:
    F100:
    G32 bed probe heights: 0.038 0.041 0.042 0.048 0.040 0.043 0.039 0.040 0.040 0.038 0.043 0.040 0.039 0.033 0.036 0.016 0.033 0.040 0.041 0.041 0.041 0.041 0.042 0.038 0.040 0.048 0.043 0.040 0.039 0.046 0.039 0.042, mean 0.040, deviation from mean 0.005

    F150:
    G32 bed probe heights: 0.039 0.041 0.044 0.043 0.038 0.039 0.040 0.041 0.040 0.042 0.042 0.040 0.040 0.044 0.038 0.043 0.044 0.038 0.041 0.045 0.048 0.042 0.039 0.041 0.044 0.043 0.044 0.043 0.046 0.044 0.044 0.039, mean 0.042, deviation from mean 0.003

    I also did some testing with higher F values, however, as my Z speed wax maxed at 200mm/min, the higher F values were also maxed at 200mm/min and not being used.


  • administrators

    @gideon, it looks like your bltouch (or clone) isn't giving reproducible results. Some other users have reported this problem too.



  • with you the differences are less great than with me I see,
    I am thinking about testing one with the ininductive sensor
    see what it does,
    whether the differences are still so great



  • @gideon:

    with you the differences are less great than with me I see,
    I am thinking about testing one with the ininductive sensor
    see what it does,
    whether the differences are still so great

    if you want accurate, repeatable probing, just use a piezo sensor, I can assure you, I tried all other options, but nothing beats its performance and ease of use (not even close).
    https://www.precisionpiezo.co.uk/



  • @dc42 Hey,
    I am now going to try to see a proximity sensor to see if it works better,
    if not, I will order the ir probe



  • The BLtouch should be more than accurate enough. Of course, it depends how rigidly you have mounted it. Another good test it to check how mechanically sound your machine is. Set your height a sheet of paper using the nozzle, raise and lower the head by 5mm, check if you still get the same gap between the bed with the paper;.



  • I have now even mounted a proximity sensor, I think this is better. or is it still nothing
    M98 P0: / macros / test
    G32 bed probe heights: -0,600 -0,600 -0,600 -0,602 -0,602 -0,608 -0,605 -0,605 -0,602 -0,602 -0,602 -0,605 -0,600-0,602 -0,605 -0,605 -0,605 -0,605 -0,608 -0,600-0,600 -0,602 - 0.605 -0.608 -0.608 -0.605 -0.605 -0.608 -0.605 -0.602 -0.605 -0.605, mean -0



  • That looks a lot better.

    I just re-run one of my tests with the bltouch, as probing at higher speeds made no sense as my z speed in config.g was limiting the probing speed. So I now set my Z speed and probe speed to 250. This was the result:

    G32 bed probe heights: -0.001 0.003 0.003 0.007 0.001 0.005 0.002 0.006 0.003 0.004 -0.001 -0.004 0.001 0.004 0.003 0.001 0.001 0.005 0.005 0.003 0.004 0.006 0.007 0.009 0.000 0.009 0.003 0.003 0.009 0.003 0.003 0.001, mean 0.003, deviation from mean 0.00



  • 12:06:43M98 P0:/macros/test white F100
    G32 bed probe heights: -0.205 -0.200 -0.200 -0.200 -0.203 -0.203 -0.203 -0.200 -0.200 -0.198 -0.200 -0.198 -0.200 -0.200 -0.203 -0.203 -0.200 -0.198 -0.203 -0.200 -0.200 -0.200 -0.205 -0.200 -0.203 -0.200 -0.200 -0.203 -0.200 -0.200 -0.200 -0.200, mean -0


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.