Gcode for test BlTouch



  • Hi,

    While Mini Ir arrives, i am testing BlTouch, that i have discarted….

    In this moment i have wired.... following the guide, i have found in facebook group, and seems works of all test...

    The only issue, that i do not know its is normal, when i haved instaled Mini IR, in Duet Web Control, start page, z.probe, indicates a numeric valor if zprobe was triggered.

    With BlTouch the field Z-probe, ever show 0....

    i have made a macro for test probe, this:

    [[language]]
    G91
    G0 X-50 Y-50 Z-50 F500 S1
    G90
    
    

    I am not sure if the flag S1, stop movement when BlTouch its triggered.

    What would be the order to move the head, and stop the movement if the zprobe is triggered?

    Thanks



  • The BlTouch signal on triggering is very fast/short so you won't see a value in the web control.
    To run a single height test I do

    [[gcode]]
    G30 S-1
    
    ```that tests/reports the trigger height for the current x/y position.
    
    To test if it works use your hand or an object somewhere above your plate so you have time to switch of the power or hit the emergency stop button before it drives hard into the plate
    
    As I have to Z axis motors, I use this macro to test if the bed is level:
    

    [[gcode]]
    G1 Z10 X5 Y105
    M401
    G30 S-1
    M402

    G1 Z10 X205 Y105
    M401
    G30 S-1
    M402



  • Hi,

    works… a half, why?

    1- Power on printer
    2- Home all
    3- Send the gcode: G30 S-1 --> and put some obstacle for test, nozzle downs slow, and when BlTouch reach obstacle, retracts, and stop down.... PEFERCT.
    4- In Web Interface, order to "AUTO DELTA CALIBRATION".... and the problems, nozzle start to down fast, and when reach bed...HEAD CRASH, and power off.

    I dont know for what, i think it's because of the speed, but I'm not sure.

    ¿Ideas?
    ¿Can change the speed nozzle displaces when i order "AUTO DELTA CALIBRATION"? How? Where?


  • administrators

    You probably have an inaccurate H (homed height) or R (delta radius) parameter in your M665 command. Until you have accurate values, try increasing the dive height, which is the H parameter in the M558 command. For example, a value of 40 will stat to probe from 40mm above where the firmware thinks the bed is.

    Once you have established your M665 parameters and written them into config.g, you can reduce the M558 H parameter again to speed up bed probing. The default is 5mm.



  • Later try….

    Another question, when send calibrate order by Duet Web Interface... Nozzle go to the bed, I seems very fast. There is some kind of dorm to reduce this speed?

    Until I haven't adjusted probe, I am interested in Duet do the calibration process slow..



  • In forum, I have read this

    The M558 F parameter controls the speed of probing, and the T parameter controls the speed of travel moves between probe points.

    This can solve my issue?
    Its for calibration or/and compensation?



  • Regards,

    I expose here my reasoning about configuring Zprobre BlTouch in Duet, so you can tell me which ones are wrong …

    Starting points

    1- My BlTouch, is the v2, Smart version, and I have cut back to transform it 3.3V
    2- I made the connections between BlTouch and Duet Wifi, according to the scheme, which I attach.
    3- The BlTouch sensor I think works correctly, because when I send the code "G30 S-1" by console, the head starts to descend, until I put an obstacle
    4- Accustomed to in DUET WEB INTEFACE, see the value of ZProbe when it was close to an object. I find it strange not to read any value. This is normal?

    Things that DO NOT work.

    A- When I give the order, by DUET WEB INTERFACE, of autocalibracion. The head drops very fast, I think too much, and hits the bed. (Luckily I put a metal plate …)
       B- At that moment I cut the current, I do not trust to continue with the autocalibration. But it seems to me like I'm going to look for another point.

    Theory of why they can be:

    A- David, tells me that it may be that he misses the values of M665, where is the geometric configuration of the printer, I doubt that is that, since, although it may have inaccuracies, are taken from the group of Facebook, Tevo Little Monster Duet
       B- To reduce the speed, I think excessive, with which the head low to start calibrating. Would it be sufficient to include parameter F500 on line M558, of config.g?
       C- There is a parameter, on line M558, of config.g, which may also have the key:
             1- The parameter H, which defines where the firmare thinks the bed is, according to David I have to upload it to about 40mm to start, then reduce it.
    D- If I adjust G31 Z (Distance between nozzle tip and extended BlTouch)

    Please, comments



  • Hi,

    I update with new tests….

    I have edited M558 line:

    [[language]]
    M558 P5 X0 Y0 Z0 H22 F120 T600
    
    ```A- The speed T600 much, much better
    B- I have raised H until H40, and test calibrate, nozzle down (slow T600) and when isfar from bed, stops to go down, and go, to, suppose first point of calibration, after second, and so on…. But how ir far from bed.... nothing
    C- I have go down H, in steps, until BlTouch, arrives to bed... but when BlTouch arrives to bed, nozzle dont Stops, and head crass.
    
    And another one:
    
    Yesterday, the gcode G30 S-1, works, after these changes, i recive this message.... [c]Error: Z probe already triggered at start of probing move, and probe its not triggered, and pin is downs.
    [/c]
    Think i am close….but....not in place...
    
    Tips please

  • administrators

    @peirof:

    Hi,

    I update with new tests….

    I have edited M558 line:

    [[language]]
    M558 P5 X0 Y0 Z0 H22 F120 T600
    
    ```A- The speed T600 much, much better
    B- I have raised H until H40, and test calibrate, nozzle down (slow T600) and when isfar from bed, stops to go down, and go, to, suppose first point of calibration, after second, and so on…. But how ir far from bed.... nothing
    C- I have go down H, in steps, until BlTouch, arrives to bed... but when BlTouch arrives to bed, nozzle dont Stops, and head crass.
    
    And another one:
    
    Yesterday, the gcode G30 S-1, works, after these changes, i recive this message.... [c]Error: Z probe already triggered at start of probing move, and probe its not triggered, and pin is downs.
    [/c]
    Think i am close….but....not in place...
    
    Tips please
    

    In the Z probe reading box in Duet Web Control, are you getting a reading of 1000 all the time? If so then the BLTouch black and white wires are not connected to the Z probe connector correctly.



  • Hi,

    I am not In home now, later try.

    These can explain that gcode [c]G30 s-1[/c] works and calibration for web interface fault?



  • What are the numbers I have to see in DUET WEB CONTROL/Zprobe, when:

    • Bltouch is triggered
      Or
    • Bltouch is released

    In this moment, I can read 1000 when is triggered, with Grey background


  • administrators

    The value when not triggered should be 0 if it is connected correctly. You definitely do not need I1 in the M558 command for bltouch. The bltouch produces only a short pulse when it triggers, so you probably won't see a different value when it triggers. If you are lucky, you might see it rise above zero sometimes when it triggers.



  • Still no work….

    Why when send by console [c]G30 S-1[/c], and out and obstacle, paper, bltouch triger, and stops….
    But when send the [c]Calibrate by DWI[/c], dont stops????

    If when i send [c]G30 S-1[/c], the head stops…. must be a configuration issue?
    BlTouch its working well, no?



  • Lets thinking….

    if it was working correctly, what should the printer do?

    1- Homing
    2- The Nozzle goes down to find the bed, at a speed T600 (in this case)
    3- When BlTouch touches the bed, the Nozzle stops going down, and goes up. How much does it rise?
    4- It moves horizontally to the next point defined in bed.g.
    5- Go back down, until the BlTouch plays ....
    and this process for all points in bed.g ....

    It would be like this?
    which can cause the head to NOT stop going down when the BlTouch is playing? Assuming it is working, since the G30 S-1 command works

    Is there any other way to prove that the BlTouch works?
    There was not a form of relative movement, which stopped when the BlTouch (ZProbe) was activated ???



  • Maybe this helps you.
    This are my config.g lines for bltouch

    [[language]]
    
    M307 H7 A-1 C-1 D-1 ; disable heater7 free it up for pwm control for bltouch
    
    M558 P5 X0 Y0 Z1 H3 F100 T500; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only. ; bltouch
    
    G31 P25 X0 Y-15 Z1.00 ; Set Z probe trigger value, offset and trigger height - bltouch
    
    M557 X5:205 Y5:205 S20 ; Define mesh grid
    M376 H3.0 ; taper of height compensation above this mm value
    
    

    This is my home.z:

    [[language]]
    ; Lift Z relatively to current position
    G91
    G1 Z5 F1000
    
    ; Back to absolute positioning - mid of bed
    G90
    G1 X105 Y120 F3000
    
    ; Move Z down until the switch triggers
    G30
    
    ; Uncomment the following lines to lift Z after probing
    ;G91
    G1 Z5 F100
    ;G90
    
    


  • @Scachi:

    Maybe this helps you.
    This are my config.g lines for bltouch

    [[language]]
    
    M307 H7 A-1 C-1 D-1 ; disable heater7 free it up for pwm control for bltouch
    
    M558 P5 X0 Y0 Z1 H3 F100 T500; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only. ; bltouch
    
    G31 P25 X0 Y-15 Z1.00 ; Set Z probe trigger value, offset and trigger height - bltouch
    
    M557 X5:205 Y5:205 S20 ; Define mesh grid
    M376 H3.0 ; taper of height compensation above this mm value
    
    

    This is my home.z:

    [[language]]
    ; Lift Z relatively to current position
    G91
    G1 Z5 F1000
    
    ; Back to absolute positioning - mid of bed
    G90
    G1 X105 Y120 F3000
    
    ; Move Z down until the switch triggers
    G30
    
    ; Uncomment the following lines to lift Z after probing
    ;G91
    G1 Z5 F100
    ;G90
    
    

    Thanks, later try, now i am not in home, and give feedback



  • Sachin, one question of your config…

    You have in config.g, this line

    [[language]]
    M558 P5 X0 Y0 Z1 H3 F100 T500;
    
    

    Z… Is the distance between, nozzle and Bltouch... When is deployed? No, in your config... You have Bltouch deployed under nozzle 1mm. No?


  • administrators

    In firmware 1.19 and earlier, Z1 in the M558 just means that the Z probe is used in lieu of a Z endstop switch. In firmware 1.20 and later it is ignored, because that option is set in M574 instead. But in fact it isn't necessary to tell the firmware to substitute the Z probe for the Z endstop switch at all, assuming you set up your homing files correctly to use G30 to do Z homing.

    The Z probe trigger height is set in the G31 command.



  • I have installed firmware 1.20….

    Whats the correct configuration.g?

    Someone using Bltouch, and firmware 1.20, can post his working configuration?


  • administrators

    The configuration that Scachi posted should work with 1.20 too.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.