Fusion 360 CAM Gcode for DuetWifi



  • Are there specific settings i need to set in Fusion 360/gcode processor for it to output compatible gcode for the DuetWifi (1.21R4)?

    Should i be using a specific preset?



  • Anyone know?



  • To me it looks like you could use the Mach2Mill or Mach3Mill post. Maybe even the LinexCNC post?

    I would try some of them to see what the program looks like when generated. The adjust the post processor to suite what you need.

    I will be building a 5 axis CNC mill starting in the fall and plan on using a Duetwifi board to control it. But I won't be much help until then, Sorry.

    I do use the Fanuc/ fanuc post for my big CNC mills at work but they all have Fanuc controls on them.



  • Ok I have outputted three sets of NC Gcode, using three post processors that are available from autodesk
    https://cam.autodesk.com/hsmposts?

    Reprap Post processor
    1_1525010417893_RepRap Test 1001.txt

    Mach3Mill Post Processor
    0_1525010417893_Mach3Mill Test 1001.txt

    GRBL Post Processor
    0_1525010451420_GRBL test 1001.txt

    They all seem quite different, not sure which i should try first. the reprap seems least likely to work based on the "N" series of GCode commands.
    I dont see those listed in the Duet3D gcode list
    https://duet3d.dozuki.com/Wiki/Gcode


  • administrators



  • Looking at GRBL Code
    Here are some Commands that i dont see in the Duet3D Gcode list

    G94
    G17
    M9
    M6



  • Looking at Reprap code
    Here are some Commands that i dont see in the Duet3D Gcode list so far

    M9
    M8

    These seem to be
    M8: Flood Coolant On (CNC specific)
    M9: Coolant Off (CNC specific)


  • administrators

    Does your CNC machine have a flood coolant facility?



  • no, this is something i need to disable in the CAM settings,


  • administrators

    RepRapFirmware will warn you if you try to use unsupported GCodes, but other than that they do no harm.



  • Ok i tried to run the reprap Gcode

    this is the error received

    M32 "RepRap Test 1001.NC"
    File RepRap Test 1001.NC selected for printing
    Error: Bad command: %
    Error: Bad command: [[language]]
    Error: Bad command: [[language]]
    Cancelled printing file RepRap Test 1001.NC, print time was 0h 0m
    Error: G0/G1: outside machine limits

    also under machine control, it says X&Y is not homed
    Can I tell it that current position is home? via a macro?


  • administrators

    You can tell it that the printer has been homed and where the tool head is using the G92 command.



  • no sorry, what i meant was.. can you run a command/macro to tell machine is has already been homed to bypass homing check.


  • administrators

    @adamfilip yes use G92

    So it when its in the home position, you have the head at X0,Y0,Z0 then use G92 X0 Y0 Z0

    If you have it homed at a different point adjust G92 as required.



  • Just what maybe a stupid observation but the Filename you have is .NC could it be that that is throwing it of most files (If not all) that we print have the .gcode extension. Remember that F360 Cam module is meant for CNC Machines rather than printers.

    Now I may well be way of the mark with the obstacles mind but I thought it worth mentioning David is prob the man to either discount or whatever on the observation.

    Doug


  • administrators

    The firmware doesn't care what the file extension is. DWC does care to some extent, for example when presenting you with a file upload dialogue.

    The "%" character is mentioned in the NIST GCode standard:

    "The RS274/NGC language has no indicator for the start of a program. The Interpreter, however,
    deals with files. A single program may be in a single file, or a program may be spread across
    several files. A file may demarcated with percents in the following way. The first non-blank line of
    a file may contain nothing but a percent sign, “%”, possibly surrounded by white space, and later
    in the file (normally at the end of the file) there may be a similar line. Demarcating a file with
    percents is optional if the file has an M2 or M30 in it, but is required if not. An error will be
    signalled if a file has a percent line at the beginning but not at the end. The useful contents of a file
    demarcated by percents stop after the second percent line. Anything after that is ignored."

    I may change RRF to recognise these %-lines.


Log in to reply