New firmware 2.0RC5 available


  • administrators

    Get it from https://github.com/dc42/RepRapFirmware/releases/tag/2.0RC5a. This is a bug fix release candidate, hopefully the last one before the 2.0 and 1.21.1 firmware release. The bug fixes are:

    • HTTP request parsing error recovery didn't work. One consequence was that connecting from Internet Explorer crashed the Duet.
    • Spurious stall warnings were sometimes generated when simulating a print
    • The print monitor didn't think the print had started until a nozzle had reached target temperature. This meant that layer counting didn't work on machines with no tool heaters, or when the tool temperatures were fluctuating.
    • The print monitor didn't count layers when simulating a print
    • Axes beyond Z were ignored in G2/G3 moves
    • DWC and the Duet could deadlock if the Duet ran out of output buffers

    Please report your feedback (good or bad) in this thread.



  • Loaded, no issues. Starting prints now.

    Firmware Name:	RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics:	Duet WiFi 1.02 or later
    Firmware Version:	2.0(RTOS)RC5 (2018-05-22b1)
    WiFi Server Version:	1.21
    Web Interface Version:	1.21.1-RC4
    


  • Installed it and I can confirm that both issues regarding simulation have been fixed.



  • Coming back to an earlier change from RC1:

    When the machine mode is set to CNC, G0 moves are now done using the maximum travel speed of the machine in accordance with the NIST standard, and E and F parameters are no longer recognised.

    Is this also the case for "laser mode"? G0 should move at maximum feed rate.
    I finally got my laser working again - and would like to test this!



  • About 1:43 into the first print, all looks good so far.



  • Why am I just having problems?
    I can not print, because before problems occur.

    Current data:

    Firmware Name:	RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics:	Duet WiFi 1.02 or later
    Firmware Version:	2.0(RTOS)RC5 (2018-05-22b1)
    WiFi Server Version:	1.21
    Web Interface Version:	1.21.1-RC4
    
    • dwc is dead after a few seconds. With dwc 1.21 this error is gone.

    • Uploading brings errors
      0_1527029971837_Uploading.JPG

    • again and again gcode files disappear. Also with dwc 1.21

    • Have more times clearing the browser cache

    If the problem persists, please open the debugging console in your browser by pressing control-shift-J and see if any Javascript exceptions have been logged.

    does not know where to find the exact!

    😟

    Do not want to miss out on the new version.


  • administrators

    Upload errors are expected with the new firmware if you have a password set on your Duet (other than the default 'reprap') and you use DWC 1.21.

    Please load DWC 1.21.4 1.21.1RC4 on to your Duet, clear the browser cache, load it and immediately press control-shift-J to get the debugging console. Then when DWC becomes unresponsive, there may be an exception message.



  • @dc42 said in New firmware 2.0RC5 available:

    Upload errors are expected with the new firmware if you have a password set on your Duet (other than the default 'reprap') and you use DWC 1.21.

    Please load DWC 1.21.4 on to your Duet, clear the browser cache, load it and immediately press control-shift-J to get the debugging console. Then when DWC becomes unresponsive, there may be an exception message.

    1.21.4 ? Where do I get this version ? All I can find is 1.21.1RC4, I thought this was the latest


  • administrators

    Sorry, I meant DWC 1.21.1RC4.



  • Hi David,

    On 2.0 RC5 now...
    I noticed that in the web interface machine status that Z jumps up and down while printing.
    I am on Layer Z 9.6, but it sometimes display goes to 10.6.. then back to 9.6 again...
    (is it because of delayed display of Z hop?)

    Can anyone double confirm on this?


  • administrators

    @otaku521 said in New firmware 2.0RC5 available:

    Hi David,

    On 2.0 RC5 now...
    I noticed that in the web interface machine status that Z jumps up and down while printing.
    I am on Layer Z 9.6, but it sometimes display goes to 10.6.. then back to 9.6 again...
    (is it because of delayed display of Z hop?)

    Can anyone double confirm on this?

    That's to be expected if you have configured 1mm Z-hop in your slicer. It won't happen if you use firmware retraction and configure Z hop in the M207 retraction settings



  • Did some machining today with 2.0RC5 and all was OK.


  • administrators

    Chrishamm had just released Duet Web Control 1.21.1 so I've added it to the release area at https://github.com/dc42/RepRapFirmware/releases/tag/2.0RC5a. Anyone who was experiencing problems with DWC 1.21.1RC4, please try this new version.



  • Just updated both & running a print now...

    FYI, I got around my Trinamic\board fan issues, by wiring the board fan in parallel (1 socket & 2 plugs) with the hot end fan, which was set to come on at the same'ish temperatures anyway...



  • Been running on the RailCore nearly non-stop since you released it yesterday. Was previously on 2.0rc3, both have worked without issues that I've encountered. Turning out some fantastic prints.



  • @dc42 said in New firmware 2.0RC5 available:

    Upload errors are expected with the new firmware if you have a password set on your Duet (other than the default 'reprap') and you use DWC 1.21.

    Please load DWC 1.21.4 1.21.1RC4 on to your Duet, clear the browser cache, load it and immediately press control-shift-J to get the debugging console. Then when DWC becomes unresponsive, there may be an exception message.

    For me there was of course no change with DuetWebControl-1.21.1, too bad.

    Why 1.21 runs smoothly, and with 2.0 and 1.21.1 DWC does not work at all? And the sporatic problem with the gcode files.

    I have not set up a password.

    Here is a video to clear the browser cache.
    https://www.dropbox.com/s/zs87rwetvx862hl/clear the browser cache.wmv?dl=0

    Here are the results of debugging console:

    crosshair.png:1 Failed to load resource: the server responded with a status of 404 (page not found)
    diabase_calibration_diagram.png:1 Failed to load resource: the server responded with a status of 404 (page not found)
    /rr_download?name=0:/sys/oem.json:1 Failed to load resource: the server responded with a status of 404 (file not found)
    dwc.js:2 GET http://192.168.188.40/rr_status?type=1 0 ()
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    setTimeout (async)
    success @ dwc.js:1456
    u @ dwc.js:2
    fireWith @ dwc.js:2
    done @ dwc.js:2
    (anonymous) @ dwc.js:2
    load (async)
    send @ dwc.js:2
    ajax @ dwc.js:2
    updateStatus @ dwc.js:612
    

    Can someone try to upload this gcode file, these are not displayed on me with RRF 2.0RC5 + DWC 1.21.
    Is this due to RRF or the gcode file.
    0_1527096457013_960 Justier Teil fuer rund gleichmaessigkeit.gcode



  • I'm having some strange under extrusion issue. Not sure how I started a print at all but I can see that my support is under extruded. The first layer of the part barely pushed out any plastic. I tested by trying to manually extrude 100mm of material and only about 40mm got extruded. I did this twice. Once by commanding a full 100 and then commanding 20mm 5 times.

    I have to revert to 2b for now which did not have any issues that I noticed.



  • @bmmal I can confirm this. I tried 100mm and 50mm extrusion and it did barely extrude less than 100mm altogether - that might also explain why my print today hat what I first thought was a layer shift. Now it rather makes sense that extrusion was so low that bed adhesion failed at one point, moved the print and gladly found hold again in a place where I did not have to toss the print away.

    I will also downgrade to RC4 and check again.

    EDIT: I retested and now can no longer reproduce the problem.

    @BMMal how fast did you extrude? When I tried with 5mm/s it would fail most often. I tried again with 1mm/s and it extruded exactly 100mm on RC5.



  • gcode file delete problem threw dwc:1.21.1, fw:2.0-rc4:
    ->http://printer.loc/rr_delete?name=0%3A%2Fgcodes%2Fvase.gcode
    <-{"err":1}
    Message displayed: Error: Cannot delete file 0:/gcodes/vase.gcode because it is open

    There was no print or simmulation since cold bootup, just deleted a bunch of other gcode files.
    After "emergency stop" the file deleted successfully.



  • This post is deleted!

Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.