Strange x shifting



  • Trying to print on my tevo and the whole part prints in a strange way. It is printing up and to the right. Any ideas 0_1529973143191_received_2268615963154954.jpeg



  • Looks like skipped steps. Your current to the X stepper motor is probably too low. It could be cause by a mechanical binding of some sort. Make sure the X moves freely when no power is applied. If it slides nice and free then you either have the current to low or the motor is too small.

    Post your config file here.



  • Well it's a delta so no real x motor. And it started randomly after one print.



  • A few things come to mind,

    Does the shift line up with one of the towers? Maybe the motor or wiring is loose/bad on that tower?

    Is there any way you added axis comp M556 somewhere in your config or gcode file?

    https://duet3d.dozuki.com/Wiki/GCode#Section_M556_Axis_compensation

    I'm not a Delta guy myself but it doesn't seem like the direction would be off only in one way if the Delta Calculation was incorrect?



  • Have you tried other files? I print alot of the same parts and have separate print files ready for each quantity 1-20 and each file worked fine except the 18 parts file which did this, no idea why to this day but it was only this file.

    Otherwise it could be a backlash setting in your config somehow. Or one of the axis is moving farther than the drive thinks it is which I would think with a delta would cause it so gradually drift to one side like that. Recalibrate the steps per mm?


  • administrators

    I agree with some of the other comments. Try rotating the model to see if the problem lines up with a particular axis. also worth checking that axis compensation is not on for some reason ...https://duet3d.dozuki.com/Wiki/Gcode#Section_M556_Axis_compensation



  • All good suggestions I'll look into when I get a chance. It dose not align up.with a tower but it dose ling up with true x axis. I have sliced 2 files separate and has done this. I'll have to reprint a older file to.see if it dose it.



  • heres my config.g sory i dont know how to put it in a little windown like the others are. i dont see a m556 any were in it
    on a side note i printed a test cube that i had sliced before the problem aroused. the problem is still there.

    the cant is toward the left in the x axis it not angled toward any tower.
    would updating the firmware erase my config and network informations?

    ; Configuration file for Duet WiFi (firmware version 1.20 or newer)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon May 21 2018 14:48:27 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration.
    M665 R162.78 L400.21 B170 H530 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 PBigBen ; Set machine name
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80 Y80 Z80 E2571.42 ; Set steps per mm
    M566 X1200 Y1200 Z1200 E40 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z18000 E1200 ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z1000 E120 ; Set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active high endstops

    ; Z-Probe
    M558 P5 R0.4 H5 F1000 T6000 ; Set Z probe type to effector and the dive height + speeds
    G31 P100 X0 Y0 Z-0.25 ; Set Z probe trigger value, offset and trigger height
    M557 R165 S20 ; Define mesh grid

    ; Heaters
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.06e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.0 I0 F2500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    M501 ; Load saved parameters from non-volatile memory
    T0 ; Select first tool



  • so now im confused. you can see in the pics that the first part that had the problem was bigger then the test cube i just printed. it was a file i sliced a while ago while setting up the printer. the slot is supposed to be straight up not at the angle.
    the test block was a file i sliced a while ago. it has the problem for the first half and then it straightens up. it seems to be most pronounced in x and only slightly in y
    im confused now.

    2_1530139739141_print 3.jpg 1_1530139739141_print 2.jpg 0_1530139739141_pic 1.jpg



  • definitely seems like a mechanical problem. Check for anything loose or shifted.



  • @phaedrux said in Strange x shifting:

    definitely seems like a mechanical problem. Check for anything loose or shifted.

    +1

    Check for a loose belt or pulley.



  • It was I had checked it like 3 times but the 4th showed the y axis pulley was loose.


  • administrators

    @bendiesel really glad you found the issue!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.