Z axis will not move close enough to nozzle to print.



  • I have had this problem for about a month now and have not been able to get it to work. It used to work but doesnt since upgrading to v2.0.

    I will pay anyone $50 via paypal who can help me get this working. I have a Cartesian printer. The bed goes up to meet nozzle.

    My endstop settings are:

    ; Endstops
    M574 X1 Y1 S1 ; Define active high microswitches took out Z1 maybe cant have both-nope

    M558 P1 X0 Y0 Z1 H-3 F320 T5000 R0 ; smart IR Z probe, used for homing Z axis only, dive height 3mm, probe speed 200mm/min, travel speed 5000mm/min, no recovery time
    ;M557 X25:175 Y25:175 S25 ; Define mesh grid

    G31 P500 X0 Y0 Z-3; Set Z probe trigger value, offset and trigger height higher numbers moves bed closer to nozzle-well it used to, now does nothing
    ;G30 ;does move bed up to trigger height* try z-2 or something-didnt home didnt go up

    I have tried as many variations as i can possibly think to no avail.

    BTW i am using S3D. I was able to get it to work with Cura 3.4.0 but there are other problems with Cura. I dont think the slicer should matter.



  • I'm not sure if it will matter because I think for that probe type the firmware will take the absolute value so the negative sign won't matter but I don't think you want a negative value for dive height and trigger height. That would imply that it triggers 3mm below the bed surface. Again, I don't know if it will matter because for probe types where a positive value is expected it will drop the negative sign for you.

    Slightly related, how did you measure your trigger height for the G31? Did you set it to 0 when doing the measurements? Do you have bed compensation active?

    Can you post the first 50 lines or so of a slicer gcode file so we can see what s3d is adding for you? There may be a z offset being applied.

    Just tossing out some ideas. Free of charge.



  • Not sure I understand the problem completely.

    • Are you saying the nozzle refuses to move close to the build surface when commanded to do so?
    • Is the first layer is consistently too thick?
    • Are you able to run a bed probe and see the height map in the web control?

    If it's too thick a layer (and the bed probe is running fine), and always by the same amount then tool (eg G10 P0 X0 Y0 Z0) or probe offsets need checking.

    If can't drive the nozzle close enough then check the limits on the maximum and minimum travel of the axis along with the position of your limits.


  • administrators

    @brian

    Try the following:
    M574 X1 Y1 Z0 S1 ; X endstop at low end, Y endstop at low end, no Z endstop, all active high
    M558 P1 H3 F200 T5000 ; smart IR Z probe,dive height 3mm, probe speed 200mm/min, travel speed 5000mm/min
    G31 X0 Y0 Z3 P500 ; probe off set is X0, Y0 trigger height is 3, threshold is 500

    Note that the X0, Y0 is strange if you are using the IR probe because this is offset from the nozzle. one on of my printer is offset by 30mm on Y for example.

    Also not that the trigger height of 3mm is large for the IR probe. Normally you would aim to mount it closer to the tip of the nozzle. Does yours really trigger 3mm before the nozzle touches the bed? A negative value makes no sense as that would imply you are driving the nozzle 3mm inot the bed before it triggers. A very small negative value can make sense on probe type that rely on the nozzle contact flexing them (such as the smart effector).

    Check out this documentation page on calibrating the z probe trigger height:
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height

    once this is sorted you need to setup your homeZ.g (and the Z parts of homeall.g) to work:
    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z



  • @phaedrux said in Z axis will not move close enough to nozzle to print.:

    I'm not sure if it will matter because I think for that probe type the firmware will take the absolute value so the negative sign won't matter but I don't think you want a negative value for dive height and trigger height. That would imply that it triggers 3mm below the bed surface. Again, I don't know if it will matter because for probe types where a positive value is expected it will drop the negative sign for you.

    Slightly related, how did you measure your trigger height for the G31? Did you set it to 0 when doing the measurements? Do you have bed compensation active?

    Can you post the first 50 lines or so of a slicer gcode file so we can see what s3d is adding for you? There may be a z offset being applied.

    Just tossing out some ideas. Free of charge.

    Thx for you post. I guess i really had no idea what dive height meant, but have some clarification now. I wasnt acutally measuring the trigger height just using trial and error. DC42 's post described how to do that and this time i understood it. I could post the slicer gcode lines but think i'm not the right path for the moment.



  • @t3p3tony said in Z axis will not move close enough to nozzle to print.:

    @brian

    Try the following:
    M574 X1 Y1 Z0 S1 ; X endstop at low end, Y endstop at low end, no Z endstop, all active high
    M558 P1 H3 F200 T5000 ; smart IR Z probe,dive height 3mm, probe speed 200mm/min, travel speed 5000mm/min
    G31 X0 Y0 Z3 P500 ; probe off set is X0, Y0 trigger height is 3, threshold is 500

    Note that the X0, Y0 is strange if you are using the IR probe because this is offset from the nozzle. one on of my printer is offset by 30mm on Y for example.

    Also not that the trigger height of 3mm is large for the IR probe. Normally you would aim to mount it closer to the tip of the nozzle. Does yours really trigger 3mm before the nozzle touches the bed? A negative value makes no sense as that would imply you are driving the nozzle 3mm inot the bed before it triggers. A very small negative value can make sense on probe type that rely on the nozzle contact flexing them (such as the smart effector).

    Check out this documentation page on calibrating the z probe trigger height:
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height

    once this is sorted you need to setup your homeZ.g (and the Z parts of homeall.g) to work:
    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z

    Thx, that has the bed going up to the nozzle now and sometimes past, but thats better. For the past day and a half i couldnt get the bed to go to the same height from one print test to the next. But thanks to another post from DC42 i think i may have that sorted out, cant be sure without more testing.

    In the meantime where do i send the money?


  • administrators

    @brian don't send me me money, just glad you have bought a Duet 😄


  • administrators

    @brian Ok to pick up from the other thread:

    https://forum.duet3d.com/topic/5745/z-axis-wont-stop/10

    @brian said in Z axis wont stop:

    Ok thx, so dive height means the height that probing starts, I can understand that but not sure why it matters and i'm ok with that.

    Using T3P3Tony's suggested endstop settings, (which is the first time homeall from panel due actually works);

    So i homeall via panel due, ran G30 from console and then M114 and got Z3, entered that in config.g for G31 z value. I started a print from where the nozzle was (not homed) and that didnt work, just air printed. So i homed all then started print and that did work. Still printing.

    have you gone through all of the steps here:

    Calibrate the Z probe trigger height

    • Make sure the dynamic test is successful (Z probe stops when it senses the bed) before doing this.
      Use the X and Y jog buttons to position the nozzle over the centre of the bed
    • Jog the nozzle down until it is just touching the bed or just gripping a sheet of paper.
      Send command G92 Z0 to tell the firmware that the head is at Z=0
    • Jog the head up by 5 to 10mm
    • If the Z probe needs to be deployed, deploy it
    • Send command G30 S-1. The nozzle will descend or the bed rise until the probe triggers and the Z height at which the probe stopped will be reported. If you are using a nozzle-contact Z probe, the trigger height will be slightly negative. For any other type of Z probe where the probe triggers before the nozzle contacts the bed, it will be positive.
    • Repeat from step 5 two or three times to make sure that the trigger height is consistent.
      In Duet Web Control, go to Settings -> System Editor and edit the config.g file. Set the Z parameter in the G31 command to the trigger height that was reported. Save the file.


  • @t3p3tony said in Z axis will not move close enough to nozzle to print.:

    If the Z probe needs to be deployed, deploy it

    I dont understand this;

    "If the Z probe needs to be deployed, deploy it"

    I've gone thru the steps all other steps as described.

    I also discovered something that may have been hindering my progress and that is; sometimes the probe didnt fire and for unknown reasons my hand passed under the glass bed directly under the probe and it fired. I repeated that several times to be sure it was happening. So i've now placed tape under the glass to ensure it fires consistently, i probably should put the tape on top of the glass.

    Continuing testing today. Thanks for all the help, feeling encouraged again.


  • administrators

    @brian some z probes are manually deployed, or deployed by a sequence of moves to flick the probe down.

    As you are using an IR probe this does not apply.

    You do need a consistent surface for the IR probe to trigger reliably see:
    https://duet3d.dozuki.com/Wiki/Choosing_a_Z_probe

    Transparent surfaces (glass, PEI etc.) must be backed with a matt black surface. See https://miscsolutions.wordpress.com/mini-height-sensor-board/

    See the "bed surface" section of https://miscsolutions.wordpress.com/mini-height-sensor-board/



  • @t3p3tony I think there is a step missing in the calibrate the Z probe trigger height.

    I followed the steps over and over again and the bed kept stopping at a distance too far from the nozzle. Then it occurred to me that the z value in the config.g file may be adding to the value the duet was reporting. So i set that value to 0 and then the bed when all the way up and too far. So then i used trial and error in the config file to get it just right. It took many tries but at last count it worked right. Final value so far is 2.87.



  • That's a good catch. The documentation assumes it's at 0 because it hasn't been measured yet but doesn't explicitly say to set it at 0.

    There is a guide linked at the bottom of the documentation that goes into detail for setting up a BLTouch. The instructions for measuring the trigger height there are a bit more detailed.

    It may also be a good idea to disable any mesh grid compensation first as well. I'm not sure if it's ignored for g30 s-1 or not.


  • administrators

    @brian good spot. I have added another step in the documentation. Thanks!


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.