USB connection failed

  • I have a Duet3D wifi, I'm still at the first establishment. Could connect with the web interface already, and make adjustments. The wifi connection always breaks off. The distance to the router is about 2 meters.
    I have a 24V power supply. Wanted the device to perform Duet3d via USB again, I plugged in the USB cable, I wanted to connect via USB with the Duet3D. When I wanted to make the connection, the Duet3d has started to flash about every 4 seconds a flash. I immediately pulled out the plug, then it smelled of burned electronics. Visually, I can not see any harm. Now I get no connection to the Duet3D not via USB or via wifi.
    In the device manager of Windows, the Duet3D is no longer recognized.
    Can you help me?

  • administrators

    @urba its sounds like something in the wiring had caused the wrong voltage to get to the wrong place on the duet board.

    initially you setup the duet using USB and got WIFI working correct?

    Once that was working you then powered the Duet by 24V?

    While the duet was connected to 24V you plugged in USB and something flashed (what?)

    With the Duet connected to USB and nothing else (no endstops, or anything else plugged in other than the USB cable) and you press the erase button does the Duet show up as a "bossa programming port" or "unknown device"?

  • Thank you for your quick reply.
    Yes, I have set up the Duet with USB the WIFI has worked.

    Then I operated it with 24V. Everything worked fine, I could drive with the axles, switch the heating on and off, the end stops have already worked.

    Only the WIFI had broken off, had to reconnect again and again.

    I did not see exactly what was flashed, turned it off because of fear of destroying it. I know this is not exactly helpful information for you.

    I've now removed all the cables after your tip and only plugged in the USB cable, pressed the erase button.

    In the device manager of Windows, no new device is displayed, nothing new is displayed. Have already used another USB cable and another USB port.

    The 3V, LED and the LED between the reset button and the USB connector are on, the 3.3V LED is off!

  • No one has an idea that can help me, would be great

  • administrators

    It looks like the 3.3V supply is not present. Are any of the ICs or the WiFi module on the Duet getting hot?

  • No, nothing gets hot.

  • administrators

    Have you disconnected everything from the Duet except USB?

  • Yes, I have everything except USB disconnected from the Duet.

  • administrators

    In that case we would need to examine your board to see what is wrong with it and whether it can be repaired economically.

  • Ok, where should i send the board?

  • administrators

    Please make a warranty claim from whoever you purchased the Duet from. If you purchased it direct from then see

    Also see the notes about USB ground loops at

Log in to reply