loud Z and inaccurate prints - proofread?



  • I think I'm missing something. Dual Z on my machine is constantly going out of sync, so I put them back on the series setup recommended online. Unfortunately, that makes the top speed of Z lower and Z moves much louder. The rest of the unit is pretty silent, but Z homing groans very loudly.

    Additionally, I've never been able to print off this board mechanically accurate parts. If I print something that's supposed to fit together, like squares, they are always off. No matter what material I use, it is always off. When I adjust the steps per mm settings, it helps a bit, but it's never consistent. It seems worse with longer prints.

    I know I have a mechanical problem with the current setup, but this problem predates it and it just needs me to reprint the X carriage.

    I'm reasonably certain this is a problem with config. So I need someone to proofread my config.g file.

    ; Configuration file for Duet WiFi (firmware version 1.17 to 1.19)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Thu Nov 09 2017 17:18:35 GMT-0500 (EST)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X220 Y250 Z235 S0 ; Set axis maxima

    ; Endstops
    M574 Z0 S0; Define active low and unused microswitches
    M574 X1 Y1 S1 ; Define active high microswitches
    M558 P1 X0 Y0 Z1 H5 F800 T6000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P500 X-15.2 Y26.00 Z3.4 ; Set Z probe trigger value, offset and trigger height
    M557 X15:213 Y15:239 S20 ; Define mesh grid

    ; Drives
    M569 P0 S1 D3 ; Drive 0 goes forwards (X)
    M569 P1 S1 D3 ; Drive 1 goes forwards (Y)
    M569 P2 S1 D0 ; Drive 2 goes forwards (Z)
    M569 P3 S0 D3 ; Drive 3 goes backwards (E0)

    M671 X-34:53 Y118:118 S0.5 ; leadscrews at rear left, front middle and rear right

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X79.4 Y79 Z800 E836 ; Set steps per mm
    M566 X300 Y300 Z12 E100 ; Set maximum instantaneous speed changes (mm/min) (old value: x/y:900 e:100 E120)
    M203 X12000 Y12000 Z1000 E3000 ; Set maximum speeds (mm/min) (old value E:1200)
    M201 X500 Y500 Z300 E250 ; Set accelerations (mm/s^2) (old values: X600 y250 z200|500)
    M906 X1300 Y1300 Z1300 E1300 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S270 ; Set maximum heater temperature to 270C
    M301 H0 S1.00 P10 I0.1 D200 T0.4 W180 B30 ; Use PID on bed heater (may require further tuning)
    M305 P0 T100000 B3950 C0 R4700 ; bed thermistor
    M305 P1 B4725 C7.06e-8 ; standard e3d cartridge

    ; Tools
    M563 P0 D0 H1 F2 ; Define tool 0, fan 2
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Network
    M550 PWheatley ; Set machine name
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Fans
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool


  • administrators

    What is the specification of your Z motors? If they are low current high inductance motors and you are using 12V power, then instead of connecting them in series, it would be better to connect them either in parallel or to separate drivers outputs.



  • If Z homing "groans" the mechanism may be out of alignment- guide rails not parallel, screws not parallel to rails, etc. That could cause missed steps and further misalignment (tilting of bed/X axis). I'd start by trying to fix that. Does the bed go up and down or the X axis? Can you post a picture of the machine?

    When you say parts don't fit together, why don't they fit? Are the parts out of square? Are the dimensions wrong? Are the parts printed at the center of the bed or off to one side?

    Do you have a caliper? You can check for squareness of the axes by printing a largish cube (try 100 mm on each side) and measuring the diagonals in each plane (XY, XZ, YZ). If the diagonals match, the axes are square. If the dimensions don't match the STL dimensions, you can tweak the steps/mm settings, assuming the mechanism is not binding and causing missed steps anywhere.



  • @mrehorstdmd I just rebuilt the printer last night. New bearings on two of the axis and a new carriage (which also cracked and will need reprinted a little wider, not bitter at all, nope nope). It's definitely square. I moved them from separate drivers to the series setup in an attempt to resolve that sync issue. I originally kept them separate expecting to set up some sort of software Z compensation (each side independently adjusting itself to get it even before a print) before I realized that wasn't possible.

    To give you a better idea of what I'm dealing with, here's a video of the machine homing.
    https://www.youtube.com/watch?v=LIGY_Yzr_6k

    I set D0 for that drive since it was the quietest I tested.


  • administrators

    @mentaluproar said in loud Z and inaccurate prints - proofread?:

    . I originally kept them separate expecting to set up some sort of software Z compensation (each side independently adjusting itself to get it even before a print) before I realized that wasn't possible

    I'f you have a Z probe setup this is possible:

    https://duet3d.dozuki.com/Wiki/Bed_levelling_using_multiple_independent_Z_motors

    Of course for a complete plane to be level you need 3 motors, but two can be adjusted to remain level with each other.



  • That sounds like a mechanical resonance- which may be characteristic of the motor at this speed, current, and load, or maybe the motor vibrations are exciting something else into ringing. Mechanical resonances can cause motors to skip steps. Try putting your fingers on different parts of the machine (if you can do it safely) while it's running. You'll probably feel the vibration, and then your finger will damp the ringing and it will suddenly get quieter. Check the side panels, the top, bottom, and back covers, guide rails, bed plate, bed support plate, etc. Or you can try changing the homing speed up or down to move the motor vibration frequency away from the resonance.


  • administrators

    @mentaluproar said in loud Z and inaccurate prints - proofread?:

    M92 X79.4 Y79 Z800 E836 ; Set steps per mm
    M566 X300 Y300 Z12 E100 ; Set maximum instantaneous speed changes (mm/min) (old value: x/y:900 e:100 E120)
    M203 X12000 Y12000 Z1000 E3000 ; Set maximum speeds (mm/min) (old value E:1200)
    M201 X500 Y500 Z300 E250 ; Set accelerations (mm/s^2) (old values: X600 y250 z200|500)

    If they are getting out of sync while the machine is running (not just when you power it off and on again) then you probably have the Z speed and acceleration configured too high. Try Z500 in your M203 command and Z100 in M201.



  • @t3p3tony said in loud Z and inaccurate prints - proofread?:

    Of course for a complete plane to be lev

    Something still sounds off but it's so much quieter, I'm calling this a win.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.