Z-offset is very high



  • Hi,

    I got a the v1.2 from precision piezo uk as endstop.

    I use:
    M558 P8 I1 R0.4 F300 Z1

    My homez.g:

    G91 ; relative mode
    G1 Z4 F400 ; lowers bed 4mm to avoid dragging nozzle over the bed
    G90 ; back to absolute mode
    G1 X200 Y180 F4000 ; Move probe to middle of bed
    G30 ; probe
    G91 ; relative mode
    G1 Z4 F150 ; move slowly 4mm in the +Z direction
    G90 ; back to absolute mode
    G30 ; probe
    G1 Z2.5 F150 ;Move Z to 2.5 above the bed
    ;G31 X0 Y0 Z-0.15
    G90 ;back to absolute
    ; G1 X0 F4000 ;move to X0

    The probe is very nice and I use a high sensetive.

    When do "G1 Z0" the nozzle goes a little bit into the bed.
    When I do G30 the carriage is not moved when the nozzle touches the bed.

    Why G30 and G1 Z0 differs so much?
    If I want to correct that, I need a very high negative offset or?


  • Moderator

    G30 uses the values from M558 and will tell the system where z0 is, G1 will not.

    Have you calibrated the zprobe trigger offset? https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe#Section_Calibrate_the_Z_probe_trigger_height

    What does the G31 command look like in your config.g?



  • With G30 I do my Z-Probe right?

    M558 P8 I1 R0.4 F300 Z1
    means: If the piezo gets triggered, there is Z0, right?


  • Moderator

    That is correct, but you first need to tell the system where the nozzle is in relation to the bed when the probe triggers using G31 Zn. In the case of the piezo probe Zn is a slightly negative value normally, but you can't be sure until you do a trigger height calibration as described in the link I posted.



  • I did all in your link, it comes -0.14. and I got it in my homez.g "G31 X0 Y0 Z-0.14", not in my config.g. (Like before).Of course I always do a G28 so it is set always.



  • Do I need G92 with piezo? In normal case, everytime when the piezo is triggered, something between 0,05 and 0,15mm over the triggerpoint is Z0 or? Maybe my error is depending on my other thread, that G31 is always 0. The offset is ignored I think


  • Moderator

    @hevilp said in Z-offset is very high:

    G31 X0 Y0 Z-0.14

    This should be in your config.g



  • @phaedrux said in Z-offset is very high:

    G31 X0 Y0 Z-0.14

    Okay, I will move it, if I set it manually, even for X or Y, it always reports 0. I just updated to the latest firmware, and there is it always 0, too.


  • Moderator

    @hevilp See your other thread for why it reports 0.

    If you send G31 T8 it will report the current settings.


Log in to reply