Cannot reach web interface



  • I am having trouble reaching the web control interface on chrome. I have been following This guide and when I get to step 8 everything seems to be running the same, yet I cannot access the web interface. Please help. I am using a duet ethernet v3 with firmware version 1.21 installed. Here is what the sd card looks like when opened:0_1533831576654_sd card.PNG

    Here is the inside of www:0_1533831604145_www.PNG

    Here is the inside of sys:0_1533831620581_sys.PNG

    And here is my config.g file:0_1533831670372_config.PNG



  • I used this program to get mine working! https://configurator.reprapfirmware.org/
    It makes a zip file and you load it to your desktop. load on a SD card and try.



  • My printer specs are incompatible with this program



  • @brmatt I have the Wifi version and just trying to help. O Well. good luck!



  • @ngwpower Thank you! Yeah i tried that a little bit ago to see if i could skip the web control but unfortunately no dice



  • @brmatt I had an issue with this as well. The only fix I could could find to make it work, was to place a copy of the DuetWifiControl folder in the sys folder and another copy renamed www. I also had to the do the same on the SD card outside of the sys folder.

    Example
    SD CARD/www
    SD CARD/DuetWifiControl
    SD CARD/sys/www
    SD CARD/sys/DuetWifiControl

    If I delete any of them, I don't have any control either. I was under the assumption, that you were only suppose to need a www folder in the sys folder, maybe @dc42 can clarify. Also I am using 1.19.2 firmware & 1.19.3 wifiserver firmware. I don't know why but the blue light on the board for the Wifi doesn't turn on with that firmware, but it does for 1.21.



  • Interesting. I'll give that a try. Seems a bit odd so hopefully @dc42 can clarify as you said. Thanks for the tip


  • administrators

    Looks like your config.g file still contains the following line:

    M552 P192.168.1.14

    As indicated in the comment line before that one, you should replace the IP address (192.168.1.14) with an IP address that will work with your router. Or you can use 0.0.0.0 and it will ask the router for an IP address, but then you will have to find out what IP address has been assigned, either from the router or by sending M552 from USB or PanelDue.



  • @dc42 It worked! I'm finally in! Thank you.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.