Stepper motors are super noisy... wrong config?



  • HI, I bought a DuetWifi2 some days ago and run into some issues with handling my stepper motors.

    My stepper configuration is like this:

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 S3 ; Configure microstepping with interpolation
    M92 X80.8865 Y80.8865 Z793.65 E94.25 ; Set steps per mm
    M566 X900 Y900 Z12 E120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z200 E1200 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z200 E250 ; Set accelerations (mm/s^2)
    M906 X700 Y700 Z1000 E700 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    But they are incredible noisy... even if I run them super slo, they are super noisy. Is there anything I made wrong? Before I run KLIPPER and they where very quite (with some 2208er in Spreadcycle). Special X and Y on my CoreXY. I mean not an high pitch noise, I mean a very rough sound...

    I use this steppers: ACT NEMA17 1.3A

    My Board is powered by 24V. Running the latest Firmware release.

    Thanks for help!



  • @stefanme said in Stepper motors are super noisy... wrong config?:

    M350 X16 Y16 Z16 E16 I1 S3 ; Configure microstepping with interpolation

    I may be wrong but maybe the S3 in the M350 line shouldn't be there.

    Duet 2 Wifi/Ethernet supports modes 0, 1 and 2



  • Ahhhhh So the Duet2 doesn't support STEALTHCHOP? Really...? Thats sad!



  • I think you'll find that with 16 interpolated to 256 you won't need it.

    https://duet3d.dozuki.com/Wiki/GCode#Section_M350_Set_microstepping_mode

    Snn Set chopper mode: 0 = constant off time, 1 = random off time, 2 = spread cycle, 3 - stealth chop. the Duet 2 Wifi/Ethernet supports modes 0, 1 and 2. The Duet 2 Maestro supports modes 2 and 3. If this parameter is not provided, the default will be used.



  • @phaedrux said in Stepper motors are super noisy... wrong config?:

    256

    Thanks, but for the interpolation I already set:

    M350 X16 Y16 Z16 E16 I1 S3 ; Configure microstepping with interpolation

    I1 = Inn Enable (nn=1) or disable (nn=0) microstep interpolation mode for the specified drivers, if they support it. The Duet 2 WiFi/Ethernet support interpolation (to x256 microstepping) only when configured for x16 microstepping. The Duet 2 Maestro supports interpolation at all microstep settings.

    The Printer is still moving super rough... sound like there are some loose parts on my printer, but there aren't.



  • Have you tried without the S3?



  • This post is deleted!


  • Yes I did... no difference. I also deactivated now I1. No Difference in the sound. Everything sounds like the same. Or close to the same. Do I have to set I to 0 or is he loading the default if I didn't write it in the config?



  • You can send M350 to the console with no parameters and the system will report back the current settings.

    If you disconnect the motors from the belts do they still sound rough when moving?



  • 8:29:18 PMM350
    Microstepping - X:16(on), Y:16(on), Z:16(on), E:16(on):16(on)

    Looks good.

    Here is a video. The sound is super rough. If I run with KLIPPER its much more silent (TMC2208 Spreadcycle... should be very similar to the 2660 on the duet2). In real live it sounds even more rough.

    Even when I remove the belts, the motors are much to loud. Without belts, they must be super silent.

    https://youtu.be/p51pXD23cyE


  • administrators

    @stefanme said in Stepper motors are super noisy... wrong config?:

    Ahhhhh So the Duet2 doesn't support STEALTHCHOP? Really...? Thats sad!

    Stealthchop on TMC2130 drivers is reported to be fairly useless because it only works at low speeds and causes problems at high speeds. Stealthchop2 as supported on the TMC2208/2224/5130 is supposed to be better, but on my Duet 2 Maestro (TMC2224 drivers) with the motors in my Cartesian printer, I find spreadCycle gives better acceleration without losing steps and is just as quiet. With some other motors, stealthChop2 is reported to be quieter.


  • administrators

    @stefanme said in Stepper motors are super noisy... wrong config?:

    Yes I did... no difference. I also deactivated now I1. No Difference in the sound. Everything sounds like the same. Or close to the same. Do I have to set I to 0 or is he loading the default if I didn't write it in the config?

    That's most unusual. With the default x16 microstepping, interpolation to x256 and spreadCycle mode, the motors should be very quiet. A few users have issue with the motors ot being silent at standstill, and that can often be improved by adjusting the driver off-time.

    Are you using motors with a very low rated current?

    Please run M569 P0 (and P1, and P2) and M350 with no parameters, to verify that you really are using spread cycle mode and x16 microstepping with interpolation.



  • This post is deleted!


  • @dc42 said in Stepper motors are super noisy... wrong config?:

    M569 P0

    I use this motors: ACT NEMA 17 1.3A

    M569 P0
    Drive 0 runs forwards, active low enable, step timing 0.0:0.0:0.0:0.0 us, mode spreadCycle, ccr 0x101b4
    M569 P1
    Drive 1 runs forwards, active low enable, step timing 0.0:0.0:0.0:0.0 us, mode spreadCycle, ccr 0x101b4
    M569 P2
    Drive 2 runs forwards, active low enable, step timing 0.0:0.0:0.0:0.0 us, mode spreadCycle, ccr 0x101b4
    M350
    Microstepping - X:16(on), Y:16(on), Z:16(on), E:16(on):16(on)



  • I don't know enough about motor and driver interaction but it would appear you may have found a motor that does not like the way the duet drivers work.

    As an experiment do you have other motors you could connect to the duet to see how they sound? If they sound better it would indicate the pairing of motor to driver is to blame. If they sound just as bad it might indicate something being wrong with your board.



  • I too have the same exact sound in my CoreXY (compared to 2160 from Replicape which was much quieter).
    My solution was to raise the motors, do a "box" with a 5mm shaft and pulley with 2 bearings and motor using a coupler to connect. The motor itself is attached to the case through a "astrosyn" mount, so the vibration is highly reduced.
    Another advantage is that the belt tension does not pull on motor top bearing.

    And yes, it is ugly.

    LE: I was having the same sound with both 1.8 deg motors and current 0.9 deg ones


  • administrators

    @stefanme said in Stepper motors are super noisy... wrong config?:

    @dc42 said in Stepper motors are super noisy... wrong config?:

    M569 P0

    I use this motors: ACT NEMA 17 1.3A

    M569 P0
    Drive 0 runs forwards, active low enable, step timing 0.0:0.0:0.0:0.0 us, mode spreadCycle, ccr 0x101b4
    M569 P1
    Drive 1 runs forwards, active low enable, step timing 0.0:0.0:0.0:0.0 us, mode spreadCycle, ccr 0x101b4
    M569 P2
    Drive 2 runs forwards, active low enable, step timing 0.0:0.0:0.0:0.0 us, mode spreadCycle, ccr 0x101b4
    M350
    Microstepping - X:16(on), Y:16(on), Z:16(on), E:16(on):16(on)

    Thanks for checking. Are the motors noisy when idle, or only when moving?

    Those motors have higher inductance than most but should be OK, especially as you are using 24V power.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.