Tips for adjusting Precision Piezo Orion



  • Hi,

    I am trying to setup Precision Piezo Onion (PPO) in a Duet 2 board... But i am having issues with fine tuning.

    Things that DO work:

    • Duet decides the PPO correctly, I have tried to configure it as digital or analog. Both work. What do you recommend?

    • PPO, detects when something touches the Nozzle, I approach an object to it in an energetic way.

    Things that DO NOT work:

    • PPO (this is mounted on a Duet Board), the calibration begins, and some points it does well, after touching the bed gently, it detects it and goes to the next point. But other points, it seems that it does not do us so well, the touch with the bed is much more "strong", even though it seems that the calibration manages to finish it.

    • The problems come when I try to do the "BED COMPENSATION" in which you have to take the height of many points. Some points take them well, others the touch is stronger, and at a given time, after about 20 points, stops taking.

    I have watched videos of YOUTUBE, and it seems that PPO should have a screw to adjust the sensitivity, but the installed one does not take it, and the one that I am going to send you, that I did not think about opening it, but I have opened it to see if it had the screw, it does not wear either. So, what ... How do I adjust the sensitivity without this screw?



  • PS: it's "Orion" not "Onion"(which translates to "cebolla" in spanish) 🙂 😉



  • have you looked at this.
    https://docs.wixstatic.com/ugd/e08222_ae707c20a0cf418b8393b44368370576.pdf
    there is a potmeter for adjusting sensitivity..However I never touched it and I use digital.The touch is very gentle. What is you configuration.maybe reduce the speed at which it decends



  • Seems I got the same problem



  • Me too!...…………………..



  • Can you please describe the problem you are having?

    Idris



  • @Moriquendi

    Please watch my other thread.

    I described it there. If you need more Informations, please ask me.



  • Hi guys.
    Just installed my Duet Maestro. I was Ramps before this and truly not 100% sure on what I am doing. Little bit of a learning curve so to say.
    What did you guys select when you were defining the Orion? Switch/Unmodulated/simple Ultrasonic etc...
    And for the Endstop Configuration, Active high, active low, z-Probe??
    Sorry for the noobs question but I am am a loss.



  • @hevilp Can you please see my questions below. Thanks brother!!



  • @cabal2000

    Please take a look at the other thread, piezo reference. There is all you need.

    You need

    M558 P8 I1 R0.6 F300 Z1

    Z1 is because Im using this as endstop.

    Just do it with the command, its better to understand with the command instead over the
    Gui.



  • @hevilp said in Tips for adjusting Precision Piezo Onion:

    M558 P8 I1 R0.6 F300 Z1

    This is what I have at present.
    ; Endstops
    M558 P1 I1 R1 F300 A3 X0 Y0 Z0
    M574 X1 Y1 Z0 S0

    ; Z-Probe
    G31 X150 Y150 Z0 P100
    M558 P8 I1 R0.6 F300 Z1

    I am guessing I have something configured wrong.



  • Try

    This is what I have at present.
    ; Endstops
    M574 X1 Y1 Z0 S0

    ; Z-Probe
    G31 Z0 P100
    M558 P8 I1 R0.6 F300 Z1



  • @hevilp said in Tips for adjusting Precision Piezo Onion:

    M574 X1 Y1 Z0 S0

    G28
    Error: G0/G1: insufficient axes homed



  • Das something to setup, what style is your printer?

    You need to Home first X and Y and last Z.

    In the beginning dont use G28 only,

    Use G28 X
    Then G28 Y
    Then G28 Z

    Before you do, tell the printer style and where are the Endstops



  • @hevilp
    Core XY.

    G28 Z
    Error: G0/G1: insufficient axes homed



  • Okay:

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops
    M574 Z1 S2 ; Define Z to use Probe. Home to Min

    ; Z Probe
    M558 P8 I1 R0.6 F300 Z1



  • @hevilp
    Nope!!
    I only have it connected to the z-stop switch. This is correct right?
    And also, which is the correct one i should clicked on Switch/Unmodulated/simple Ultrasonic etc...?



  • No it comes to the z Probe connection, not the end stop z

    Take a look at the wiring guide from duet for your Board



  • @hevilp
    Will that makes more sense!! OK, 5v or 3.3v and Z-Probe_mod I am guessing!!



  • I dont know your Board, but piezo can do 5v yes



  • @hevilp
    I think I have that figured out BUT for some reason the z is not going up.



  • I'm do not know the Maestro but...

    To use the Orion as the Z-endstop and the Z-probe it must be connected to the Z-probe connector. As @hevilp says, your M558 should be...

    M558 P8 (mode 8, digital, unfiltered) I1 (inverted, active low) R0.6 (wait 0.6s before Z-probe) F300 (probe at 5mm/s) Z1 (probe from 1mm z-height)

    M558 P8 I1 R0.6 F300 Z1

    Did you use the Duet online configurator?

    I'm on holiday at the moment so I don't have access to my printer to check your config against mine.

    Idris



  • @moriquendi So, do I just change the one line or take everything out I just add this line. Sorry for such noobs questions, very very new to Duet boards. And yes i did use the Duet online configurator. I used the "Switch" setting. And set all the endstops to Low End. Z to Z-Probe.



  • @cabal2000 Just change that line in your config.g

    Here's the relevant part of my config.g

    ; Endstops
    M574 X1 Y1 S0 ; Set active low endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P8 I1 H2 R0.5 F300 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 X0 Y0 Z0 ; Set Z probe trigger value, offset and trigger height

    The important parts are:

    M574 X1 Y1 S0 ; X and Y endstops active low.

    M574 Z1 S2 ; Z-endstop active low, controlled by Z-probe.

    Do you have these lines in your config.g?

    Idris



  • @moriquendi
    What do you have in your homez?


Log in to reply